none
XBOX: the token resolver is unable to resolve the security key reference

    Question

  • We are having issues with the xbox authentication service, when the authentication token it’s send to the “/getclaims” services this shows the following error:

     The server encountered an error processing the request. The exception message is 'The token resolver is unable to resolve the security key reference 'X509ThumbprintKeyIdentifierClause(Hash = 0xFB3A55DCB0F5299645617C3BA9F6EC721637B489)'.'. See server logs for more details. The exception stack trace is:

    at Microsoft.XboxLive.Auth.Protocol.XblAuthorizationPolicy.Evaluate(EvaluationContext evaluationContext, Object& state) at System.IdentityModel.SecurityUtils.CreateDefaultAuthorizationContext(IList`1 authorizationPolicies) at System.ServiceModel.ServiceSecurityContext.get_AuthorizationContext() at System.ServiceModel.Dispatcher.SecurityImpersonationBehavior.GetCustomPrincipal(ServiceSecurityContext securityContext) at System.ServiceModel.Dispatcher.SecurityImpersonationBehavior.SetCurrentThreadPrincipal(ServiceSecurityContext securityContext, Boolean& isThreadPrincipalSet) at System.ServiceModel.Dispatcher.SecurityImpersonationBehavior.StartImpersonation(MessageRpc& rpc, IDisposable& impersonationContext, IPrincipal& originalPrincipal, Boolean& isThreadPrincipalSet) at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc& rpc) at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)

    This issue started when the SSL certificate for our SSO server for XBOX expired: xbox.foxplay.com

    We renewed the certificate but apparently our server is not authorized on XBOX servers.

    After doing this we uploaded the certificate to our XDP account and published.

    But the error is still present after following all the steps.

    It fails every time and the result is exactly the same each time

    Wednesday, September 02, 2015 4:19 PM

Answers

All replies

  • Your issue appears to be unrelated to .NET Framework setup (this forum's topic), but I do not know where you should ask. If nobody else directs you to an appropriate forum, you can ask here:

    https://social.msdn.microsoft.com/Forums/en-US/whatforum/threads

    Wednesday, September 02, 2015 11:49 PM
  • @LAPTV LLC,

    I've moved your case to "Where is the forum for". Actually your issue seems like an end user question. Maybe some XBOX support forum will better.

    Best regards,

    Barry


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, September 03, 2015 7:15 AM
  • Hi,

    The xbox forums live on their own site:

    http://forums.xbox.com/

    Good luck.


    Thursday, September 03, 2015 11:29 AM
  • Hi Mike,

    I know that your post is 2 years old but I have the same issue with my servers. Did you find a solution ?

    Thank you

    Alex

    Sunday, May 21, 2017 8:46 AM
  • Hi Mike,

    I know that your post is 2 years old but I have the same issue with my servers. Did you find a solution ?

    Thank you

    Alex

    This is "where is" forum for direction on where best to ask questions. Xbox forums are over here.

    http://www.xbox.com/en-US/forums

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    Sunday, May 21, 2017 12:29 PM
    Moderator