locked
Outlook 2007, CRM 3.0, cannot connect problem RRS feed

  • Question

  • Hi all,

    I really hope someone can help here.  I have crm client verson 3.0.5745.0 installed and I did not receive any errors during install (except the indexing service warning).

    I can open IE7 and type in http://crmweb and it works no problem.  However when we start Outlook, we are immediately provided with a login dialog box and no matter what combination of login/domain/password that we use, I cannot get it to connect.

    All the icons are present and are showing in outlook but access any of them and you get a IE window and a contact you admin error, the CRM icon is in the taskbar area so everything seems ok.

    Can anyone provide any steps to try and resolve this, it is very important for our business.

    TIA

    irishtoon
    Tuesday, July 28, 2009 2:25 PM

Answers

  • Ensure the user does not have any stored passwords

    Control Panel
    User Accounts
    Advanced
    Manage Passwords

    You could also uninstall the client and install it using the CRM IP address and see if that makes a difference.  It has been awhile since I dealt with 3.0 so I've forgotten many of the tips and tricks.  Best idea is for the client to upgrade but I understand that is not always possible.

    Is there any type of error logged in the user's event viewer?


    Here is what one user posted, but I doubt it is supported so I am not necassarily recommending it.  However, it might provide some insight:

    I had an issue once at a client like this. Turned out there was an AD issue causing kerberos problems.
    To workaround it until that was solved (got an AD specialist out to help) I disabled IIS from doing kerberos authentication using the IIS admin script (in <system drive>:\Inetpub\AdminScripts) and running these two commands

    adsutil.vbs SET W3SVC\NTAuthenticationProvider "NTLM"
    adsutil.vbs SET W3SVC\<MSCRM Site ID>\NTAuthenticationProvider "NTLM"

    You can get the site ID in IIS under websites. To put it back to the way it was run

    adsutil.vbs SET W3SVC\NTAuthenticationProvider "Negotiate,NTLM"
    adsutil.vbs SET W3SVC\<MSCRM Site ID>\NTAuthenticationProvider



    Best Regards, Donna
    • Marked as answer by Jim Glass Jr Monday, August 10, 2009 2:55 PM
    Tuesday, July 28, 2009 7:52 PM

All replies

  • Try placing the CRM URL in the Intranet Trusted zones.  Also put the URL IP address in the same zone.

    Take a look at the Event Viewer on the user machine and see if an error message was logged.  You can also turn Dev Errors on to see if you receive a better error message.

    You can turn on Dev Errors by changing the setting in the web.config file located in the root folder for crm web site (you may need to reset IIS after the change) or download the diag tool for CRM 3 and use it.
    Best Regards, Donna
    Tuesday, July 28, 2009 5:38 PM
  • Thanks Donna,

    I've added to the trusted zones, I will check the IP address and see does this help.

    The dev error change has been implemented but no better results on the error. I believe it's purely an authentication thing as the problem exists on an XP and a vista machine.

    I downloaded the tool but it crashed as it fails when it cannot find the cisvc service which it won't on vista.

    Any more ideas?

    Regards,

    Irishtoon
    Tuesday, July 28, 2009 7:36 PM
  • Ensure the user does not have any stored passwords

    Control Panel
    User Accounts
    Advanced
    Manage Passwords

    You could also uninstall the client and install it using the CRM IP address and see if that makes a difference.  It has been awhile since I dealt with 3.0 so I've forgotten many of the tips and tricks.  Best idea is for the client to upgrade but I understand that is not always possible.

    Is there any type of error logged in the user's event viewer?


    Here is what one user posted, but I doubt it is supported so I am not necassarily recommending it.  However, it might provide some insight:

    I had an issue once at a client like this. Turned out there was an AD issue causing kerberos problems.
    To workaround it until that was solved (got an AD specialist out to help) I disabled IIS from doing kerberos authentication using the IIS admin script (in <system drive>:\Inetpub\AdminScripts) and running these two commands

    adsutil.vbs SET W3SVC\NTAuthenticationProvider "NTLM"
    adsutil.vbs SET W3SVC\<MSCRM Site ID>\NTAuthenticationProvider "NTLM"

    You can get the site ID in IIS under websites. To put it back to the way it was run

    adsutil.vbs SET W3SVC\NTAuthenticationProvider "Negotiate,NTLM"
    adsutil.vbs SET W3SVC\<MSCRM Site ID>\NTAuthenticationProvider



    Best Regards, Donna
    • Marked as answer by Jim Glass Jr Monday, August 10, 2009 2:55 PM
    Tuesday, July 28, 2009 7:52 PM
  • what rollup have you installed?
    Tiaan van Niekerk http://crmdelacreme.blogspot.com Skype:tiaan.van.niekerk1
    Monday, August 3, 2009 8:55 AM