locked
WHS Consuming 1.6TB that isn't there!? RRS feed

  • Question

  • This is really perplexing me. I had a 2TB drive that was failing, transfer speeeds wouldn't exceed ~1.6MB/s, and had errors noted by crystaldisk info and chkdisk. So I removed the drive (took 3 days because of transfer rate). I figured safer to do that than just pull the drive even though I had folder duplication enabled, plus it would take a few days to get the RMA drive anyhow. Unfortunately the RMA drive was advance format when original wasn't, but that's another story.

    After I removed the failing drive, two of my remaining three storage drives were around 90% full, the other about 75%. I then installed the new hard drive. I did a manual database repair and cleanup just to make sure everything was ok. Repair found errors with two of my four PC's backups and lost all the PC backups for those two machines. :( Then about a day later is when I noticed the huge "System" file size of 2.2TB!!!

    After doing some web searching, I found that it could be shadow copies. I ran the vssadmin tool and there was nothing of significance there but ran the "vssadamin delete shadows /all" and checked the reg entry for it and it was disabled as it should have been. Then I read about if drives get quite full then some funny things can happen, so I disabled file sharing and then turned off PC backups, and then did a manual run of database repair and then database cleanup, thinking maybe there was something with duplication or full drives. Well that 2.2TB went down to 1.6TB.

    I ran Treesize Free (which shows folder sizes) and it didn't show anything but the 1.1TB for shares and 476GB for PC backups. No indication of this phantom 1.6TB. See Treesize Free snapshot here: http://img152.imageshack.us/img152/8122/whstreesizefreed.jpg

    Not sure where to go from here.

    My WHS consists of the following drives and Disk management reports each as following:

    Disk 0: 1863 GB 34% full = 633GB
    Disk 1: 1863 GB 74% full = 1379GB
    Disk 2: 963 GB 2% full (system drive)
    Disk 3: 1863 GB 52% full = 969GB
    Disk 4: 1863 GB 8% full (new drive) = 149GB

    That makes total consumption = 3130GB when it should only be about half that.

    Screenshot can be seen here: http://img267.imageshack.us/img267/5980/whsdiskmgtdiskdistribut.jpg

    Server Storage on the Pie Chart indicates:

    Shared Folders: 1.1 TB
    PC Backups: 471 GB
    System: 1.6 TB (!!!)
    Free Space: 5.1 TB

    Screenshot can be seen here: http://img89.imageshack.us/img89/8810/whsserverstoragesystem1.jpg

    Any ideas, suggestions? IIRC that system size used to be really small, like less than 100MB at any given time.

    Could it just take a while for these files to disappear or what? It's been over 24 hours, or do I have to let DE do it's magic over a longer period?

    Thursday, January 6, 2011 4:02 PM

All replies

  • I checked this thread: http://social.microsoft.com/forums/en-US/whspowerpack1beta/thread/e61def88-773f-4387-a719-906e88e9f78f/

    and this folder was empty: D:\folders\{1618D36B-F4E7-4360-B070-A32070519DC9}\

    and also tried Ken Warren's suggestion for checking the snap period is 0:

    HKLM\SOFTWARE\Microsoft\Windows Home Server\Storage Manager\Volumes

    and they were all 0.

    I'm getting quite frustrated. It's almost like something is being reported incorrectly. Anyone know what file might be holding the storage sizes and can it be regenerated or replaced?

     

    Thursday, January 6, 2011 10:32 PM
  • Did you turn on duplication of the backup database using the WHS BDBB add-in? The duplicated backup database shows up as "System" rather than "Duplication."
    Thursday, January 6, 2011 10:38 PM
  • What is BDBB? I'm assuming by my ignorance the answer is probably no. Either way, total file size is only about 1.5GB between shares and backups, as shown by treesize free and just doing a file size check on the D: drive.
    Thursday, January 6, 2011 10:51 PM
  • As I look at it, it seems my files are seen twice by the system for some reason. In the system files as well as whs files. It shows up both in disk management and also the Server Storage of the console. Unless its coincidence that my file sizes are the same size as the "system" file size shown. What could cause this? Tombstones screwed up? Buy why would this be shown as such in disk management? i don't get it.
    Friday, January 7, 2011 1:27 AM
  • I have the same problem. My System shows 1.7TB

    I got this way because my system drive failed and I had to install a new one and a new system.

    I recovered all my files, but lost all of my backups; so I am pretty sure the "system" is made up of dead pieces of old backup files.

    How do I get rid of all that junk?

    How do I even see the files using WHS on my EX485?

     

    Friday, July 1, 2011 3:07 AM