locked
remove icon RRS feed

  • Question

  • Hello,

    I used microsoft demonstration tool to publish an icon set for a custom entity.Now when i acces that entity an error occure.I tried updating the icons manually with the icons that demo tools provide but an it said that icon in web application is not valid.

    How can i remove the icons from an entity?

    thanks
    Monday, January 18, 2010 1:59 PM

Answers

  • Your best option should be to import new icons from your computer (as it works there). You should place the icon-files in the same folder as the original icons are in order to allow all computers of the network to access them.
    • Marked as answer by Cosminc Wednesday, January 20, 2010 12:52 PM
    Wednesday, January 20, 2010 12:23 PM

All replies

  • If the entity has become corrupted, you might have to export the entity and then edit the image references manually in the XML before reimporting and publishing the entity. If you export another entity you should be able to see the valid format for image references in XML.

    I haven't tried this myself, but hopefully it works for you.

    Monday, January 18, 2010 2:08 PM
    Moderator
  • Hi,

    There isn't any image reference in the xml.

    Thanks
    Monday, January 18, 2010 2:35 PM
  • Sorry Casminc, I assumed there was. But you're right, there isn't. There must be a database reference to the image location, perhaps you could try looking in the database for the image reference. Or try replacing the image on the web server with a known good image with the same name.
    • Marked as answer by Jim Glass Jr Monday, January 18, 2010 7:55 PM
    • Unmarked as answer by Cosminc Tuesday, January 19, 2010 10:07 AM
    Monday, January 18, 2010 3:19 PM
    Moderator
  • Hello,

    Unfortunately my problem is not resolved, on my computer there is no error on the custom entity but other computers can't acces the custom entity with error on page.
    How can I unpublish the icons?
    Reimport original sitemap will resolve my problem?

    Thanks
    Tuesday, January 19, 2010 10:08 AM
  • Hi,
    I don't remember the exact table in the db, but the icons are serialized inside. When you find it, do a db backup just in case, and replace the values for all the serialized icon fields with values of an entity that doesn't have custom icons.
    Tuesday, January 19, 2010 11:05 PM
  • Your best option should be to import new icons from your computer (as it works there). You should place the icon-files in the same folder as the original icons are in order to allow all computers of the network to access them.
    • Marked as answer by Cosminc Wednesday, January 20, 2010 12:52 PM
    Wednesday, January 20, 2010 12:23 PM
  • Hello,

    I did that and it works.

    Thanks all for your time.
    Wednesday, January 20, 2010 12:51 PM