locked
An error has occured {1}{0} while importing solution in CRM 2011 RRS feed

  • Question

  • Hi Everyone,

    I encountered this error while trying to import solution in CRM 2011. i have two different environment, one is dev and the other is QA environment. both are running the same Roll up (in this case RU 6). basically my solution contains all necessary components in dev including (entities, option set, webresources, security role, dashboard, and reports). please advise, any help really appreciated.

    Wednesday, August 8, 2012 3:49 AM

Answers

  • Hi guys, finally i manage to find the problem. there are duplicates definitions of attributes and relationships in "Customization.xml". i just deleted it and it imported successfully.

    Hope this helps

    Friday, October 19, 2012 8:17 AM

All replies

  • I am sure you have looked at the event viewer does it give any clue? Any exception? 

    -Devashish
    http://thecrmworld.wordpress.com
    http://ebizartisans.com


    Wednesday, August 8, 2012 5:16 AM
  • i have looked at the event viewer, it didnt throw me any exception.

    I got this error BEFORE the importing process started. (right after choose zip file).

    Wednesday, August 8, 2012 8:21 AM
  • Hi,

    Check whether in your solution have you added any field, entity with different prefix name.

    Ex: While creating solution you set prefix test, but while creating new field, entity it created prefix with new.

    Check whether in web resource both function name with same name.

    Check field schema name, entity name all are same or not.


    Thanks & Regards, MS CRM Consultant, V.Surya. My Blog: http://inventcrm.wordpress.com/

    Wednesday, August 8, 2012 12:37 PM
  • Thanks Surya for your reply,

    I believe my solution contains the same prefix, i think CRM have the capability handling multiple prefix since they provide us functionality to create multiple publishers,, however i did a massive changes in my entities (dropping fields, changing the data type and adding new fields). Do you think it will cause the problem?

    Friday, August 10, 2012 3:31 AM
  • same problem ocurred in my crm online solution .......... if u got any solution please share ......... 

    Thanks


    Manoj Chauhan

    Wednesday, September 26, 2012 7:06 AM
  • Did you check the memory usage?


    Esa Kirvesmäki Avanade

    Wednesday, September 26, 2012 10:41 AM
  • This is a common error with solutions, if possible export again from the source environment and import again to the target.

    As you said the error comes before trying even to install, this is when CRM is checking for the dependencies, have you modifed externally the customisations.xml to remove this dependencies??

    Cheers,

    Mc

    Wednesday, September 26, 2012 10:50 AM
  • Hi guys, finally i manage to find the problem. there are duplicates definitions of attributes and relationships in "Customization.xml". i just deleted it and it imported successfully.

    Hope this helps

    Friday, October 19, 2012 8:17 AM