locked
CRM Client 4.0 - No Connection could be established RRS feed

  • Question

  • Hello everybody,

    a few days ago we updated our CRM 3.0 to 4.0. This means we need the new CRM Desktop Client 4.0 for Outlook.
    I installed it on my PC for testing purposes, and it works fine.
    For a few seconds, but then i get an error message. And this error message displays every 45 seconds or so.
    You can see a screen below, for translation see below pic.



    No Connection could be enabled.
    There could still be no connection established with Microsoft Dynamics CRM.
    It will be reestablished, as soon as possible.
    Click with your right mouse, choose "Sign out" to stop repeating the connection process.

    This whole thing is pretty annoying, and i´m looking for the cause.

    I´ll describe the installation:

    1. Starting SetupClient.exe
    2. Choose "Install Microsoft Dynamics CRM for Outlook (recommended)
    3. Agree with License Terms
    4. Install Microsoft Visual C++ Runtimelibraries
    5. Choose Installpath (standard)
    6. The 4 tests are completing without error
    7. Setup finished

    And a short description for configuration:

    1. Starting Outlook
    2. Choose "Configure Microsoft Dynamics CRM for Outlook"
    3. Choose "My company"
    4. Intranetaddress: "http://crm"; (I also tried the servers IP)
    5. Use same address for Internetconnections

    Now i´m starting my outlook, and during the first seconds everything runs fine. But shortly after (10-30 seconds) i get a red exclamation mark and the error message you can see above.

    In version 3.0 we also used "http://crm" and it worked fine.

    I also started the Diagnostic Tool, it displays the following error message:

    Test Network and Connectivity:
    The indicated URL "http://crm/company" doesn´t answer

    "company" is our only company in crm

    If you need more information please let me know

    sincerely yours, jens
    Friday, March 7, 2008 1:25 PM

Answers

All replies

  •  

    Use CRM Diagnostic wizard to check this

     

    http://blogs.msdn.com/benlec/archive/2008/03/04/crmdiagtool4-for-microsoft-crm-4-0-has-been-released.aspx

     

    also check outlook diagnostic wizard tool in cd.

     

    Regards,

    Imran

     

    http://microsoftcrm3.blogspot.com

     

    Sunday, March 9, 2008 11:17 AM
    Moderator
  • Well, the only error message i could find is:
    System.Net.WebException: The Remoteserver returned an error: (401) not authorized.
    Found it in MSCRM Diagnostics Report.xml

    Another interesting thing i found in mypc-Microsoft.Crm.Outlook.Diagnostics-ConfigWizard-20080310-1.log:

    # CRM Tracing Version 2.0

    # LocalTime: 2008-03-10 09:45:57.6

    # Categories: *:Verbose

    # CallStackOn: Yes

    # ComputerName: mypc

    # CRMVersion: 4.0.7333.113

     

    >The client authentication manager is signing in.

    >Retrieving a secret.

    >Retrieving a secret from physical storage.

    >Retrieving a secret.

    >The secret is not stored in memory and physical storage is not allowed.

    >The client authentication manager is selecting a client authentication provider.

    >Creating a client authentication provider.

    >The user name is: .

    >The target URL is: http://crm/company.

    >The discovery URL is: http://crm/MSCRMServices.

    >Creating a connected client authentication provider.

    >Creating an Active Directory client authentication provider.

    >The client authentication manager is performing a silent sign in.

    >The silent sign in succeeded and no client authentication form will be launched.

    >Signing out the user from Active Directory.

     >Active Directory authentication state is now none.

    >Network connection state is now none.

    >A client authentication provider is signing out.

    >A client authentication provider is stopping background maintenance work.



    And then it´s back to >The client authentication manager is signing in.

    Everything starting again... and again... and again ^^



    Greetz


    Monday, March 10, 2008 10:23 AM
  • I am having the exact error. Any solutions or clues to this one?

     

    Shri

     

    Friday, October 10, 2008 10:08 PM
  • Did you uninstall 3.0 Client before installing 4.0 client?  If not do a complete uninstall of all clients, reboot and re-install the 4 Client.

     

    Friday, October 10, 2008 11:29 PM
  • Are your client computers using a firewall?  I think I saw a similar issue to this when someone had  Windows Firewall on their PC.

    Saturday, October 11, 2008 6:41 AM
    Moderator
  • run inetmgr and check if the folder "_imgs" has anonymous access ENabled. This seams to be the problem in our environment.

    Thursday, May 7, 2009 1:58 PM