locked
HTTP Error 500.19 - Internal Server Error The requested page cannot be accessed because the related configuration data for the page is invalid. RRS feed

  • Question

  • <?xml version="1.0" encoding="utf-8"?>
    <!--
      For more information on how to configure your ASP.NET application, please visit
      https://go.microsoft.com/fwlink/?LinkId=169433
      -->
    <configuration>
      <connectionStrings>
        <add name="DefaultConnection" connectionString="Data Source=DESKTOP-U341J1JIS;Initial Catalog=Chalochale;Integrated Security=True" providerName="System.Data.SqlClient" />
      </connectionStrings>
      <!--
        For a description of web.config changes see http://go.microsoft.com/fwlink/?LinkId=235367.

        The following attributes can be set on the <httpRuntime> tag.
          <system.Web>
            <httpRuntime targetFramework="4.7.2" />
          </system.Web>
      -->
      <system.web>
        <webServices>
          <protocols>
            <add name="HttpGet" />
            <add name="HttpPost" />
          </protocols>

        </webServices>
        <compilation targetFramework="4.6" />
        <httpRuntime targetFramework="4.6" />
        <sessionState allowCustomSqlDatabase="true" cookieless="UseCookies" mode="InProc" timeout="20" compressionEnabled="true" />
        <customErrors defaultRedirect="~/Error/error.aspx" mode="On">
          <error statusCode="400" redirect="~/Error/page-400.aspx" />
          <error statusCode="401" redirect="~/Error/page-400.aspx" />
          <error statusCode="402" redirect="~/Error/page-400.aspx" />
          <error statusCode="403" redirect="~/Error/page-400.aspx" />
          <error statusCode="404" redirect="~/Error/page-400.aspx" />
          <error statusCode="500" redirect="~/Error/page-500.aspx" />
        </customErrors>
        <pages enableSessionState="true" />
      </system.web>
      <system.webServer>
      <security>
        <requestFiltering>
          <requestLimits maxAllowedContentLength="1073741824"/>
        </requestFiltering>
      </security>
        <staticContent defaultDocFooter="" enableDocFooter="true">
          <mimeMap fileExtension=".aspx" mimeType="application/aspx" />
          <mimeMap fileExtension=".asp" mimeType="application/asp" />
          <clientCache cacheControlMode="UseMaxAge" cacheControlMaxAge="20.00:00:00" httpExpires="Sun, 29 Mar 2020 00:00:00 GMT" cacheControlCustom="HTTP 1.1" />
        </staticContent>
        <defaultDocument>
          <files>
            <clear />
            <add value="../account/Login.aspx" />
          </files>
        </defaultDocument>
        <caching enabled="true" enableKernelCache="true" maxCacheSize="500000000">
          <profiles>
            <remove extension=".aspx" />
            <add extension=".png" policy="DontCache" kernelCachePolicy="DontCache" duration="00:00:01" varyByQueryString="*" />
            <add extension=".jpeg" policy="CacheForTimePeriod" kernelCachePolicy="CacheForTimePeriod" duration="00:00:01" varyByQueryString="*" />
            <add extension=".jpg" policy="CacheForTimePeriod" kernelCachePolicy="CacheForTimePeriod" duration="00:00:01" varyByQueryString="*" />
            <add extension=".js" policy="CacheForTimePeriod" kernelCachePolicy="CacheForTimePeriod" duration="00:00:01" varyByQueryString="*" />
            <add extension=".css" policy="CacheForTimePeriod" kernelCachePolicy="CacheForTimePeriod" duration="00:00:01" varyByQueryString="*" />
            <add extension=".aspx" policy="CacheUntilChange" kernelCachePolicy="CacheUntilChange" duration="00:00:01" varyByQueryString="*" />
          </profiles>
        </caching>
        <httpCompression directory="%SystemDrive%\inetpub\temp\IIS Temporary Compressed Files">
          <scheme name="gzip" dll="%Windir%\system32\inetsrv\gzip.dll" staticCompressionLevel="9" />
          <dynamicTypes>
            <add mimeType="text/*" enabled="true" />
            <add mimeType="message/*" enabled="true" />
            <add mimeType="application/x-javascript" enabled="true" />
            <add mimeType="application/json" enabled="true" />
            <add mimeType="*/*" enabled="true" />
            <add mimeType="image/*" enabled="false" />
            <add mimeType="font/*" enabled="true" />
          </dynamicTypes>
          <staticTypes>
            <add mimeType="text/*" enabled="true" />
            <add mimeType="message/*" enabled="true" />
            <add mimeType="application/x-javascript" enabled="true" />
            <add mimeType="application/atom+xml" enabled="true" />
            <add mimeType="application/xaml+xml" enabled="true" />
            <add mimeType="*/*" enabled="true" />
            <add mimeType="image/*" enabled="false" />
            <add mimeType="font/*" enabled="true" />
          </staticTypes>
        </httpCompression>
        <urlCompression doStaticCompression="true" doDynamicCompression="true" dynamicCompressionBeforeCache="true" />
        <httpProtocol allowKeepAlive="true">
          <customHeaders>
            <add name="Cache-Control" value="public" />
          </customHeaders>
        </httpProtocol>
        <rewrite>
          <rules>
            <clear />
          </rules>
        </rewrite>
      </system.webServer>
      <appSettings>
        <add key="UnobtrusiveJavaScriptEnabled" value="true" />
        <add key="ChaloCacheDuration" value="10" />
        <add key="ChaloIsCache" value="true" />
        <add key="SessionWarning" value="10" />
      </appSettings>
      <system.codedom>
        <compilers>
          <compiler extension=".cs" language="c#;cs;csharp" warningLevel="4" compilerOptions="/langversion:7.3 /nowarn:1659;1699;1701;612;618" type="Microsoft.CodeDom.Providers.DotNetCompilerPlatform.CSharpCodeProvider, Microsoft.CodeDom.Providers.DotNetCompilerPlatform, Version=3.6.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
          <compiler extension=".vb" language="vb;vbs;visualbasic;vbscript" warningLevel="4" compilerOptions="/langversion:default /nowarn:41008,40000,40008 /define:_MYTYPE=\&quot;Web\&quot; /optionInfer+" type="Microsoft.CodeDom.Providers.DotNetCompilerPlatform.VBCodeProvider, Microsoft.CodeDom.Providers.DotNetCompilerPlatform, Version=3.6.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
        </compilers>
      </system.codedom>
      <runtime>
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
          <dependentAssembly>
            <assemblyIdentity name="Newtonsoft.Json" publicKeyToken="30ad4fe6b2a6aeed" culture="neutral" />
            <bindingRedirect oldVersion="0.0.0.0-7.0.0.0" newVersion="7.0.0.0" />
          </dependentAssembly>
        </assemblyBinding>
      </runtime>
    </configuration>
    <!--ProjectGuid: 924E691A-8FD7-42C6-ABFB-EA9495FE8F49-->

    Where do i changes in web.config file please help to solve this error on iis server azure

      
    • Edited by Dharam00147 Saturday, August 15, 2020 10:59 AM
    • Moved by CoolDadTx Saturday, August 15, 2020 3:40 PM ASP.NET related
    Saturday, August 15, 2020 10:58 AM

All replies

  • Hello,

    You are better off asking here https://forums.asp.net/


    Please remember to mark the replies as answers if they help and unmarked them if they provide no help, this will help others who are looking for solutions to the same or similar problem. Contact via my Twitter (Karen Payne) or Facebook (Karen Payne) via my MSDN profile but will not answer coding question on either.

    NuGet BaseConnectionLibrary for database connections.

    StackOverFlow
    profile for Karen Payne on Stack Exchange

    Saturday, August 15, 2020 11:05 AM