locked
Media Library dosen´t refresh RRS feed

  • Question

  • Hi there,

    I am having trouble viewing new files (some copied to server folders 2 motnhs ago) from WHS media server, beeing via PS3 (movies), or for the matter, pictures via windows phone connector...

    Since a have restarted whs several times I am confident that it wouln't solve the problem.

    Just stoped and restarted the media server (via dashboard) and it was a no go.

    Any ideas, as there's no "refresh media library" button?

    What to do in order to prevent this?

    thanks

    LLuz


    LL

    Thursday, February 16, 2012 1:29 PM

Answers

  •  Copy the code below and paste it into notepad, then save it on your server's desktop as medialibrary_refresh.bat

    cd c:\program files\windows server\bin
    wsspowershell.exe set-wssmediaserverenabled "-enable 0"
    net stop WMPNetworkSvc
    del "C:\Users\MediaStreamingAdmin\AppData\Local\Microsoft\Media Player\CurrentDatabase_372.wmdb"
    net start WMPNetworkSvc
    cd c:\program files\windows server\bin
    wsspowershell.exe set-wssmediaserverenabled "-enable 1"

    Run the .bat file, then your library will be refreshed.

    ------------------------------------

     Masahiko Sada

    • Marked as answer by lrluz Thursday, February 16, 2012 6:12 PM
    Thursday, February 16, 2012 2:21 PM

All replies

  • First, you are sure the file types are supported?  Movies in MKV containers are not supported, for example.

    If so, then you may be seeing a problem I've observed from time to time on my system.  Best I can figure, it is related to deleting files in the media shares, then copying them back again.  The media server doesn't always pick up the restored files automatically. 

    Try removing the shared media folder from the Media Library altogether (in Server Settings > Media Settings), then adding it back in again.  Alternatively, try making copies of the files and seeing if the library picks up the new files--if so, delete the originals and rename the copies.

    Thursday, February 16, 2012 2:17 PM
  •  Copy the code below and paste it into notepad, then save it on your server's desktop as medialibrary_refresh.bat

    cd c:\program files\windows server\bin
    wsspowershell.exe set-wssmediaserverenabled "-enable 0"
    net stop WMPNetworkSvc
    del "C:\Users\MediaStreamingAdmin\AppData\Local\Microsoft\Media Player\CurrentDatabase_372.wmdb"
    net start WMPNetworkSvc
    cd c:\program files\windows server\bin
    wsspowershell.exe set-wssmediaserverenabled "-enable 1"

    Run the .bat file, then your library will be refreshed.

    ------------------------------------

     Masahiko Sada

    • Marked as answer by lrluz Thursday, February 16, 2012 6:12 PM
    Thursday, February 16, 2012 2:21 PM
  • Thanks alot M Sada !

    At first attempt, funny thing happened as from video folder the videos disappeared but one, and from those that weren't showing only one was visible. The pictures folders got fixed tough.

    At second run, all get sorted out, so it’s ok.

    I believe all this code batch shouldn’t be necessary, right!!!

    Once again thanks alot!!


    LL

    Thursday, February 16, 2012 6:19 PM
  • I know it's an old thread but it worked for me.  Thanks!
    Thursday, January 10, 2013 3:42 AM
  • FYI. Microsoft had published Fixit.  http://support.microsoft.com/kb/2719283/en-us


    Microsoft MVP for Server Solutions - Windows Home Server

    Saturday, January 12, 2013 1:46 AM
  •  Copy the code below and paste it into notepad, then save it on your server's desktop as medialibrary_refresh.bat

    cd c:\program files\windows server\bin
    wsspowershell.exe set-wssmediaserverenabled "-enable 0"
    net stop WMPNetworkSvc
    del "C:\Users\MediaStreamingAdmin\AppData\Local\Microsoft\Media Player\CurrentDatabase_372.wmdb"
    net start WMPNetworkSvc
    cd c:\program files\windows server\bin
    wsspowershell.exe set-wssmediaserverenabled "-enable 1"

    Run the .bat file, then your library will be refreshed.

    ------------------------------------

     Masahiko Sada


    Did this and it says the file is still in use so cant be deleted.  also the fix it has stopped deleting the file as well
    Friday, February 15, 2013 12:43 PM