locked
Problem restoring a Win7 64b SSD Image from Microsoft Home Server RRS feed

  • Question

  • I’m hoping one of you experts out there can offer some guidance on how proceed with the recovery of a Win7-64b SSD Drive image from a Microsoft Windows Home Server backup copy. I apologize in advance for the long-winded post, but I wanted to provide as much detail as possible up front so reduce the need for back-and-forth questions. I’ve been trying t solve this problem for a while now, so the history is somewhat involved. I’ve provided a lot of relevant information in the problem description below, followed by some questions about how to proceed at the end of this post. If you get bored reading my long-winded story, please skip down to my questions at the end before bailing on me. Any guidance on any of those points would be extremely appreciated as I’m a bit desperate to recover this drive image. Thanks in advance!!!!!!!!!!!!!!!

    Problem Description

    For years, I’ve been using Windows Home Server to do daily backups of all the PCs in my house. During that time, I’ve used the auto recovery feature to restore the hard drives on a number of my machines although I don't recall if I've ever restored a Win7 machine. I'm running MWHS 3.3.1.35433 - 2/3/2010 on an HP EX490 MediaSmart Server. I’ve been extremely happy with MWHS and assumed that I was covered in case of a disk failure. It’s been a long time since I’ve had a failure, but one of my Windows 7 machines crashed on me the other day. Since I had a full backup on the Home Server, I proceeded to recover the entire disk. When I tried to do that, however, I encountered what appears to be a common problem: the restore program could not find the server. I tried a few things to fix that, but I concluded that I had must be suffering from some of the issues described in Olaf Engelke’s post entitled “How to restore a client PC, if the network connection does not work in the CD based restore environment,” so I decided to restore my disk from another PC using Olaf’s method.

    The drive in question is a 512Gb Samsung 540 Pro drive with a 400M data partition and a 476Gb OS partition. I removed it from its parent machine (an Alienware M18xR2) and installed it into a ‘Sabrent 2.5” SSD & SATA Hard Drive USB 3.0 Enclosure’. I plugged that into the USB port on another Win7/64b machine and followed Olaf’s instructions from the post referenced above. Unfortunately, I had the same issue: the ClientRestoreWizard could not find the Home Server. I could see the disk from Explorer in the ‘My Computers’ directory, and I was able to log into the server from the Win7 machine I was using to do the restore, but no matter what I tried, ClientRestore Wizard could not find the Home Server.

    In the course of studying this problem, I was thinking that maybe Win7 was the problem here, and in light of Olaf’s discussions about different drivers, etc. this seemed to make sense. So I decided to try the same thing from one of my XP machines. I connected it to the USB port of the XP machine and rebooted it in Safe Mode. As I had done with the Win7 machine, I also disabled the wireless connection and hard wired the XP machine into the network. This time, the server could be found and the ClientRestore Wizard would run!!!! However, after waiting about 4 hours for the restore process to complete, the ClientRestoreWizard crashed with 20 minutes to go. Verrry Frustrating!!! I tried restoring the two partitions separately, and I was able to successfully restore the Data partition, but the OS partition restore always crashes with 20 minutes to go. As you can imagine, I’ve been working on this a long time now since every re-try takes 4 hours to complete.

    After many attempts, I started to suspect (actually more like hoped) that the SSD drive may have gone bad. So I put the SSD drive back in the original Win7 machine as a secondary disk to the Win7 HDD that originally came with the machine (which I had swapped for the SSD at the time I bought it). This allowed me to run Samsung Magician on the drive, which reported that it’s in good condition and the write limit has not been exceeded. But still, I’m wondering if the SDD might still have a problem...

    The latest thing I tried was to use the same procedure to clone the HDD to the SSD that I used when I originally bought the machine. This worked fine, although the amount of space taken up on the SSD by the original factory image (~70Gb) is much less than the space needed for the image I’m trying to restore (~310Gb). After doing this, I put the SSD back in the enclosure and tried again to restore the larger image to the SSD from the Home Server using the XP machine, but it still didn’t work, hanging with 20 minutes to go. So this is where I am today.

    I’m hoping that someone will be able to provide some ideas on how to proceed from here. This is my main CAD machine and I really want to recover it. It’s particularly frustrating that I can't restore an image to a machine I've backed up religiously for years. I realize (now) that Windows Home Server is no longer supported, but it had worked so well for so many years that I had no reason to think about it. It just ran reliably, backing up every machine every night, which is what it’s supposed to do, isn’t it? Anyway, I've listed some specific questions below. Any advise would be greatly appreciated. 

    Questions:

    Has anyone successfully restored a Win7 64b image from Windows Home Server? Has anyone seen this issue where the ClientRestoreWizard crashes with 20 minutes left to go? I’m using ClientRestoreWizard.exe, File Version 6.0.3436.0. Is this the latest version available, or is there a newer one? (I haven’t been able to find any Windows Home Server files on the MSFT site. Are they there somewhere?? If not, where’s a good place to find the latest versions?) Is there another way to restore a Windows Home Server Volume, perhaps using another application? Would the restore work better if I installed the drive directly into the XP machine rather than through a USB-to-SATA adapter? Since it’s taking so long to restore, could something be timing out on me?

    Is this kind of behavior indicative of a hardware failure? If so, should I try erasing and re-formatting the SSD before trying again? If so, what’s the best utility to use for that? I’d like to completely erase it and re-format it with the same size Data and OS partitions there now so it’s ready to accept the restored images. Considering that I’ve used it for all attempts at recovery so far, could this hanging problem be caused by the Sabrent USB-to-SATA adaptor? Is there another adapter that someone has successfully used to restore a drive image in this way? Is there anything special that needs to be done when restoring an SSD from Windows Home Server as compared to an HDD? I’ve not yet bit the bullet on a new SSD drive, but I was thinking I could try restoring to an HDD drive instead. If that doesn’t work either, then I will at least have ruled out the SSD drive. Any thoughts on that?

    Any other ideas? Hopefully one of you will be able to provide some recommendations on how to proceed from here.

    Thanks for reading! Help!
    Thursday, July 13, 2017 4:25 PM

Answers

  • Problem solved! Read on to see how I did it. It's based on the process outlined in the second half of Olaf Engelke's post referenced in my first email, but with some of the blanks filled in. I also found a NEW USB-to-Ethernet with downloadable Win 32b drivers, which will hopefully save some time for those like me who don't have an old one lying around.

    FYI, I was never able to make the process work with the XP machine. It might have worked, but as luck would have it, the XP machine stopped working while I was in the process of trying to restore the Win7 machine. This was definitely the low point of the process, but I regrouped and moved on. So I went back to trying the restore process on the Win7 machine. I didn't initially explore using the 32b drivers since the Alien M18xR2 only supports 64 bit drivers, according to Dell's site. So no 32b drivers from Dell, but I was able to find 32b Vista drivers for my NIC on another site. I loaded them from a separate USB disk when prompted during the install process and the client restore wizard was finally able to find the server! I thought I was home free at that point but I then with only 7minutes left to go in the restore process, I encountered the dreaded "ClientRestoreWizard_Fresh.exe - Application error. The exception cannot continue. Windows cannot continue from this exception (0xc0000025) occurred in the application at location 0x00f23f59". This exception is discussed by a number of people on the WHS 2011 form, but nothing I tried would get me past this one. Apparently the Alien REALLY doesn't support 32b drivers.

    From what I could tell by reading the WHS 2011 forums on the 0xc0000025 exception, this once again appears to be a driver issue. So I followed Olaf's alternate process and used an old external LITE-ON eHAU424 DVD drive (connected through a USB port) that I had laying around for a while that I know was from the Win XP era, so no 64b drivers on that guy. Along with this, however, I needed an 'old' external USB-to-Ethernet adapter that doesn't use 64b drivers. I had no such animal. So I searched for a new one that has 32 drivers available, which is not as easy as one might think. I finally found an IOGear GUC3100 adapter that has a variety of 32b drivers available from the  manufacturer of the Ethernet controller chip used in the IOGear adapter, ASIX. The controller chip is the AX88179 and I used the Windows XP/Vista 32-bit Driver, Revision V1.4.2.0, Release Date 2013-05-24 which can be found at the ASIX.te site.

    The entire process I used is described in detail below:

    1) Copy the following files form the Computer Restore CD onto a USB stick as described by Olaf's post:
    backupapi.dll
    clfs.sys
    clientrestorewizard.exe
    itss.dll
    partnermanager.dll
    restorecdinit.dll
    transportserviceproxy.dll
    vfpodbc.dll
    whsdriversetup.exe

    Create a restore.cmd batch file in the same folder with the following content:
    @echo off
    for %%a in (*.dll) do regsvr32 /s %%a
    restorecdinit.exe

    2) Find or borrow a Windows 7 32b install DVD to use as a boot disk (Step 1 above will not work with a Win7 64b install disk. It needs to run in a 32b environment.)

    3) Connect the external DVD to one USB port. Connect the USB-to-Ethernet adapter to another USB port. (Connect the Ethernet cable from this adapter DIRECTLY to the WHS.) Connect the USB stick with the files created in Step 1 above to a third USB port. Insert the Win32 32b DVD into the external DVD drive.

    4) Copy the AX88179 Windows XP/Vista 32-bit Driver to another USB stick but do not insert it yet.

    5) Reboot the Win7 machine and restart into bios setup (F2). Disable the internal NIC controller. disable the wireless Ethernet adapter. Enable USB Emulation. (This is what I needed to do for my particular machine, so yours may be slightly different. The point is to disable the internal NIC and Ethernet controller. Not sure why, but the process wouldn't work without enabling USB Emulation on my machine.)

    6) Reboot the WHS and then immediately reboot the Win7 machine into the boot menu (F12).

    7) Select boot from CD/DVD in the boot menu. Be ready to hit the return key again quickly when prompted whether you want to boot from the CD/DVD drive, the prompt goes by quickly if you're not looking for it.

    8) Wait while the computer boots from the Win7 32b DVD. When the boot completes, cancel out and then open the command window.

    9) Type restore and wait for the WHS restore process to start.

    10) When the Installed Devices screen shows, you should not see a network device.

    11) Select More Details (or something like that) and Select Install drivers. When prompted, remove the USB stick with the WHS files and insert the USB stick with the network driver and press OK.

    12) When the driver is found, remove the USB stick with the driver and re-insert the USB stick with the WHS files, click OK and then continue through to find the WHS server.

    13) Enter the WHS password when prompted and then continue to select the volume(s) to restore after the server is found.

    14) Now all you have to do is wait for the volume to be restored, hopefully without errors.

    I did this 5 or 6 times until I found a stable restoration image (in which Windows XP mode would start, which was my original problem), so this process seems pretty stable, at least for me. Hopefully it will work to others out there.

    Good Luck!

    • Marked as answer by Powderboy Saturday, July 22, 2017 6:31 AM
    Saturday, July 22, 2017 6:31 AM