locked
Connection Problem After Installing New Router RRS feed

  • Question

  • I have had WHS running for about a year. Today I installed a new wireless router because the old one had a flakey connection.  The new router is a Linksys WRT54GL.  I flashed it with the latest Linksys firmware since the old firmware was 2 years old. My symptoms are:

    I can view, copy and paste files to the server from several computers.
    I can remote into the server
    I can access the Internet via IE with the server and desktops
    I can ping the IP address of the server from my desktops
    I cannot ping the server by name
    If I try to connect via Windows Explorer I get an can not find error from my IPS
    I can connect via WIndows Workgroups
    I cannot connect using the Connector
    I can not reinstall the connector and get an error stating it cannot connect to the server. 

    I have checked to make sure all cables are plugged in snuggly. 

    Below are the results of running IPCONFIG /All

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : Walter-Compaq
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : cfl.rr.com

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . : cfl.rr.com
       Description . . . . . . . . . . . : Realtek RTL8139/810x Family Fast Ethernet NIC
       Physical Address. . . . . . . . . : 00-13-D4-D4-F4-84
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::5c45:aa25:32d8:d574%8(Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.1.103(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : Saturday, March 28, 2009 5:20:37 PM
       Lease Expires . . . . . . . . . . : Sunday, March 29, 2009 5:20:36 PM
       Default Gateway . . . . . . . . . : 192.168.1.1
       DHCP Server . . . . . . . . . . . : 192.168.1.1
       DNS Servers . . . . . . . . . . . : 65.32.5.111
                                           65.32.5.112
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter Local Area Connection* 6:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . : cfl.rr.com
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 7:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : 02-00-54-55-4E-01
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    I am assuming there is some switch or entry I need to change in my router relating to DNS but so far I have not fixured out what is necessary to fix this.

    Any help would be greatly appreciated.

    Walter

    Sunday, March 29, 2009 2:19 AM

Answers

  • I finally figured out a way around this.  While I am sure there is a setting in the router I am missing, but since my WHS has a fixed IP address I simply added it to the HOSTS files in each desktop.  Everything works now.

    My thanks and appreciation to those who replied.
    Walter
    • Marked as answer by Walter Wood Saturday, April 4, 2009 7:31 PM
    Saturday, April 4, 2009 7:31 PM

All replies

  • You can try to configure your router to hand out it's own internal IP address as the DNS server address.
    I'm not on the WHS team, I just post a lot. :)
    Sunday, March 29, 2009 5:31 AM
    Moderator
  • Also remove the connection specific DNS suffix as well as the suffix search list, since those entries change the name of your WHS to <server>.cfl.rr.com, which makes DNS name resolution either fail, time out or deliver a wrong machines address.
    Best greetings from Germany
    Olaf

    Sunday, March 29, 2009 10:17 AM
    Moderator
  • Also remove the connection specific DNS suffix as well as the suffix search list, since those entries change the name of your WHS to <server>.cfl.rr.com, which makes DNS name resolution either fail, time out or deliver a wrong machines address.
    Best greetings from Germany
    Olaf

    Ken and Olaf,

    My WHS box already has a fixed local IP address and points to the router as the default gateway and DNS server so I am assuming changes need to be done in the router.  I am not sure specificlly what settings in this router need to be changed. 

    Walter
    Sunday, March 29, 2009 10:54 AM
  • Hi Walter,
    yes, the changes should be done somewhere in the router configuration (DHCP settings would be a good begin). This should be found somewhere in the routers manual.
    Best greetings from Germany
    Olaf
    Sunday, March 29, 2009 12:18 PM
    Moderator
  • As near as I can tell, the router is set correctly.  All computers except the WHS which has a fixed IP address get their addresses from the router.  However when I try to use the Console it apparently looks to the ISP's DNS for the address. 

    Walter
    Thursday, April 2, 2009 12:35 AM
  • As near as I can tell, the router is set correctly.  All computers except the WHS which has a fixed IP address get their addresses from the router.  However when I try to use the Console it apparently looks to the ISP's DNS for the address. 

    Walter

    That would be due to the fact that your client PC is looking to your ISP's DNS servers (rather than to your router) for name resolution:
    Default Gateway . . . . . . . . . : 192.168.1.1
       DHCP Server . . . . . . . . . . . : 192.168.1.1
       DNS Servers . . . . . . . . . . . : 65.32.5.111
                                           65.32.5.112
    It matters not, here, what the WHS itself is using - what matters is what the client is using. 
    Reconfigure your clients to look to the router for DNS (read:  remove the DNS server addresses from the client PCs), and things should "JustWork."

    HTH,
    Chris
    [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Thursday, April 2, 2009 1:19 AM
  • That would be due to the fact that your client PC is looking to your ISP's DNS servers (rather than to your router) for name resolution:
    Default Gateway . . . . . . . . . : 192.168.1.1
       DHCP Server . . . . . . . . . . . : 192.168.1.1
       DNS Servers . . . . . . . . . . . : 65.32.5.111
                                           65.32.5.112
    It matters not, here, what the WHS itself is using - what matters is what the client is using. 
    Reconfigure your clients to look to the router for DNS (read:  remove the DNS server addresses from the client PCs), and things should "JustWork."

    HTH,
    Chris


    Chris,

    I have to admit that while I know how to do some things, I am not always sure why.  Having said that, I don't think that the router can function as a DNS server.  I have never had to set the router as a DNS server in the past.  If I try to use the routers address in the IP's DNS properties it will not accept it, giving an error. 

    What I have tried since I last wrote is to flash the router with dd-wrt.  After doing that I was able to reinstall the connecter on my desktop. During the reinstall, the setup program found my server, logged me in and configured backups. 
    My WHS is now backing up each computer and I (still) have access to the files.  I still can not run the Connecter from my desktop however as it give me the error "Cannot connect to your home server... I can also connect to my WHS from another location over the Internet and even access my desktop remotely. 

    Walter
    Saturday, April 4, 2009 1:35 PM
  • Hi Walter,
    while consumer routers usually do not have a real DNS server built in, they may distinguish, which names should be resolved locally and which must be resolved at a real DNS server. So the router forwards your DNS query only if necessary (if a domain is attached to the name or if you add a DNS Suffix/Search Suffix) to another DNS server. And this is part is a job, which almost each router is able to do.
    Best greetings from Germany
    Olaf
    Saturday, April 4, 2009 2:47 PM
    Moderator
  • I finally figured out a way around this.  While I am sure there is a setting in the router I am missing, but since my WHS has a fixed IP address I simply added it to the HOSTS files in each desktop.  Everything works now.

    My thanks and appreciation to those who replied.
    Walter
    • Marked as answer by Walter Wood Saturday, April 4, 2009 7:31 PM
    Saturday, April 4, 2009 7:31 PM