locked
Problem Recognising USB drives RRS feed

  • Question

  • I am currently using a 3 to 4 year old laptop as my WHS, and it's been running great. It's a P4 2.66Ghz with 512MB RAM, but only 80GB internal storage, so I've been relying on my ever increasing number of external drives that have built up over the years to be part of the storage pool. Problem is, at the moment I have 4 drives, but the lappy only has 2 USB ports. No problem, I think, I'll just attatch a 4-port hub. At first, everything was fine. 1 of the drives refused to add to the pool at first, the option simply wasn't there, but then it suddenly worked. However, when it suddenly worked, everything started going wrong. Basically, if a drive is conencted to the hub it does not get recognised as being there, but if a drive is directly connected to the laptop then it is. First thought was it's the hub, tried all configurations of ports being used and still nothing. Tried another hub, and still nothing. So I'm beginning to think it's something wrong with WHS. Has anyone else had any problems of this kind? And yes, I know, using a laptop isn't a brilliant idea, but I don't have much cash to splash around on making a new server and making sure it's 100% silent.

     

    Thank you in advance for any advice you can give to me.

    Tuesday, January 8, 2008 12:49 AM

All replies

  • You may be running into an undervoltage problem. Are the drives you're attaching with USB self-powered (they have their own power supply) or are they powered by the USB hub? Does this happen with all USB ports on the laptop home server?

    Tuesday, January 8, 2008 12:57 AM
  • All drives are powered by an external power brick to the mains, and the same thing happens on both USB ports. The only issue I can think of is the hub being self-powered, but that didn't stop it working before, and it now doesn't work with only 1 device connected to one of it's 4 ports

     

    Tuesday, January 8, 2008 12:59 AM
  • I ran the Server re-installation but it's done nothing. I tried the adapter in my main PC and it works fine, but a lot of the data seems to be missing from what I can understand of the gibberish that WHS has made my HDs say. I'm going to buy a powered USB hub and see if it's a problem with undervoltage, but why wouldn't the hub even show a drive when only 1 is conencted? Surely it can't be that bad, and besides, it worked before, so why stop now?

     

    Thursday, January 10, 2008 4:10 PM
  • One of the problems that seems to be common, is that server 2003 doesn't recognise USB drives when they are plugged into a different port. Also, if at some point, the USB drive is removed, then server 2003, (and Win2k,) the USB driver sets the Open Host Controller Interface (OHCI) controller to suspend.

    There is a registry hack, which, as usual, means 'be it on your own head'

     

    From the Microsoft site: "Disable the Selective Suspend feature of the USB hub driver. To do this, follow these steps:

    1. Click Start, click Run, type regedit, and then click OK.
    2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\USB
    3. On the Edit menu, point to New, and then click DWORD.
    4. Type DisableSelectiveSuspend, and then press ENTER.
    5. On the Edit menu, click Modify.
    6. Type 1, and then click OK.

    Note If the DisableSelectiveSuspend registry entry is not present, you must create this registry subkey. This setting affects all USB host controller drivers in the system.

    If the value of the DisableSelectiveSuspend registry entry is set to 1, the Selective Suspend feature is disabled. Additionally, the Allow the computer to turn off this device to save power check box does not appear on the Power Management tab for the USB Root Hub. "

     

    There is also this KB, which has more info.

     

    HTH,

     

    Colin

     

    Thursday, January 10, 2008 6:40 PM
  •  

    I don't have a
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\USB,
    just a
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\USBehci
    a
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\USBhub
    or a
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\USBuhci
     
    I created a new DisableSelectiveSuspend registry DWORD under the USBhub section, but it did nothing :-(
     
     
    Thursday, January 10, 2008 10:35 PM
  • It really sounds like a combination of your USB hub going out and the intermittent connection your drives had because of the inconsistent connection. Please let me know how it goes once you've replaced the USB hub with a self-powered hub.

     

    What adapter did you try in your main PC? That you have a ....\usbehci key and not a ...\usb key in the registry suggests that the previously mentioned hotfix has been applied to your home server already.

    Thursday, January 10, 2008 11:02 PM
  •  

    It was just a generic USB 2 4-port hub, and it also worked with the generic USB 1.1 hub, neither of which are no longer recognised on the server. Doing a completely fresh reinstall now, losing all my data unfortunately, but s**t happens I guess! If that doesn't fix it I'll report back with the powered hub, arriving in a couple of days and let you know then. The sticking point for me is why is worked originally but then just stopped.
    Thursday, January 10, 2008 11:08 PM
  •  

    I believe Marc to be correct about this and the powered hub most likely will fix the issue.  Most non powered hubs (even if the devices plugged into them are powered) can not pump the amount of voltage required to the computer for 4 devices that are not items like mice and keyboards.  Should be able to see in device manager under the hub with one connected the amount of power used for that device.  Then times by four and see if that is more then 500mv(the amount most non powered hubs can push)  I have seen this many times and a powered hub fixes it every time.

     

    Ron

    Friday, January 11, 2008 2:09 AM
  • Hi am having the same prob did you find a solution? MY WHS doesnt seem to pick up andy additional USb which i add. I have a powered HUB but doesnt recognise any devices connected to it and i also just purchased a PCI 2.0 USB and no luck. Its fustrating as i need more usb ports.
    Friday, March 28, 2008 3:12 PM