locked
CRM 2013/2015 - Unable to debug Create message plugin for Activity Entities RRS feed

  • Question

  • Hi I am having some weird issue with 'Create' message based plugins for Activities.  I am able to hit the break-point on all other entities without any issues. Also the 'Update', 'Delete' etc messages for Activity plugins work. But just the 'Create' message Synchronous or Async mode is not working in CRM 2013/CRM 2015 environment. It works fine in CRM 2011 environment.

    I tried the following already...

    1. When registering for Sync mode, I connect to w3wp.exe (there are two of them in my machine, connected to both). When trying out the same for Async mode, I connected to CrmAsyncService (again I connected to both CrmAsyncServices available). None worked.

    2. I restarted the CrmAsyncService and IISReset, but no luck.

    3. I did fresh new deployment and then also pushed the DLL/PDB into Server\bin\Assembly folder. I can see the symbols are loaded and the break-point stays active, but did not get hit.

    Out of curiosity, I tried to even change the plugin to Update message and the debugging works. Not sure why it is not hitting the breakpoint for CREATE messages. These are pre-existing plugins from CRM 2011.

    Any suggestions?

    Sunday, June 14, 2015 10:48 PM

All replies

  • Are you trying to register on the generic activitypointer entity? Did you try on the specific activity type?
    Monday, June 15, 2015 8:20 AM
  • The plugin is registered on specific activity entities email, fax, phonecall etc.
    Monday, June 15, 2015 12:37 PM
  • Hi

    One alternative can be to use Itracing.

    But you can see tracing only when an exception is thrown. so you can add exceptions deliberately in you code by new Invalidpluginexecutionexception ...

    a bit more laborious than standard debugging, but you can know what is the course of action your code is taking

    Monday, June 15, 2015 2:53 PM
  • Ok Thanks, will try that out and update the thread. Thanks
    Monday, June 15, 2015 3:34 PM