locked
Front end server service RRS feed

  • Question

  • Hello there,

    I installed OCS 2007 Standard Edition on a windows 2003 SP2. So all the relating servers (A/V conferencing, web conferencing) are installed on the same server. When it tries to start the services, all the services start except the front end server service. Error: 3286842439 (0xC3E93C47).

     

    I read many posts about this subject but none of them helped me.

     

    Any help will be hugely appreciated.

     

    Thank you very much

    Tuesday, September 23, 2008 9:52 AM

All replies

  • I would take a close look at the certificate you created for the Front-End server and what the Subject Name and SAN values are.

     

    Typically the SN should be the server's FQDN (e.g. ocsserver1.contoso.com) and the SAN should include both the SN and the SIP domain(s) (e.g. ocsserver1.contoso.com,sip.contoso.com.sip.nwtraders.com).

    Tuesday, September 23, 2008 12:49 PM
    Moderator
  • Did you run all of the config checkers?

     

    Wednesday, September 24, 2008 3:28 AM
  • Hello there,

     

    Thank you all for the replies.

     

    To go deeper in details, i have a pc with windows server 2003 SP2 on it which is a domain controller (trial.com) and a DNS server.

     

    I have another pc with windows sever 2003 SP2 on it and i installed OCS 2007 Standard Edition on this pc. The OCS 2007 is a trial version downloaded from the microsoft website. So all the server roles are on the same pc.

     

    I created a certificate for the front end server using the certificate wizard in the setup.exe file of the OCS 2007 and i included the Subjext name as softdev3.trial.com (the pc where the OCS 2007 in installed on) and the SAN as sip.trial.com, and still the front end service doesn't run.

     

    I tried to use the SAN as softdev3.trial.com,sip.trial.com and still the service won't run.

     

    I installed the CA component on my domain controller first and the fron end service won't run.

    And another time i removed the CA from the domain controller and installed it on the pc where i have the OCS 2007 on it and still the fron end service won't run.

     

    When i check the event viewer of the office comunication server i get the following error while trying to start the fron end server service:

    Failed starting the protocol stack. The service has to stop.

    Error code is:0xC3E93C47

    (SIPPROXY_E_BAD_SERVER_CONFIGURATION)

     

    Any help will be hugely appreciated. SmileSmileSmile

     

    Thank you very much.

     

    Elliot Antoine Nehme.

    Monday, October 6, 2008 10:21 AM
  • One thing worth trying is to configure the Front-End service to use TCP instead of TLS and see if you can get it running that way, taking the certificate out of the scenario.  This is unsupported but since it's the only OCS server you aren't limited by the MTLS server-to-server communication requirements at the moment and can at least figure out if your server-configuration is 'bad' due to the certificate or something else.
    Monday, October 6, 2008 12:53 PM
    Moderator
  • Thanks Jeff for your help, but how can i configure the frond end service to use TCP instead of TLS ??

    Waiting for your reply to try it and hope it will work.

     

    Thanks a lot

    Monday, October 6, 2008 10:01 PM
  • Configure the Front-End Properties on the server object in the console and in the General tab you can enable (or add if missing) an entry for TCP on port 5060.  Then manually configure an OC client to use the server FQDN and TCP to attempt connection if you manage to get the services started.

    Monday, October 6, 2008 11:01 PM
    Moderator
  • Hey Jeff, thanks for the info, i tried it but the service didn't start... any other idea... i am wondering why it shouldn't start in the first place.

    Thanks a lot. Big SmileBig SmileBig Smile
    Tuesday, October 7, 2008 11:34 AM
  •  

    Hello there, please can anyone help me. I'll be very thankful.

     

    Thanks a lot.

    Wednesday, October 8, 2008 6:16 AM