locked
MSCRMAsyncService not working RRS feed

  • Question

  •  

    I noticed that the deletion service wasn't working on one of my CRM installs. I restarted the MSCRMAsyncService and get the following error in the Event log. I tried deleting all the "System Jobs" and workflows, and installed the hotfix in the KB article 950680 all to no avail. Does anyone know a solution?

     

    Thanks,

     

     

    Host PCCPLACRM01: error while processing organization 1899cca1-fa0b-dd11-ba65-00188b4bca0c. Exception: Microsoft.Crm.Metadata.EntityMetadataNotFoundException: The entity with ObjectTypeCode = 0 was not found in the MetadataCache.

    at Microsoft.Crm.Metadata.DynamicMetadataCache.GetEntity(Int32 entityCode)

    at Microsoft.Crm.Asynchronous.QueueDataAccess.GetEntityLogicalNameFromObjectTypeCode(Int32 objectTypeCode)

    at Microsoft.Crm.Asynchronous.QueueDataAccess.GetLookup(Object objectId, String objectIdName, Int32 objectDsc, Int32 objectTypeCode)

    at Microsoft.Crm.Asynchronous.QueueDataAccess.<>c__DisplayClass2.<SelectEvents>b__0(Object[] values)

    at Microsoft.Crm.Asynchronous.DataAccessBase.ExecuteSqlCommandAndProcessRecords(IDbCommand command, RecordProcessor recordProcessor)

    at Microsoft.Crm.Asynchronous.QueueDataAccess.SelectEvents(Int32 numberOfEvents)

    For more information, see Help and Support Center at

    Friday, May 30, 2008 4:51 PM

Answers

  • did you get the problem fixed?  One thing that I've seen is installing .net 3.0 rollup 1 can fix this issue.

     

    Sunday, October 12, 2008 7:12 PM
    Moderator