locked
OCS / Exchange 2007 Integration problem RRS feed

  • Question

  • Hi,

    I am having a problem with setting up OCS server to communicate with Exchange 2007.

    I have a simple lab with a DC running Exch 2007 with UM & the other server running OCS Standard Edition and is also the Certificate Authority - i have 2 laptops running OCS client software.

    I have installed OCS & Exchange as recommended by Microsoft - followed UM integration to the letter -  the clients can call, chat and have live meetings from PC to PC......but when it comes to forwarding to voicemail (i.e routing to exchange) the call disconnects.

    In the dubugging tool i get the error "The connection was closed before TLS negotiation completed. Did the remote peer accept our certificate?"

    In the event log i get "An attempt to route to an Exchange UM server failed. The attempt failed with response code 504. Check this server is correctly configured to point to the appropriate Exchange UM server. Also check whether the Exchange UM server is up and whether it in turn is also properly configured."

    Now i'm not the foremost authority on certificates but i have gone through them and all seems good.

    Has anyone come across this??

    Any help would be greatly appreciated.

    Tuesday, September 9, 2008 11:37 AM

All replies

  • After 3 days of head scratching and 1 hour after posting this thread i solved it myself.

    Ran Exchucutil.ps1 again & it fixed the problem

    Hoooray!!!!
    Tuesday, September 9, 2008 1:28 PM