locked
Crm 2011 Export managed solution -> view settings (inactive, active) not exported? RRS feed

  • Question

  • Hy

     

    When I export my unmanaged solution as a managed solution, the view settings of the account entity (for example if a view is active or inactive) doesn't get exported. So when I import this solution on another server, all views are active as default.

     

    Is this a bug?

     

    Thanks for your help,

    Peter

    Wednesday, June 29, 2011 11:24 AM

Answers

  • The behavior that you are experiencing is "by design."  Changing the status of a a view is considered an end use scenario, and not necessarily something that would be done by the solution developer - thus active/deactive state is not transferred.  This is good feedback though.  I will follow up with the feature team.

    Thanks,

    Brandon

    Tuesday, July 26, 2011 12:02 AM

All replies

  • Do you have other unmanaged solutions on the target server. Are you doing any unmanaged change directly on the target server.

    The fact is that Unmanaged layer always stays on the top, that may be causing this behavior


    Manny Grewal || Australia
    Thursday, July 14, 2011 12:09 AM
  • No I don't have unmanaged solutions on the target server...the target server has an organization, which was empty before importing the unmanaged solutions.

     

    By the way: Is there a site to report bugs/feature requests for crm 2011?

    Thursday, July 14, 2011 5:30 AM
  • The behavior that you are experiencing is "by design."  Changing the status of a a view is considered an end use scenario, and not necessarily something that would be done by the solution developer - thus active/deactive state is not transferred.  This is good feedback though.  I will follow up with the feature team.

    Thanks,

    Brandon

    Tuesday, July 26, 2011 12:02 AM