locked
CRM 2011 unexpected error trying to add steps to workflow RRS feed

  • Question

  • I am trying to add a new step to a workflow, when I tried to "save and close" after choose the condition, I got the error message is saying"Unexpected Error", the log file saying

    "Unhandled Exception: System.ServiceModel.FaultException`1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: Workflow does not contain a step with ID: indexOfDetail: 
    <OrganizationServiceFault xmlns:i="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/xrm/2011/Contracts">
      <ErrorCode>-2147220970</ErrorCode>
      <ErrorDetails xmlns:d2p1="http://schemas.datacontract.org/2004/07/System.Collections.Generic">
        <KeyValuePairOfstringanyType>
          <d2p1:key>CallStack</d2p1:key>
          <d2p1:value xmlns:d4p1="http://www.w3.org/2001/XMLSchema" i:type="d4p1:string">   at Microsoft.Crm.Workflow.ObjectModel.WorkflowStep.GetStepWithId(String id)
       at Microsoft.Crm.Workflow.ObjectModel.WorkflowStep.UpdateStepDescriptions(String descriptionXml, String defaultDescription)
       at Microsoft.Crm.Application.WebServices.WorkflowWebService.UpdateCondition(String activityId, String conditionXml, String entityId, String descriptionXml)</d2p1:value>
        </KeyValuePairOfstringanyType>
      </ErrorDetails>
      <Message>Workflow does not contain a step with ID: indexOf</Message>
      <Timestamp>2014-02-10T18:04:00.6609882Z</Timestamp>
      <InnerFault i:nil="true" />
      <TraceText i:nil="true" />
    </OrganizationServiceFault>"

    I tried log in with different administrator accounts from this computer, but get the same error. And my other two coworkers who are using the XP OS have no problem. My OS is windows 7 32x with IE10.

    Please help me figure out the solution.

    Thanks,

    Kai 


    • Edited by THS KAI Monday, February 10, 2014 7:55 PM
    Monday, February 10, 2014 6:34 PM

Answers

All replies