locked
Opening WHS Shared Folders Never Completes RRS feed

  • Question

  • I've had an annoying problem with Windows Home Server ever since I installed it.  I searched for a solution and have tried many things.  Sorry this is such a long post, but I want to provide as much information as possible.  I do most of my computing on the desktop, and the laptop is usually in hibernation mode.  The desktop is put in sleep mode when I am sleeping at night.  I use the home server as my file server, and keep all my documents there in the shared folders.

    So, here is my problem.  Symptoms that are known to be a WHS problem include the following:

    1. Periodically, from several times a day to once every few days, the shared folders will become inaccessible.   I will not know this unless I try to access them, or open any application that will look to the shared folders (either because the last document opened in the application was located in the shared folders, or because I have set a default location there).  There is no error message, the application just hangs.
    2. When this occurs, I can usually close the application with the 'x' at the top right (Windows Explorer), but I may have to answer to a "Not Responding Prompt" to close it, or open task manager and stop the application or process.
    3. When this occurs, I CAN open the console and get to the server, but CANNOT open the shared folders, even from the console.  I can ping the server, and remote desktop into the server (and open the shared folders that way).  Network Magic shows nothing wrong.
    4. When this occurs, opening Window Explorer immediately hangs because Windows Explorer defaults to "Libraries," and "Libraries" includes folders in the shared folders.
    5. When this occurs, no matter how many applications I shut down, no matter how many processes I stop, no matter how many services I stop, the problem is not resolved.  I can ONLY resolve the problem by rebooting the machine I am working on (rebooting the home server does NOT help).
    6. When this occurs, and I attempt to shut down or restart, windows 7 hangs on the blue "Logging Off" screen, and NEVER finishes logging off.  I left it running all night once, and it was still "Logging Off" in the morning.  I always have to use the power button to shut the machine down.
    7. When this occurs, it seems to occur on BOTH the desktop and the laptop.  Turning off one of the machines and restarting fixes that machine ONLY, the problem is still happening on the other machine.
    8. When this occurs, and after restarting the machine, the "Passwords do not match" error message pops up (even though I have synced the passwords many times).  Also, some settings on the rebooted machine seem to regress to the past (window size and locations for Skype, etc.).

    I have tried many things, including adding machine names and IP addresses to the hosts files on the laptop, desktop, and server.  I thought the problem might be related to an anomaly I noticed on the laptop.  The user on the laptop was one name, but the directory folder for that user under the "Users" directory was another name, and this other name was the same as the main user on the desktop.  I renamed the user on the laptop, created that user again, and deleted the directory with the incorrect name.  I also deleted the user that was renamed.  The laptop now has one user with a directory name that matches, and these are NOT the same as the desktop user any more.  The problem remains.

    I have also noticed that the "Passwords do not Match" message pops up every once in a while even when the problem has not occurred.  Also, although the nightly backups seem to be working OK, every once in a while, in the morning the desktop will be shut off instead of sleep mode.  When I start the machine, I get the "Windows did not shut down normally" screen as the machine boots up.  This has happened with the laptop as well.

    I am using WHS version 5.2.3790, software version v1.30(0940.005)

    I hope someone has some ideas!

    Thanks,

    Dave

    My configuration:

    Home network includes a QWest DSL modem/router (wireless turned off), Vonage device connected directly to the modem, a D-Link / Wireless Draft 11n Router DIR-635 connected to the modem as well.  The modem is the gateway for the 192.160.1.nnn network, and the D-Link is a client on that network.  The D-Link is the gateway for the 192.168.0.nnn network, and all other machines (except the Vonage device) are clients on that network.

    I have a linksys power-line network device connected to the D-Link router and to a power outlet.  The other Linksys device connected to the power lines is hooked up to a DirecTV DVR (media server) and Samsung Blue-Ray recorder.  Also connected directly to the D-Link router is an Acer Aspire home server (see stats below).

    Connected to the D-Link router wirelessly are a Desktop, and a laptop, both running Windows 7, and a D-Link network print server (stats below).

    The home server :

    Acer Aspire server, Phoenix Technologies LTD P03

    Intel Atom CPU 230 @ 1.6 GHz
    MS Windows Server Standard SP@
    2058 MB storage
    Marvell Yukon 88E8071 PCI-E Gigabit Etherney Controller (100.0 Mbs connection speed)
    The desktop

    Windows 7 Ultimate (x64) (build 7600)
    3.00 gigahertz AMD Athlon 64 X2 Dual Core
    128 kilobyte primary memory cache
    1024 kilobyte secondary memory cache
    64-bit ready
    Multi-core (2 total)
    Not hyper-threaded

    Board: ASUSTeK Computer INC. CROSSHAIR 1.XX
    Bus Clock: 200 megahertz, 4096 Megabytes Usable Installed Memory
    BIOS: Phoenix Technologies, LTD ASUS CROSSHAIR ACPI BIOS Revision 0502 01/02/2007 Maxtor 3 H500F0 SCSI Disk Device (500.11 GB) -- drive 1, s/n H81C2Q3H, SMART Status: Healthy
    ST350063 0AS SCSI Disk Device (500.11 GB) -- drive 0, s/n 9QG24JJ3, SMART Status: Healthy
    HL-DT-ST BD-RE BH08LS20 SCSI CdRom Device [CD-ROM drive]
    NVIDIA GeForce 8800 GTX [Display adapter]
    Acer X223W [Monitor] (22.0"vis, s/n LAV0C0514010, November 2008)
    Samsung SyncMaster [Monitor] (22.0"vis, s/n HVCP324366, March 2007)
    D-Link DWA-542 RangeBooster N Desktop Adapter Acer Inc. - Aspire easyStore Home Server Software Update Version 1.20.003 AxoNet Software GmbH - LightsOutClientService Version 0.8.2.234 Check Point Software Technologies - ZoneAlarm ForceField Version 1, 5, 53, 4
    Check Point Software Technologies LTD - TrueVector Service Version 9.1.008.000
    Check Point Software Technologies LTD - ZoneAlarm Client Version 9.1.008.000
    Check Point, Inc. - ZoneAlarm Uninstaller Version 9.1.8.1
    Cisco Systems, Inc. - Network Magic Version 5.5.09170.0
    Cisco Systems, Inc. - Pure Networks Platform Version 11.2.09170.0
    Microsoft Corporation - Internet Explorer Version 8.00.7600.16385
    Microsoft Corporation - Windows Installer - Unicode Version 5.0.7600.16385
    Microsoft Corporation - Windows® Search Version 7.00.7600.16385
    Microsoft ® Windows Script Host Version 5.8.7600.16385
    Microsoft® .NET Framework Version 2.0.50727.4927
    Microsoft® .NET Framework Version 3.0.6920.4902
    Microsoft® Windows® Operating System Version 12.0.7600.16385
    MindVision Software - Installer VISE Version 3, 7, 0, 0
    Mozilla - Sunbird Version 0.9
    Mozilla Corporation - Firefox Version 3.6.3
    Mozilla Messaging - Thunderbird Version 3.0.4 NVIDIA Driver Helper Service, Version 196.21 Version 8.17.11.9621
    OpenOffice.org 3.1
    OpenOffice.org 3.2 Version 3.02.9476
    OpenOffice.org Base Version 3.02.9476
    OpenOffice.org Calc Version 3.02.9476
    OpenOffice.org Draw Version 3.02.9476
    OpenOffice.org Impress Version 3.02.9476
    OpenOffice.org Math Version 3.02.9476
    OpenOffice.org Writer Version 3.02.9476
    OpenOffice.org Writer(Web) Version 3.02.9476
    Skype Extras Manager Version 1.0.0.0
    Skype Version 4.2
    Sun Microsystems, Inc. - Java(TM) Platform SE 6 U18 Version 6.0.180.7
    Sun Microsystems, Inc. - Java(TM) Platform SE Auto Updater 2 0 Version 2.0.1.2

    MSXML4SP2
    KB954430 on 1/2/2010
    KB973688 on 1/2/2010

    Windows 7
    KB971033 on 2/25/2010
    KB971468 on 2/10/2010
    KB972270 on 1/14/2010
    KB973525 on 12/31/2009
    KB974332 on 12/31/2009
    KB974431 on 12/31/2009
    KB974571 on 12/31/2009
    KB975364 on 12/31/2009
    KB975467 on 12/31/2009
    KB975560 on 2/10/2010
    KB976098 on 12/31/2009
    KB976264 on 3/11/2010
    KB976325 on 12/31/2009
    KB976662 on 2/24/2010
    KB976972 on 1/27/2010
    KB977074 on 1/27/2010
    KB977863 on 2/24/2010
    KB978207 on 1/22/2010
    KB978251 on 2/10/2010
    KB978262 on 2/10/2010
    KB978506 on 1/27/2010
    KB978637 on 2/24/2010
    KB979099 on 2/10/2010
    KB979306 on 2/24/2010
    KB980182 on 3/31/2010
    KB980302 on 3/24/2010

    Laptop:

    Gateway M-1631U
    Windows 7 (x64 Home Preimum), 54Mbs connection speed
    AMD Turion 64 X2 Mobile Technology TL-60
    3968 MB RAM

     


    David A. Desautel dadepfan@desautel.net Desautel.net! http://desautel.net The Boomer Blog! http://boomer-blog.com The Reverse Spin! http://reverse-spin.com
    Friday, April 9, 2010 12:27 AM

All replies

  • What component versions are reported in the Windows Home Server console, Settings tab, Resources view?
    I'm not on the WHS team, I just post a lot. :)
    Friday, April 9, 2010 4:00 AM
    Moderator
  • Hi Ken

    Here are the versions:

    Windows Home Server Console: 6.0.2423.0
    Windows Home Server Backup & Restore: 6.0.2423.0
    Windows Home Server Drive Extender: 6.0.2423.0
    Windows Home Server Remote Access: 6.0.2423.0
    Windows Home Server Storage Manager: 6.0.2423.0

    Dave

    David A. Desautel dadepfan@desautel.net Desautel.net! http://desautel.net The Boomer Blog! http://boomer-blog.com The Reverse Spin! http://reverse-spin.com
    Friday, April 9, 2010 2:47 PM
  • I may have solved my shared folders problem, though I still do not know what was causing it.  After reading on another forum that deleting the users on WHS and then re-creating them helped someone else with a similar problem, I gave it a try yesterday morning.  24 hours later, the problem has not returned.  This is not definitive, but a good sign (considering this was happening multiple times each day).  I will update this thread if the problem comes back, or end it when the problem has not happened for long enough for me to consider it gone.

    Thanks,

    Dave
    David A. Desautel dadepfan@desautel.net Desautel.net! http://desautel.net The Boomer Blog! http://boomer-blog.com The Reverse Spin! http://reverse-spin.com
    Sunday, April 11, 2010 3:14 PM
  • This only helped for a couple of days.

     

    Dave


    David A. Desautel dadepfan@desautel.net Desautel.net! http://desautel.net The Boomer Blog! http://boomer-blog.com The Reverse Spin! http://reverse-spin.com
    Wednesday, April 21, 2010 4:08 PM
  • Hi Dave

    You are NOT alone - I'm having the same problem with a new PC added to my net. It runs Win 7 Pro and when accessing the shared folders it displays about 20-30 image icons in a folder and then just stops. At the address bar if I select one of the folder tabs it just displays "Computing Items" (greyed) insted of showing the sub-folders. The picture folders on the C:\ drive display just fine, it's just with the shared folders from WHS. I've loaded 64 and 32 bit win 7 OS with same result. I've only loaded the OS and updates along with MB driver updates for Zotac ionitx-a-u with 4gig ram on a wired lan.

    I hope someone comes along with a solution

    Tuesday, April 27, 2010 2:15 AM