locked
CRM 4 Custom Report Views RRS feed

  • Question

  •  

    I have tried to create a custom view for my reports under customizations and am getting nowhere. After I created the view with a Name and Description column and a filter for custom reports I published the Report entity. I can see it in the dropdown list Workplace > Reports > View. But I cannot see it to move a custom report to that area and if I create a view in that area I get an error message. Any suggestions/pointers will be appreciated.

    Wednesday, September 17, 2008 10:41 PM

Answers

  •  

    I think this is the error massage you got. If you get this error, the reason probably is that you neglected to add the “Report Type” column to your report views. Once you add the column to your view, it should work.

    Have a great day !
    Thursday, August 6, 2009 5:47 AM

All replies

  • Please post the error message.

     

    Thursday, September 18, 2008 1:47 PM
  •  

    The error is generic and also the error log contains no errors.
    Friday, September 19, 2008 2:28 PM
  • Yup, get this too. My report view only shows the report name and tries to filter on "Report Related Categories (Report)" with a Category equals to a specific category name, because I want the default view for Reports to show only our custom reports. An Advanced Find with exactly the same criteria works just fine, but the view blows up. And oasisaplus wasn't kidding, the error is very generic:

     

    "An error has occurred. Try this action again. If the problem continues, check the Microsoft Dynamics CRM Community for solutions or contact your organization's Microsoft Dynamics CRM Administrator. Finally, you can contact Microsoft Support."

     

    That's it - no event log message, nothing. So I am here because that's the first thing the message says, and since I am the CRM administrator I have already been in contact with me.

     

    Any ideas?

    • Proposed as answer by toTheja Thursday, August 6, 2009 5:44 AM
    Saturday, January 24, 2009 3:53 PM
  •  

    I think this is the error massage you got. If you get this error, the reason probably is that you neglected to add the “Report Type” column to your report views. Once you add the column to your view, it should work.

    Have a great day !
    Thursday, August 6, 2009 5:47 AM
  • Hello friends, when i got the above error msg i apply above mentioned solution and it was work for me. but when i add new report to relevant category and save it, not come to that report to the relevant view when i select it.


     Any ideas?

    Have a Great day !
    Thursday, August 6, 2009 5:53 AM
  • Hi
    I was geeting the same error and it worked for me once I added the report type column.
    Can anyone explain the reason for why the custom view throws eror without report type ?

    Thanks

    Shilpa Sharma
    Friday, August 14, 2009 12:31 PM