locked
Direct Email to Multiple Contacts RRS feed

  • Question

  • We recently upgraded to CRM 2013 (on-premise).  Since the upgrade, the "Send Direct Email" feature appears to only work for a single contact.  If we send direct email to a SINGLE contact, then the email activity is created and the email is sent successfully.  If we select multiple contacts and use the direct email feature, no activities are created and no email messages are generated.  

    Has anyone experienced this?  

    I have seen older posts for the same issue, but those were for earlier versions of CRM and the issue was fixed by a rollup. We are already on the latest version of CRM 2013.  

    Thanks!

    Friday, January 3, 2014 10:13 PM

Answers

  • Hi Payman -

    Thanks for testing this out.  We were able to resolve the issue on our own.  

    In case anyone else faces this issue, the "Send Direct Email" feature behaves differently in these two scenarios.  When you select a single contact, the activity is created immediately.  When you select multiple contacts, a System Job with the name "Bulk Email" is used to asynchronously create the activities.  It turned out that the system jobs in our environment were failing due to a missed step in the upgrade process.  

    • Marked as answer by DDMC Saturday, January 4, 2014 6:03 PM
    Saturday, January 4, 2014 6:02 PM

All replies

  • Hi,

    I have tested the conditions you mentioned. I have the same problem also! You may open a ticket for this issue.

    Saturday, January 4, 2014 2:54 PM
    Moderator
  • Hi Payman -

    Thanks for testing this out.  We were able to resolve the issue on our own.  

    In case anyone else faces this issue, the "Send Direct Email" feature behaves differently in these two scenarios.  When you select a single contact, the activity is created immediately.  When you select multiple contacts, a System Job with the name "Bulk Email" is used to asynchronously create the activities.  It turned out that the system jobs in our environment were failing due to a missed step in the upgrade process.  

    • Marked as answer by DDMC Saturday, January 4, 2014 6:03 PM
    Saturday, January 4, 2014 6:02 PM