locked
Windows Installer Service error on Vista x64 Connector Install RRS feed

  • Question

  • When trying to install the connector on my x64 Vista machine this morning I keep getting "The Windows Installer Service could not be accessed" Error, and the install won't finish.  I have successfully updated the connector software on my other XP machines using the updated connector in Server\Software so I am assuming the connector software updated properly after installing PP1. 

    I have tried copying the connector software onto my machine and running the setup vs. WHSConnectorInstall (although it will successfully download the connector software off the server and attempt install as well).  It will not however let me run the x64.msi independently and instead says I must run it through setup.exe

    I downloaded KB942288 and updated to the latest Windows Installer 4.5, still no luck.

    Have checked to make sure the msiexec service is running.

    Ran SFC, no faults found. 

    Any thoughts or suggestions would be appreciated.


    moved from Software Forum
    Tuesday, June 10, 2008 6:22 PM

All replies

  • Can you please grab the logs from this PC and put them in a zip file and create a bug in Connect referencing the CAB file.  The team needs the logs to troubleshoot the issue.

     

     

    Vista machine:
    %SystemDrive%\ProgramData\Microsoft\Windows Home Server\logs

     

    Tuesday, June 10, 2008 7:35 PM
  • Thank you for submitting a bug report via Connect with a Zip of your log files.  The team will contact you through Connect if they have additional questions

     

    Tuesday, June 10, 2008 10:01 PM
  • Thank you addressing my problem, I did play around with it some more this evening and tried running Vista repair console, re-registered msiexec in Syswow, and also tested some MS Office Component .msi installs to see if it was an installer error, but they worked properly. 

    Still won't complete.



    Wednesday, June 11, 2008 12:23 AM