locked
How to get sensor description by name? RRS feed

  • Question

  • I'd like to get sensor information by name from sensormap that I registered.
    Could you anyone can tell me how to implement it? I attached the source code.
    When I publish this code, I got the error (Error 1 Failed to connect to 'https://atom.research.microsoft.com/sensordatahub/service.asmx/' with the following error: Unable to create the Web 'https://atom.research.microsoft.com/sensordatahub/service.asmx/'. The Web server does not appear to have the FrontPage server extensions installed. 1 1 sensorPublisher).

    Thank you in advance.
    Seungweon.

    ---------------Program.cs----------
    using System;
    using System.Collections.Generic;
    using System.Text;
    using System.Drawing;

    using MSRSense.Sensors;
    using SWLib;

    using sensorPublisher.com.microsoft.research.atom;

    namespace sensorPublisher
    {
        class Program
        {
            static void Main(string[] args)
            {


                string publisherName = "sensormap_id";
                string password = "password";
                string sensorName = "sensor_name";
                DataHub mySensorMap = new DataHub();

                string response;
                response = mySensorMap.GetSensorDescriptionByName(publisherName, password, sensorName);
                Console.WriteLine("Registration response = " + response);

            }
        }
    }

    -------------------------------------------
    Tuesday, May 29, 2007 8:08 PM

Answers

  • Well, I misunderstood When I run the app. using SensorMap API. I just run it by Ctrl + F5 not "publish ...". Thank you so much.
    Thursday, May 31, 2007 5:44 AM

All replies

  • You can't have the last '/' in the URL. Try this: https://atom.research.microsoft.com/sensordatahub/service.asmx

     

    Jie

    Wednesday, May 30, 2007 2:23 AM
  • Thank you for answering. However, Visual Studio 2005 automatically put '/' at the end of that server URL. I don't know why that is happening. I doubt that VS 2005 has a bug, so I installed VS 2005 SP1, but same.

    Should I give some option when I publish to SensorMap in VS 2005?

    Thank you,
    Seungweon.
    Wednesday, May 30, 2007 11:10 PM
  • Well, I misunderstood When I run the app. using SensorMap API. I just run it by Ctrl + F5 not "publish ...". Thank you so much.
    Thursday, May 31, 2007 5:44 AM