locked
CRM 4.0 Outlook Client installed, but configuration not possible (another user) RRS feed

  • Question

  •  

    We have the Outlook Client installed on a number of workstations for CRM 4.0 in Laptop mode (offline access) and whilst the installation went OK, when we select to configure Microsoft Dynamics CRM for Outlook, we get the following message on all machines:

     

    "Microsoft Dynamics CRM for Outlook with Offline Access has already been configured for a user on this computer. Only one use can be configured per computer for Microsoft CRM for Outlook with Offline Access."

     

    We uninstalled the offline access version of the CRM 3.0 Client on all these machines AND completely removed the SQL Outlook Database and the entire SQL Server install prior to installing the client. I cannot understand how any traces of any existing user would exist.

     

    Can anyone advise where this information is stored, so we can get rid of the current user?

     

    - Jeremy

    Wednesday, January 23, 2008 12:40 AM

Answers

  • I logged in to the database with SQL Manager and deleted the CRM databases.  That allowed me to configure CRM 4.0 Outlook client without having to do any of the more dangerous system changes suggested previously.  Good luck to everyone else.

    Saturday, February 2, 2008 3:16 AM

All replies

  • Dear Jeremy

     

    In the following article it is mentioned how you can use that for CRM 4.0

    http://support.microsoft.com/kb/947089/en-us?spid=12976

     

     

    Best Regards,

    Imran

     

    http://microsoftcrm3.blogspot.com

     

    Wednesday, January 23, 2008 5:25 AM
    Moderator
  • Sorry Imran

     

    That relates to a completely different issue with a different error message.

     

    In our case, the installation went fine, but it cannot be configured. We do not get the message mentioned.

    Wednesday, January 23, 2008 7:59 AM
  • I would just say that we have exactly the same problem.

    Wednesday, January 23, 2008 2:40 PM
  •  

    It looks to me like you reinstalled CRM 3.0 for outlook before install CRM 4.0 outlook client, but the uninstall wasn't quite complete(e.g: in registry it still has CRM 3.0 for Outlook Client information)?

     

    Jim

    Wednesday, January 23, 2008 4:31 PM
    Moderator
  • Hi,

     

    We did uninstall V3.0 client on all machines and manually uninstalled the database also. These uninstalls completed correctly.

     

    Any ideas what registry entries or other rubbish we need to remove to allow the configuration of V4.0 client to work? This is a big problem for us, given it is the same for every client.

     

    We cannot install the V3.0 client and try an upgrade, since there is no V3.0 server to connect to.

     

    - Jeremy

    Monday, January 28, 2008 12:34 PM
  • Same for me.

    I uninstalled correctly the old client, but the new wont allow me to configure...

     

    Monday, January 28, 2008 5:25 PM
  • Monday, January 28, 2008 5:41 PM
    Moderator
  • My company also have this same error after we removed our old version 3 clients instead of upgrading. 

    Because we receive the same error when we run the configure CRM button within Outlook we cannot run the diagnostics either.  Any other thoughts would appreciated.

    Tuesday, January 29, 2008 9:32 AM
  •  

    I already did it: it replies "CRM for Outlook has not been configured. Run the CRM configuration wizard and then rerun CRM diagnostics"!!!

    <:-(

    ALberto

    Tuesday, January 29, 2008 9:40 AM
  • We are not getting very far. Clearly there is a bug in the upgrade, in that if the V3.0 client is uninstalled before the V4.0 install is performed, the client cannot be configured - and many of us are stuck completely!

     

    We cannot run the diagnostic tool, since the initial configuration has not been run (and cannot be run).

     

    Is there any help from a CRM guru who knows what to fudge to get the client able to be configured?

    Tuesday, January 29, 2008 11:06 AM
  •  

    Suffering from this problem badly ourselves, and it's not helping us in trying troubleshoot the log on process to CRM we also have by using the local Outlook Client either! I suspect are Outlook remote clients will work, but the in-house ones using the local client won't!

     

    Any contributions to this topic gratefully received...

     

    Polescat

    Wednesday, January 30, 2008 10:13 AM
  • We are having exactly the same problem, but only with laptops that were running CRM 3.0 offline version before. The desktops that had the online version installed upgrade just fine (well not really an upgrade as I had to uninstall CRM 3.0 Client first).


    Paul J Shadwell
    Wednesday, January 30, 2008 10:13 AM
  •  

    We are also having this problem, It's happening on a laptop, offline version, Vista + Office 2007 SP1

     

    I also tried deleting the Outlook profile data from the application data folder. This didn't help.

    Wednesday, January 30, 2008 11:12 AM
  • An update on my companies situation.

     

    We have completed the following tests to no avail:

     

    1. Removed Outlook Profile. Nothing.

    2. Removed Windows Local Profile. Nothing

    3. Added local CRM server as a secure site. Nothing.

    4. Updated Outlook 2007 to latest patch level. Nothing.

     

    When we upgraded the remaining CRM 3 clients to CRM 4 they all worked 100% fine.

     

    This only appears to be affecting new/offline CRM Users.

     

    I hope this saves time for other people.

    Wednesday, January 30, 2008 2:55 PM
  • We are having the exact same problem with a machine here.  Here is how I ran into the problem:

     

    1.  Uninstalled CRM 3c

    2.  Installed CRM 4

     

    I also tried to uninstall 4 and reinstall, but end up with the same problem.

     

     

    Wednesday, January 30, 2008 5:28 PM
  •  

    I've logged a support incident with Microsoft, I'll let you guys know the outcome.

     

    Just about to have another go after removing CRM registry entries/CRM program folder/SQL/outlook profile.

     

    Thursday, January 31, 2008 9:17 AM
  • I will try the following:

     

    1. Remove all MSCRM registry entries, CRM program folder, SQL and Outlook profile. Install Offline Client. Result?

    2. If it installs but doesn't allow configuration, Apply SQL Express SP2, try again. Result?

    3. Try removing all entries again, install using the Online client. Result?

    4. If No.3 was successful, try installing the offline client over the top. Result?

     

    Let me know if you've done any of these already!

     

    Thursday, January 31, 2008 9:23 AM
  • Good news guys!

     

    No.1 on my previous post fixed both issues, the first being that it would not complete the install and would rollback, secondly it resolves the configuration problem! All working for me on Vista.

     

    To reiterate what I did:

     

     -  Uninstalled SQL completely and deleted the 'Microsoft SQL Server' folder under 'Program Files'

     -  Remove 'Microsoft Dynamics CRM' folder completely, if any files are locked, try using 'Unlocker 1.8.5' (Google it)

        I did not have an option to remove the CRM client in Add/Remove Programs as it didn't install correctly, if you do, make sure you run the uninstall first.

     

     - Ran 'regedt32' and searched the registry for all keys/values/data for 'MSCRM' and removed all of them. Remember to backup your registry just in case! (I didn't)

     - Removed the Outlook profile from the user's application folder. First delete the profile by going to Control Panel > Mail > Profiles. Then remove the files. Don't forget to back up these files in case there is a .pst in there somewhere (i.e archive or personal folder). These will be in the following locations:

     

    For Vista:

     

    C:\users\<username>\appdata\roaming\microsoft\outlook

    C:\users\<username>\appdata\local\microsoft\outlook

     

    For XP - I'm pretty sure about these but not using XP right now so it's only from memory...

     

    C:\Documents and Settings\<username>\Application Data\Microsoft\Outlook

    C:\Documents and Settings\<username>\Local Settings\Application Data\Microsoft\Outlook

     

     

    - Restart PC and run the install again. Let me know if it works or not - party.marty 'at' hotmail.com

    Thursday, January 31, 2008 9:51 AM
  • Just fixed a second vista laptop that only had the configuration problem, so it looks like a good workaround.

    Thursday, January 31, 2008 10:38 AM
  • Just want to confirm that the above worked for me, with a slight difference.

     

    As I am running several Instances on my machine I did not want to unin-stall SQL Express completely. I eventually removed all references to the particular databse (CRM) from the registry, delete the instance directories and managed to reinstall successfully.

     

    Bear in mind that you will need to search for CRM, MSCRM, $CRM etc etc when you scour regedit to find the keys to delete, otherwise it will fail.

     

    I'm convinced now that the problem is due to SQL Express, but removed the Outlook profiles just to be sure. At least this way I didn't screw up any other instances of SQL, most of the other guides have suggested removing the SQL program folder completely, but it isn't actually necessary.

     

    Now to fix my original problem which means I can't configure Dynamics due to 401 errors being reported when it tries to connect to the server - any ideas!?

     

    Polecat

     

    Thursday, January 31, 2008 2:46 PM
  • You're right about the SQL instance, it's just I assumed these CRM users will know that

     

    Have you seen this KB Polecat? http://support.microsoft.com/kb/917818   Look very close to what you're referring to.

     

     

    Thursday, January 31, 2008 2:56 PM
  • Hi PartyMarty,

     

    Can't believe I didn't find that KB article myself, it really convinced me for a minute that we had fixed it, because Kerberos authentication wasn't set on the Website in IIS. If it had worked, you could pretty much have named your price!

     

    After the reboot, we still have the same problem with the Outlook client though.

     

    We don't use host headers, or a default website. We just deleted the default and created a new site when we installed CRM 3.0. (we upgraded btw from V3).

     

    One interesting thing, is that if authentication on the site is set to Integrated Authentication, the Web Client doesn't work. Set to basic, it does fine. Might also be worth pointing out that there is an SSL cert on the server (CRM can be accessed via HTTP or HTTPS in our environment), which I have previously removed for troubleshooting purposes, so I'm sure it's not that...

     

    Output from IISLOG - this is the 401 error when I try to connect.

     

    xxx.xxx.xxx.xxx POST /MSCRMServices/CrmQuery.srf - 80 - 192.168.0.54 VCSoapClient 401 1 0

     

    I even looked in the MSCRM_CONFIG database Deployment.Properties table to check that the server name & port are correct, and they are.

     

    Stumped, anyone else come across this?

     

    Polecat 

     

     

    Thursday, January 31, 2008 4:02 PM
  • So when you go to the properties of the CRM Website >Directory Security > First 'Edit' button 

    does it not have integrated windows auth ticked? Ours does.

     

    http://blogs.msdn.com/david.wang/archive/2005/07/14/HOWTO_Diagnose_IIS_401_Access_Denied.aspx

     

    Don't know if the 401.1 descriptions help at all in the above link...prob seen this site already.

     

    Thursday, January 31, 2008 6:23 PM
  •  

    Also, try enabling integrated windows auth and using Firefox, it won't work but it'll ask you to upgrade your browser if it connects OK. If it does, could be a group policy change for IE security zones maybe?

     

    Try checking Control Panel > Users > somewhere in there is 'Managed Passwords'. See if there is an entry for the CRM server and delete.

    If there isn't then it also might be worth trying to add one as a workaround with the correct login details....

     

    I just added a fake login for this and it came up with the 401 error when connecting to the web client.

    Thursday, January 31, 2008 6:41 PM
  • Well, fixed it!

    Not easy mind. Had to do a lot of trawling and cross referencing.

    What I *think* the problems were:

    a) Previous V 3 CRM was configured with internal and external DNS FQDN's, as we were using SSL on the website for external users. This didn't help troubleshoot the problem, and packet sniffing using Wireshark showed a few problems with the internal (.local) domain being returned when connecting remotely. It led me to think there was something wrong with domain authentication..

    b) What then surprised me the most was that we were running our AD in Windows 2000 mode, and I had forgotten about that as we still have some old NT4 machines lying around and we had never bothered to raise the Forest Functional Level to Windows 2003. I was led to this area of investigation by re-examining the CRM 4 installation logs and noticing a warning that we had not thought about on installation. This was "Verify Domain User account SPN for the Microsoft Dynamics CRM ASP.NET Application Pool account."

    The user account we had created for V3 CRM was certainly a domain user account of course, and CRM Application Pool was running under it with no problems at all as the Web Client was working just fine, or so we thought...

    By reading through this (although they refer to CRM 3, they are still relevant) -

    http://www.microsoft.com/downloads/details.aspx?FamilyID=51BF9F20-BD00-4759-8378-B38EEFDA7B99&displaylang=en

    & this

    http://blog.sonomapartners.com/2007/04/kerberos_and_de.html (excellent by the way)

    I realised that the domain accounts we had set up to run CRM & SQLSERVER were not trusted for User Account Delegation. (this wasn't possible as we had been running in Windows 200 Functional Level). So Kerberos & NTLM authentication on the CRM Website weren't working correctly for these accounts. What strikes me as quite odd is that this should not have been a problem because both accounts were in the correct SQL & CRM AD Groups and SQL and CRM are installed on the same server. The scenarios in the documents above are designed for when the applications are split between different servers.

    Once I had set up the SPN's and delegated the accounts with the correct authentication settings in ADSIEDIT / ADU&C both Outlook Lite & Outlook offline all started working as they should.

    Thanks very much for your help, without that link to David Wangs blog, I would never have started looking at Kerberos related troubleshooting - I owe you one!

    Polecat
    Friday, February 1, 2008 2:19 AM
  • No probs, I wish you had mentioned that warning in the log earlier as we had it too!

     

    Friday, February 1, 2008 9:18 AM
  • Doh!

     

    Yeah, it was a late night upgrade, the memory is not so good in the early hours.

     

    A bit more of an update, forget the a) scenario in my previous post. We put the SSL cert back and added another host name (to match the cert name) for the server in DNS and all is still good. Basic and Integrated Authentication is working fine on the CRM website and external users can access the server using Outlook client or Web client.

     

    TFI Friday!

     

    Friday, February 1, 2008 1:48 PM
  • I logged in to the database with SQL Manager and deleted the CRM databases.  That allowed me to configure CRM 4.0 Outlook client without having to do any of the more dangerous system changes suggested previously.  Good luck to everyone else.

    Saturday, February 2, 2008 3:16 AM
  • All,

     

    We have the same problem and tried all the suggested. Is there any way to resolve this?

     

    Thursday, February 28, 2008 8:43 PM
  • I would say that the previous posts all have good methods of resolving this problem. Just to add an extra bit of information, I had a problem with a Terminal Services user and none of the above worked, bar one little detail from Euneeq's post, and that was to remove the users local profile from the Terminal Server (after doing everything else) and it worked from thereone in.

     

    Have a look at the output from the CRM / Outlook installer log files in the Application Data folders for that users profile, they can be quite useful for clues.

    Friday, February 29, 2008 9:17 AM
  •  

    It's probably because you didn't delete the MSCRM folder under the user's roaming profile folder. Think i missed that out in my explanation...
    Friday, February 29, 2008 10:24 AM
  • Well, that's what I thought...

     

    When I removed the CRM client, the only items left in that particular folder were log files and nothing else, it still didn't work correctly so I left the log files alone. The real clue was that a bucket error was being reported in the Outlook errors file (this also shows up when you enable the 'Support' diagnostics in the CRM configuration wizard).

     

    It reported a MAPI subsytem error, so I knew it wasn't anything to do with CRM and that it was an Outlook problem.

    Friday, February 29, 2008 10:40 AM
  •  

    That probably would have been the outcmd.dat file as that has the plugin info. Removing that file fixes other issues anyway, like 'CRM could not connect to the server' or something similar.
    Friday, February 29, 2008 10:44 AM
  • Excellent, this worked for me, thanks PartyMarty, don't know what I would of done without you!
    Tuesday, May 19, 2009 1:33 PM
  • A standard uninstallation of the CRM 4.0 for Outlook client, then Express SQL Server via add/remove programs. And reinstallation of CRM 4.0 for outlook client worked for me.

    - We had no CRM 3.0 for Outlook client previously on the subject machine.

     

    I think as a feature suggestion - CRM 4.0 for Outlook client with offline access *should* support multiple users.


    Sun - MSCRM Specialist @ Intergen, Sunny (slightly breezy)Wellington, New Zealand. http://sundium.wordpress.com
    Wednesday, July 14, 2010 6:20 AM