locked
Microsoft Dynamics CRM on premise "Unable to access the MSCRM_CONFIG.." RRS feed

  • Question

  • Whenever I try to run Microsoft Dynamics CRM Deployment Manager it give me the error "Unable to access the MSCRM_CONFIG database. SQL Server does not exist or access denied." While I can login into Microsoft SQL Server Management System using username "sa" and password "BLAHBLAHBLAH", it shows under the database "MSCRM_CONFIG" it is there. So I don't know exactly how do I grant the CRM Deployment Manager permission to access that database. I have tried to create a user through active directory which is in SQLAccess Group and Domain Users but when I try to login using that user name in Microsoft SQL Server Management System it give the Login Failed SQL Server error: 18456 if use username "sa" it does login to the SQL Server Management System but The CRM Deployment Manager gives the error mentioned above about MSCRM_CONFIG access. 

    Please help me Solve this problem! 

    Monday, July 7, 2014 10:54 AM

All replies

  • Hi,

    you can try to watch this links:

    http://msdn.microsoft.com/en-us/library/gg197631.aspx

    http://blogs.msdn.com/microsoft_blog_images/b/permission_denied_erroraccessing_organizationservicesvc_from_js_in_crm_2011/archive/2013/04/23/fixed-quot-unable-to-access-the-mscrm-config-database-sql-server-does-not-exist-or-access-denied-quot-in-crm-2011.aspx

    http://hinamehta14.wordpress.com/2012/08/22/fixed-unable-to-access-the-mscrm_config-database-sql-server-does-not-exist-or-access-denied-in-crm-2011-2/

    Bye

    A.G.


    Alessandro Graps

    Monday, July 7, 2014 11:51 AM
  • Well, after adding user from active directory to the SQLAccess Group, when I move to the 2nd step run CRM Deployment Manager It gives me the same error "Unable to access the MSCRM_CONFIG database. SQL Server does not exist or access denied." While every link you provided add user to the Deployment Manager, I can't do this after even adding the user to the SQLAccess Group?

    When MSCRM Deployment Manager runs which credentials it uses to login to the SQL? Where and how do I change that? 

    I tried to add MSCRMSqlClrLogin to the MSCRM_CONFIG>Security>User add new user and add that there but still when I run the Deployment Manager it gives me the same error.


    Rana Muhammad Waqas



    Tuesday, July 8, 2014 8:06 AM
  • Hi,

    I had the same problem. Here you can find my solution:

    https://nothingnessit.wordpress.com/2016/03/09/error-message-when-you-try-to-log-on-to-microsoft-dynamics-crm-cannot-open-database-organization_mscrm-requested-by-the-login-after-restart-server/

    Thanks

    Alessandro


    Alessandro Graps

    Tuesday, March 15, 2016 11:22 AM