locked
Deployment errors RRS feed

  • Question

  • Hi,
    I am actually trying the MSF because it sounds more than nice =)
    I developped a N-Tier application to synchronize data between sql server and sql ce. I followed some tutorials to do this and everything seems fine.
    But of course I get some problems ....
    First I deployed my application on the VS emulator and it said that i maybe got a wrong version of sql so he can't create a database ... ok let's check this out.

    And now when i deploy my application, VS start to load many files like System.EnterpriseService.dll, System.Transactions.dll etc ... to finally announce that is there not enough space to deploy my application ...

    So my first question is :
    does this type of dll is needed for MSF application ? Why has it work the first time and not the others ? Sad

    I tried to deploy my application directly on my pocketpc this time because it has more space. The deployment succeed, but when i click on my button which launch the synchronization, the prog don t even enter in the code of the button it does nothing and after 3 min an exception is catched :

    Can t load type 'Microsoft.Synchronization.Data.SqlServerCe.SqlCeClientSyncProvider' from assembly 'Microsoft.Synchronization.Data.SqlServerCe, Version=1.0.0.0, Culture=neutral

    I tried with the versions 1.0, 2.0, 3.5 of this file but it always saying the same thing ...

    If anybody got an idea i'll take it

    Thanks in advance

    Sam

    Ps : Sorry for my english level, i am french and i started c# a month ago.
    • Moved by Max Wang_1983 Friday, April 22, 2011 7:36 PM forum consolidation (From:SyncFx - Microsoft Sync Framework Database Providers [ReadOnly])
    Thursday, May 15, 2008 12:15 AM

Answers

  • Well after re installing the all component the error disappear ...
    Thanks very much for your active help Yunwen
    Wednesday, May 21, 2008 7:51 PM

All replies

  •  

    Hi Sam,

     

    where do you get the device bits ? did you download the and installed them from http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=2957116&SiteID=1 ?

     

    thanks

    Yunwen

    Friday, May 16, 2008 12:19 AM
    Moderator
  • Hi,
    thanks for paying attention.
    Yes I already download and install SyncServices.msi, also CTP2SyncServicesADO_x86 and CTP2SyncSetup_x86.
    Do you see why i get that error of loading ?

    Thanks

    Sam

    Friday, May 16, 2008 9:10 PM
  • No, I don't have a clue yet.

     

    have you tried the sample from that website ?

     

    could you create a very simple project just have serveral line of code such as:

     

    SyncAgent agent = new SyncAgent();

    SqlCeClientProvider cp = new SqlCeClientProvider();

     

    please also make sure your project references to the right Microsoft.Synchronization.Data.dll and Microsoft.Synchronizationl.Data.SqlserverCe.dll.

     

    thanks

    Yunwen

     

    Friday, May 16, 2008 11:17 PM
    Moderator
  • I ve just read the Readme file and it says that VS2008 is needed and i ve got only VS2005.
    I come here by searching answers to my problem through search engine and i didn t realize that i am in the "Visual Studio 2008" section ... : /
    I am really sorry can i keep my question here or do i have to move to the 2005 section ?

    In the case where i can keep my question here :
    At start i used tutorials from syncguru.com they worked fine. But they are Windows application and not Device applications so i developped my own Device application, with the inspiration of those tutorials.

    I created the database, the procs for inserts, updates and deletes. I put my webservice on IIS and wrotte a simple application to sync 4 tables in bidirectionnal ways.
    First i used the same version of those 2 dlls :
    1.0 for Microsoft.Synchronization.Data
    3.5 for Microsoft.Synchronization.Data.SqlServerCe

    I tried the one (3.5) from :
    C:\Program Files\Microsoft Visual Studio 8\Common7\IDE\PublicAssemblies\System.Data.SqlServerCe.dll
    and
    C:\Program Files\Microsoft Synchronization Services\ADO.NET\v1.0


    The problem seemed to comes from the Microsoft.Synchronization.Data.SqlServerCe so i tried the others version that i get ( 1.0 and 2.0), and always the same error occurs.

    So i tried to put my code in a Windows application (not a device one) and i havn t the error so i am wondering if i didn t miss to install a file on the device but after some research i didn t find something new ... I really dont understand why my application succeed to load the type SqlCeClientSyncProvider in a Windows application and not in a Device application.

    Thanks for paying attention again and tell me if i have to move my question to another thread.

    Sam
    Saturday, May 17, 2008 12:29 AM
  • Well after re installing the all component the error disappear ...
    Thanks very much for your active help Yunwen
    Wednesday, May 21, 2008 7:51 PM