none
How to add thumb field to Facebook video RRS feed

  • Question

  •  I created desktop application that upload videos to Facebook using graph.facebook and it works ok, but when i try to add "thumb" field to upload request it return error "(OAuthException - #100) (#100) Invalid image format. It should be an image file data." . 

    Note coverpath is full image path and i try to path image as bytes but the same error return.
    here my code used :

    dynamic parameters = new ExpandoObject();
            parameters.source = new FacebookMediaObject
                                {
                                    ContentType = string.Format("video/{0}", VideoExtension.Split('.')[1]),
                                    FileName = VideoName
                                }
                                .SetValue(File.ReadAllBytes(filePath));
            parameters.title = VideoTitle;
            parameters.description = VideoTitle;           
            parameters.universal_video_id = new Guid();
            parameters.thumb = coverPath;
            parameters.published = false;
            parameters.unpublished_content_type = "DRAFT";
            dynamic uploadresult = fb.Post("/367728493684998/videos", parameters);

    • Moved by Stanly Fan Tuesday, November 7, 2017 8:51 AM
    Saturday, October 28, 2017 8:46 AM

All replies

  • Hello,

     I did some research but honestly, I don't know much about Facebook API.

    Here is a link about Creating Thumbs for Videos.

     https://developers.facebook.com/docs/graph-api/reference/video/thumbnails/

     Hope this helps :)

    • Proposed as answer by Stanly Fan Tuesday, October 31, 2017 1:31 AM
    Saturday, October 28, 2017 8:52 AM
  • Thanks a lot for your search but my implementation done  by this documentation "https://developers.facebook.com/docs/graph-api/reference/video/thumbnails/".
    Saturday, October 28, 2017 9:57 AM
  • Thanks a lot for your search but my implementation done  by this documentation "https://developers.facebook.com/docs/graph-api/reference/video/thumbnails/".

    Hi friend,

    So have you solved your problem now?

    If so, hope you can mark the helpful reply as answer as this will help others looking for the same or similar issues down the road.

    Regards,

    Stanly


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, October 31, 2017 1:30 AM