locked
Live Meeting 2007 GPO RRS feed

  • Question

  •  

    Problem - Live Meeting 2007 client, when pushed to end users does not have matching Group Policy settings to tell the software to look at your OCS 2007 Server.  This ends up requiring you to edit registry settings remotely or requiring your users to input the setting manually...both are "rough" options. 

     

    Resolution - My team and I created a small custom ADM file that will preconfigure the Live Meeting 2007 client settings using Group Policy...instructions follow. 

     

    Step 1

    Copy the following code to a text file and rename to whatever.ADM

    CLASS USER

    CATEGORY !!RTCPOLICY_TOP_CAT

        KEYNAME "Software\Microsoft\Shared\UcClient"

        POLICY !!PolicyConfigurationMode
        EXPLAIN !!ExplainText_ConfigurationMode
        VALUENAME "ConfigurationMode"
            VALUEON   NUMERIC 1
            VALUEOFF  NUMERIC 0       

            PART !!ServerAddressInternal_VALUE EDITTEXT
            VALUENAME "ServerAddressInternal"
                MAXLEN   256
                REQUIRED
            END PART

            PART !!ServerAddressExternal_VALUE EDITTEXT
            VALUENAME "ServerAddressExternal"
                MAXLEN   256
                REQUIRED
            END PART

            PART !!Transport_VALUE DROPDOWNLIST NOSORT
            VALUENAME "Transport"
                ITEMLIST
                NAME !!TransportTCP    VALUE NUMERIC  2 DEFAULT
                NAME !!TransportTLS    VALUE NUMERIC  4
                END ITEMLIST
            END PART
        END POLICY



    END CATEGORY

    [strings]
    RTCPOLICY_TOP_CAT="Live Meeting 2007 Client Policy Settings"
    PolicyConfigurationMode="Specify Servers and Transport"
    ExplainText_ConfigurationMode="Pre-configures the Live Meeting client
    connection to the Office Communications Server. Not enabling this address
    will leave this field blank and will require user intervention."
    ServerAddressInternal_VALUE="DNS name or IP address of the Internal server"
    ServerAddressExternal_VALUE="DNS name or IP address of the External server"
    Transport_VALUE="Transport"
    TransportTCP="TCP (default)"
    TransportTLS="TLS"

     

    Step 2

    Import the ADM file into your Group Policy, as usual. 

     

    Step 3

    Since this ADM manages "non standard" Microsoft Registry Settings, you will need to change your View in the Group Policy Editor before you can view these settings.

    From Group Policy Editor, Select "View > Filtering"
    Uncheck "Only show policy settings that can be fully managed"

     

    Step 4

    Enjoy.

     

     

     

    Hope this helps! 

     

    ------------------------------------------------------------------------

    Lance Auman
    Integration Services Manager
    PFCU Information Technology Department
    Office: 703.631.4407
    Mobile: 703.254.7224
    Email: lance.auman@penfed.org

     

    Thursday, October 11, 2007 1:41 PM

All replies

  • You should use DNS for autoconfiguration

    SVR record port TCP 5061 _sipinternaltls to server.domain.com

     

    Deli
    Thursday, October 18, 2007 10:39 PM
  • This is true, but not always possible.

     

    In my case, the UPN of all user is company.com, but the internal domain name is company.org.

     

    So it will try to resolve the SRV record to company.com which is not the internal domain name, but the public domain name.  So, GPO is the way to go in this case.

     

     

    Friday, November 2, 2007 9:25 PM
  •  

    Hi,

     

    Is there a full set of all existing Registry Keys for LM2007? On the OC2007 a huge set is available and published which makes central control and deployment easy. On LM2007 it's like back to stone age...

     

    thanks

     

    Daniel Rhein | Global IS Shared Solutions | Syngenta AG, 

    Global Service Manager for Email, E-Conferencing, Content-Filtering, Mobile Device Service,

     

    Thursday, November 29, 2007 10:53 AM
  •  Lance Auman wrote:

    Step 3

    Since this ADM manages "non standard" Microsoft Registry Settings, you will need to change your View in the Group Policy Editor before you can view these settings.

    From Group Policy Editor, Select "View > Filtering"
    Uncheck "Only show policy settings that can be fully managed"

     

    Lance,

     

    Thanks for sharing your custom group policy template.  One thing I'd like to point out for anyone reading this thread is that because these registry settings are not under one of the four Microsoft definied 'Policies' keys then any changes made to a client using this template will effectively 'tattoo' the registry.  So if anyone decides to stop using these settings, simply disabling them in the GPO template will NOT remove the changes from the registry.

     

    This is why MS forces users to manually configure gpedit to view 'unmanaged' policies.

    Thursday, November 29, 2007 2:08 PM
    Moderator
  • Thanks for putting this together and posting it.  I hate writing these things.  Like you said, for some of us, this is the only option...thanks to Microsoft's "security".

    Tuesday, January 8, 2008 8:51 PM
  • Seems microsoft has released an adm for LiveMeeting

    http://support.microsoft.com/?kbid=948741#appliesto

     

    Check it out

    Wednesday, June 18, 2008 2:14 AM
  • Thanks

     

    Wednesday, June 18, 2008 6:09 PM
  • Where can we request for this hotfix? I couldnt see any link for this?
    Anybody who knows?

    Regards,

    Tuesday, August 26, 2008 1:54 PM
  • You can request the hotfix by contacting Microsoft Support or buy using the online request page: http://support.microsoft.com/hotfix/KBHotfix.aspx?kbnum=948741

     

    Tuesday, August 26, 2008 8:05 PM
    Moderator