none
Windows Authentication not propagating from application to Web service / Web API RRS feed

  • Question

  • Hi Team,

       I am working for a customer by connecting through Microsoft Azure VPN. My PC is not connected to their domain so all my accounts and exe (visual studio and SSMS) are running under local account. In order to connect the customer DB through windows authentication we open the Visual Studio using the following command

    runas /netonly /user:domain\username "C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\devenv.exe" 

    This is working fine if my application directly calling the data helper. But not working if my application calling the web service or web api which in turn calling the database. I tried to run the Inetmgr like this

    runas /netonly /user:domain\username "c:\Windows\System32\inetsrv\InetMgr.exe" it does not help.

    Also tried to create an application pool using that domain account. The application pool is getting stop also getting http 503 error.

    Kindly let me know how to solve this.


    SenthilKumar R Please Mark as Answered if answers your question

    • Moved by CoolDadTx Tuesday, February 6, 2018 3:30 PM ASP.NET related
    Tuesday, February 6, 2018 7:14 AM

All replies