none
Streets & Trips stopped working on Windows 10 RRS feed

  • Question

  • I've had it installed on this PC for 5 years. I upgraded to Windows 10 a few months ago with some issues, but once Windows 10 finally started working and I resolved the wireless network card error, Streets and Trips has worked flawlessly. I use it frequently and run it at least every other day. Today, it was running fine, I rebooted for something else and now all of a sudden I get the error:

    Your registry settings for this application were not copied correctly.  To correct these settings, run setup again for this application from the location where you originally installed it.

    Really guys?  It's worked FINE for several months.  Why would it stop working today?  It looks like and update for Windows was installed 2 days ago (KB3124200) and with all the changes I'm finding it hard to uninstall this patch to see if that resolves it.  Nonetheless, I've had problem after problem after problem since 'upgrading' to Windows 10.  The only way I seem to be able to resolve this is changing the settings for the shortcut to run as an administrator but now it prompts me to make sure I want to run something that want's to make a change to my computer.  HOW DO I GET THIS TO JUST WORK LIKE IT DID 30 MINUTES AGO WITHOUT PROMPTS?  I just want it to work!  No prompts!  No editing ANYTHING!  Just WORK!  Why do I have to keep making changes to things to get them to work?

    Tuesday, December 22, 2015 4:44 AM

All replies

  • Hello MJohnsonMonroe. I had the same problem you've experienced. Thanks for the tip on changing the shortcut to run as an administrator. I did that and now at least the program will open. I know it requires an extra click, but at least it will open the program. Your tip helped me, and I'm sure others will be helped by it also. It would be nice if the shortcut just opened the program as it did before, but at least it will now open. :-)
    Wednesday, January 27, 2016 8:14 PM
  • Just got the same issue today.  We are letting tech companies use H1-B visas to bring in the folks who create this kind of mess.  Where were the QA folks and the auditors.  Did  Microsoft outsource the work to PriceWaterhouseCoopers?
    Friday, March 3, 2017 1:29 AM
  • The problem is Windows 10 Anniversary Edition.  My 2013 Streets and Trips with the included GPS receiver worked fine until the Anniversary Edition.  After that, plugging in the GPS causes the blue screen of death.  There are a lot of discussions about this and the bottom line is, the driver just won't work any longer.  I never found a free fix but ended up ordering a GlobalSat BU-353S4 GPS Receiver and everything works as it should again.  That is <g class="gr_ gr_659 gr-alert gr_gramm gr_disable_anim_appear Grammar only-del replaceWithoutSep" data-gr-id="659" id="659">about </g>a $30.00 solution if you shop around.  Works perfectly though.
    Friday, April 14, 2017 11:43 AM
  • Just do what the error message said. Reinstall the program.

    IF you saved all of your maps to a Onedrive folder, shouldn't be any problem.

    IF you saved your downloaded installation files to your Onedrive folder, again, no problem.

    IF you saved your product key in either an email folder or to your Onedrive folder, No problem.

    IF you installed from a CD, If you have your box with the key and the cd is not all scratched up, no problem.

    IF the CD is all scratched up, a little problem. download the trial from https://www.microsoft.com/en-us/download/details.aspx?id=30173, then enter your software key.

    IF you no longer have your software key, that could be a problem. (Might be able to find it using Belarc Advisor. I found a lost Office key that way once.)

    Just reinstall Streets & Trips and it works just fine in Windows 10. I never had the issue that you were talking about but a simple reinstallation, as the error code said, should straighten it out.

    And the driver problem with the Pharos GPS device was fixed in less than a week. I did have that problem. Bluescreens are scary, but they fixed it pretty fast.

    Take care and Happy Trips!


    • Edited by Ranger31036 Saturday, June 24, 2017 11:53 PM
    Saturday, June 24, 2017 11:50 PM
  • Hi,

    I just reinstalled 2013 version and it still gets a blue screen. 

    I hope I can find another solution. 

    Evelyn


    Monday, October 30, 2017 1:22 AM
  • Sadly that doesn't work for me. I have not resolved the problem yet.
    Wednesday, December 20, 2017 12:37 AM
  • Streets and Trips worked fine on WIN10 for at least a year.  Now I get a "There was an error..." message.

    I have uninstalled and re-installed 3 times and I still have the same issue.

    Saturday, December 23, 2017 8:23 PM