locked
New D-Link SharePort Software RRS feed

  • Question

  •  

    D-Link has release a new software that allows the DGL-4500 router to use USB drives over the network.

     

    It seems this SharePort software only work when I turn my OneCare firewall "Off". If I turn the firewall "On" the SharePort software is blocked.

     

    I checked the firewall to see if the program was "allowed" and it was!

     

    It is listed as "SharePort Network USB 0.9.4.0".

     

    It would be great to get this working properly.

    Saturday, October 4, 2008 2:27 AM

Answers

  • Generally it's best to contact the support for the provider of the sharing product itself, since they should know what type of access is required.

     

    Since the program works with the firewall disabled, you should only need to determine what ports and/or protocols need to be enabled to allow it to work with better security.

     

    OneCareBear

    Sunday, October 5, 2008 7:26 AM
    Moderator
  • I posted this on another page, so some of those logging on here may have not seen it yet.  The solutions were to make the following adjustments to the Onecare Firewall:

     

    Bring up the Firewall Settings.  Under "Advanced Settings", "Ports and protocols" tab, add the following:

    - Allow Port UDP 9303 (I have it as "inbound", but it might need to be "both ways")

    - Allow Inbound TCP Port 80

    - Allow Outbound TCP/UDP Port 53

    - Allow USB Protocol 6 with "both" checked

     

    Under the "Programs" tab, add the following:

    -  Add the "SharePort Network USB" program and check it as allowed.

     

    This has worked for me and for others.  I don't know if these settings are the most secure, so use at your own risk.  Post back if it works for you.

    Monday, October 20, 2008 3:30 AM

All replies

  • Generally it's best to contact the support for the provider of the sharing product itself, since they should know what type of access is required.

     

    Since the program works with the firewall disabled, you should only need to determine what ports and/or protocols need to be enabled to allow it to work with better security.

     

    OneCareBear

    Sunday, October 5, 2008 7:26 AM
    Moderator
  •  

    Thanks, I will give D-Link a try.
    Sunday, October 5, 2008 2:20 PM
  • Ok, so DLink customer support says there are no ports to open...which sounds like they just don't know how the software works.

     

    Can I get this working another way?

     

    I found this info in the onecare firewall log, after trying to enable Shareport.

     

    The following request was blocked:
    Full Application Path: Unknown
    Version: Unknown
    Local Computer: 0.0.0.0:4294953187
    0.0.0.0:0
    Protocol Name: TCP
    Protocol Number: 6
    Traffic Direction: Inbound

     

    I tried to open port "6" but that seemed to do nothing.

     

    Sunday, October 5, 2008 3:27 PM
  • Since D-Link support was unable to resolve this for you, please contact OneCare support.

    How to reach support (FAQ) - http://forums.microsoft.com/WindowsOneCare/ShowPost.aspx?PostID=2421771&SiteID=2

     

    -steve

    Monday, October 6, 2008 5:09 PM
    Moderator
  • When I review my Network Adaptors Firewall Properties it shows an Exception of

    "SharePort Network USB Utility UDP" using Port 9303

     

    I hope this help.

    Saturday, October 11, 2008 2:00 AM
  •  

    I have the same problem.  Interesting thing is, the utility works great with a Toshiba laptop that I have running Norton 360, but I can't seem to get it to work with the other computers that I have running OneCare unless the firewall is turned off.  I've tried enabling the 9303 port, and have added the Sharepoint utility to the allowed programs list.  No luck. Like you, I would certainly like to get this to work.  On the Toshiba, it is a very handly utility.  I'd just like to have it for my other computers.
    Sunday, October 12, 2008 7:29 PM
  • I posted this on another page, so some of those logging on here may have not seen it yet.  The solutions were to make the following adjustments to the Onecare Firewall:

     

    Bring up the Firewall Settings.  Under "Advanced Settings", "Ports and protocols" tab, add the following:

    - Allow Port UDP 9303 (I have it as "inbound", but it might need to be "both ways")

    - Allow Inbound TCP Port 80

    - Allow Outbound TCP/UDP Port 53

    - Allow USB Protocol 6 with "both" checked

     

    Under the "Programs" tab, add the following:

    -  Add the "SharePort Network USB" program and check it as allowed.

     

    This has worked for me and for others.  I don't know if these settings are the most secure, so use at your own risk.  Post back if it works for you.

    Monday, October 20, 2008 3:30 AM
  •  

    Thank you, very much!

     

    I can confirm that this is working. I can now access the drive with OneCare firewall active.

    Monday, October 20, 2008 3:58 AM
  •  

    You only need the USB Protocol 6 with both checked active.  I would not allow port 80 inbound,  that can open you up to possible DoS attacks.
    Wednesday, November 12, 2008 8:09 AM
  • Thanks a million guys.  D-Link support was clueless and without your help, I wouldn't have done it.

    mK

     

    Wednesday, December 10, 2008 8:19 PM
  •  



    thanks, for this infomation on D-Link share port and one care...only need to setup USB Protocol 6.... to clear the firewall
     thanks..
    Monday, January 19, 2009 2:28 AM
  • I am not the best on the computer, I opened up Ports and protcols and did not understand what you put on your post and
     what I was seeing. Could you explain this a little more in detail, Thanks in advance
    Tuesday, January 20, 2009 11:53 PM
  • Harleyoil said:

    I am not the best on the computer, I opened up Ports and protcols and did not understand what you put on your post and
     what I was seeing. Could you explain this a little more in detail, Thanks in advance



    The specific instructions are actually in the post above. if you need more help with those instructions, please contact OneCare support and refer to this forum thread so that they can see what ports and protocols you are trying to add to the allow list.
     

    How to reach support (FAQ) - http://social.microsoft.com/Forums/en-US/onecareinstallandactivate/thread/30400b52-7f26-4ba0-bc18-17e305329d90

    -steve


    Microsoft MVP Windows Live / Windows Live OneCare Forum Moderator
    Wednesday, January 21, 2009 12:32 PM
    Moderator