locked
Should I see a "Management Reporter Application Service" under Windows Services? RRS feed

  • Question

  • I installed the Management Reporter on the server.  Under Services,  I can see “Management Reporter Process Service”, but I don’t see an “Application Service”.  When I try to do the client install and connect to http://servername:4712  it cannot connect.  Should I see an Application Service?

    Tuesday, January 19, 2010 9:37 PM

Answers

  • David,

    .NET Framework 3.5 is installed on the server, right?  If you go into the properties for the MR web site and click on the Home Directory tab, then click the Configuration button, which extensions do you see in the Application Mappings list?  You should at least see .aspx, .config, and .svc mapped to C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll.  Also, under Web Extensions, make sure that you see "ASP.NET v2.0.50727" and that it's set to Allowed.

    All of these things should have been done for you by the installation, but these are areas to check just in case.

    I hope that helps.

    Jeff
    Tuesday, January 26, 2010 10:12 PM

All replies

  • Hi David,

    No, only the Process Service will be visible in Services.  The Application Service runs in IIS.  When you installed the MR services, did you select the check box to add a firewall exception for the app service port?  That check box is not selected by default.  You can verify by going to the Windows Firewall configuration and looking for an exception called "Management Reporter".  If you do not see one, you can add it manually (for port 4712).

    You can also verify connectivity to the MR app service by using Internet Explorer - try to connect to http://servername:4712/SecurityService.svc.  If it fails to connect, there's a problem.  If you see a page with information about the service, it has connected successfully (and the client should be able to connect, too).

    I hope this helps.

    Jeff [MSFT]
    Software Development Engineer
    Tuesday, January 19, 2010 9:45 PM
  • Hi Jeff,
           I did select the checkbox to add a firewall exception during server installation.   Then, I had one of our network guys asissting me.  I can now get to http://servername:4712 however, when I try to go to http://servername:4712/SecurityService.svc I get an HTTP 500 error.  Am I missing a step? The server is a 64-bit machine running Windows Server 2003.

    Thanks...
    David Andrade
    Gordon College 
    Friday, January 22, 2010 1:48 PM
  • David,

    .NET Framework 3.5 is installed on the server, right?  If you go into the properties for the MR web site and click on the Home Directory tab, then click the Configuration button, which extensions do you see in the Application Mappings list?  You should at least see .aspx, .config, and .svc mapped to C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll.  Also, under Web Extensions, make sure that you see "ASP.NET v2.0.50727" and that it's set to Allowed.

    All of these things should have been done for you by the installation, but these are areas to check just in case.

    I hope that helps.

    Jeff
    Tuesday, January 26, 2010 10:12 PM