locked
How to use CRM Portal Web Controls? RRS feed

  • Question

  • I have followed the document as below:

    http://msdn.microsoft.com/en-us/library/gg695790.aspx

    I have added the following to the <controls> section of the web.config file to register the Microsoft.Xrm.Portal controls with this Web application.

    <system.web>
        <pages>
          <controls>
            <add tagPrefix="crm" namespace="Microsoft.Xrm.Portal.web.UI.WebControls"  assembly="Microsoft.Xrm.Portal" />
          </controls>
        </pages>
        <compilation debug="true" targetFramework="4.5" />
        <httpRuntime targetFramework="4.5" />
      </system.web>

    But I can't use these controls:

    Is there anything I missed?

    In addition, other web page that didn't use these controls were displayed correctly, only pages that used the controls were not correct.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, December 22, 2014 10:01 AM

All replies

  • Which version of crm you are using? Change target framework to 4

    Regards, Saad

    Monday, December 22, 2014 10:40 AM
  • Hi Saad,

    Thanks for your response.

    I's using CRM 2013. Target .NET framework is 4.5.

    I have tried changing target .NET framework to 4, nothing changed.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Edited by George Hua Tuesday, December 23, 2014 1:56 AM
    Tuesday, December 23, 2014 1:54 AM
  • Remove this tag and try to run it again

    <compilation debug="true" targetFramework="4.5" />
        <httpRuntime targetFramework="4.5" />


    Regards, Saad

    Tuesday, December 23, 2014 6:54 AM
  • Hi Saad,

    Thanks for your reply.

    It is not helpful. I also got a compile error as below:

    Wednesday, December 24, 2014 2:44 AM