none
How to set ms-mpi v7 on intel visual fortran withing visual studio 2015 on win10? RRS feed

  • Question

  • Hi,<o:p></o:p>

    I am a student, and learned from the blog "How to compile and run a simple MS-MPI program", and I set everything already. When I build a Fortran program where I write a code "using mpi", it shows "error #7002: Error in opening the compiled module file.  Check INCLUDE paths.   [MPI]". So I want to seek help.<o:p></o:p>

    Monday, March 14, 2016 2:53 PM

All replies

  • Hi there,

    How are you building the program (which compiler and the command that you run)? If the program is very simple you can also post it here and we can take a look.

    Thanks

    Thursday, March 17, 2016 6:39 PM
  • I went into the same issue. My OS is win10 and would like to compile an x64 mpi program in vs2015, intel visual fortran. I downloaded MS-MPI v8 and installed msmpisdk.msi. Then I configure my project in vs2015 by adding the include and lib libraries, as shown in the above mentioned blog "How to compile and run a simple MS-MPI program". In Linker--input, I add msmpi.lib and msmpifec.lib as additional dependencies.  In Linker, I add "D:\Program Files (x86)\Microsoft SDKs\MPI\Lib\x64" as additional library directories and in Fortran, I add "D:\Program Files (x86)\Microsoft SDKs\MPI\Include\x64" as additional include directories. My source code starts with "use mpi". However after I compile it, I get "error #7002: Error in opening the compiled module file.  Check INCLUDE paths.   [MPI]". What is the problem? Thanks.
    Wednesday, February 22, 2017 12:47 PM