Cannot process OLAP: "Login failed for user..." RRS feed

  • Question

  • Components:

    MS Windows Server 2008 R2, SQL Server 2012 SP1 CU7, Sharepoint 2013 Enterprise + Project Server 2013 Enterprise. All components is installed on one server (test server).

    I configure Project on http://technet.microsoft.com/en-us/library/cc197479(v=office.15).aspx. 

    When I process OLAP I see:

    ===== Initiating the process of building the database OLAP =====
    [ 13.05.2014 10:54 ] The request message is added to the Cube Building Project Server Queue
    ===== Check and perform an event handler to the server build process =====
    [ 13.05.2014 17:54 ] Checking and handler execution server events before building
    ===== Determining the structure of the database and the database OLAP =====
    [ 13.05.2014 17:54 ] Initializing cube building started
    ===== Building database and cubes =====
    [ 13.05.2014 17:54 ] Start of the session cube building
    ===== Check and perform the event handler server after the build process =====
    [ 13.05.2014 17:55 ] Checking and handler execution server events after building
    Processing ===== database OLAP =====
    [ 13.05.2014 17:55 ] Start of session processing OLAP database
    Process Completed ===== =====
    [ 13.05.2014 17:55 ] Unable to build cubes OLAP. Error: Failed to process the Analysis Services database server PWA test-sp. Error : OLE DB error: OLE DB or ODBC error: Login failed for user "DOMEN \ TEST-SP $".; 28000 .
    Errors in the high-level relational engine. A connection could not be made to the data source with the DataSourceID of 'Project Reporting data source', Name of 'Project Reporting data source'.
    Errors in the OLAP storage engine: An error occurred while the dimension, with the ID of 'Deliverable Start Date', Name of 'Deliverable Start Date' was being processed.
    Server: The current operation was cancelled because another operation in the transaction failed.

    PWA - cube name, DOMEN - domen name, test-sp - server name.

    Why Project tried processed cube using nonexistent account "DOMEN \ TEST-SP $"? TEST-SP it's computer name, it's not user (service account) name!

    P.S.: I connected to SSAS using Management Studio and looked properties of Data Sourse. In Security Settings option Impersonation Info = Default (Inherit). When I tried to process cube I ger same error. I set my account in Impersonation Info and cube building succesfully. But when I building cube from Project, all settings is reset and i have error.

    Thursday, May 15, 2014 4:27 AM


  • I solve this problem!


    I run SSAS with Domain account (set it in sql server configuration manager). I use my account. I have necessary permissions on Project database.

    Thursday, May 15, 2014 6:11 AM