locked
Errors connecting to server remotely RRS feed

  • Question

  • Hi - I've mentioned this before in passing when replying to somebody else's post, but thought I'd elevate and elaborate it, since I'm at a bit of a loss...

    I can log into my Home Server remotely via web access, that's fine.  However, when I click on a machine to RDP onto, I get a "Your computer can't connect to the remote computer because the cookie was rejected by the Remote Desktop Gateway server.  Contact your network adminsitrator for assistance".

    Googling this error returned nothing I'm afraid.  I sometimes get a slightly different message (I think it was "...because the remote desktop gateway is not available).  When I googled that message I had several results pertaining to the SBS edtition, and some of the solutions were quite scary (I didn't want to try in case I made things worse).

    In addition, about 95% of the time, I get "An error has occurred on the server. Please try again later. If the error continues, view Support Information for help." in the Media Library panel.  I don't know whether this is related.

    Some things I've done that may have led to it (plus some other notes)...

    • I factory reset my router recently, since it was still configured for my old pre-home-server setup.  I was getting "router not configured" alerts, although remote access worked perfectly.  As far as I know I have set the router up as it was (but taken out any port forwards to my old server)
    • I have set my router up to always give the home server the same IP address (192.168.1.99).  Originally it was .100, and that temporarily created an IP conflict, but I think that's flushed out now (and the new address is outside of my DHCP range)
    • Other software I run on the server - Squeezebox, DVBTVLink, MyMovies
    • I think everything works fine from inside my network, but I can't test RDP, since I'm using the internal IP Address to access the web front end, which results in a security mis-match of certificates and addresses
    • I haven't manually changed anything in IIS
    • I can't find anything in the Event Viewer

    What I have tried...

    • Turning off and on remote access to try and rebuild it
    • Turning off uPNP on the router to generate a router configuration alert, turning it back on and getting the Server Settings to repair remote access
    • Turning off the firewall on my router (plus looking through every setting on there that I can)

    Internally, the system seems to be running perfectly.  Remotely I can't get much joy at all.  Don't know whether it's the router, IIS on the server, or the server itself.

    Any help very greatly appreciated!


    EDIT: Addendum.  If I open port 3389 on my router, I can connect to the desktop fine using RDC, so it's connecting over a web interface that I appear to be having trouble with.
    Thursday, June 9, 2011 8:22 AM

All replies

  • Any ideas on this anyone?  I'm struggling to fix remote access and media library.  Sometimes the media library will work (very rarely), but the remote access is always broken.
    Monday, June 13, 2011 10:26 AM
  • Well, today it's working.  I did two things that I don't know whether helped, whether I've flushed the issues through, or whether it just started working on its own...

    - On my router, I changed the fixed IP of the server's MAC address from 192.168.1.99 to 192.168.1.199 (.99 is technically outside of my DHCP range, but I was trying to avoid IP conflicts - might have been an issue, but I don't know enough about that sort of thing)

    - On the server (via RDC), I opened up the command line and typed "ipconfig /release".  Since I was using the machine remotely, I lost connectivity.  However, I waited and it sorted itself out.

    I've just gone on today and can connect to all machines on my network (that support the technology).  I don't know whether it's fixed or not to be honest.  Might play up again later.

    However, I still can't get to my media library online.  Every now and then that'll work, but mostly not.  Used to be 100% fine.

    Tuesday, June 14, 2011 10:28 AM
  • Spoke too soon, kind of.  Today I couldn't get back in again.  Restarted the browser and voila.

    However, I can now only get into the server dashboard.  I can't connect to any machines on my network (although I can connect to them internally via RDC).  Keep getting the error message...

    "Remote Desktop can't find the computer "<computername>".  This might mean that "<computername>" does not belong to the specified network.  Verify the computer name and domain that you are trying to connect to.

    Media Library still a no-go too.  I've perhaps had two pages from it this week, but it falls back over very quickly.

    Stuck.

    Friday, June 17, 2011 8:42 AM
  • I experience the same issue: "your computer can't connect to the remote computer because the cookie was rejected by the remote desktop gateway server" error when trying to connect the server or a computer in the home from the remote  access website. Other function do work (remote library, shared folders).

    This problem seems to occur since the last security updates. At least id did work some weeks ago. Can a security hotfix be the cause?


    You know you're an engineer when you have no life and can prove it mathematically
    Tuesday, June 21, 2011 6:57 AM
  • I don't suppose you've had any luck with this at all have you?

    Or anybody else?

    Media Library and Remote Access not working at all on my server, and haven't been for some time.

    Thursday, July 21, 2011 2:01 PM
  • Just to report, i am havinng the same issue:

    "Your computer can't connect to the remote computer because the cookie was rejected by the Remote Desktop Gateway server.  Contact your network adminsitrator for assistance"

    As Stephen noticed it started since the latest updates rollout (tuesday 14th of February 2012)

    Looking forward to hearing the solution

    Thursday, February 16, 2012 3:09 PM
  • just to let anyone know. The solution to the fix is to go to your IE and clear/delete cokies, cache etc.

    cheers

    Thursday, February 16, 2012 3:31 PM
  • I thought I'd posted back here to say clear out the cookies.  Looks like I didn't, sorry.

    I still get this every now and then and have to clear out the cookies.  Doesn't appear to be any reason for it.

    Thursday, February 16, 2012 3:51 PM