Reporting Error - "The report cannot be displayed. (rsProcessingAborted)" RRS feed

  • Question

  • I have an assortment of reports which run perfectly fine on other instances, both locally and on CRM online.  However, within the instance I am currently working, a locally hosted instance, none of the reports run.  Additionally, if I go to the effort of creating a very simple report within the CRM report creation wizard (built into the CRM application itself), even that report will not run.  Under all circumstances, I receive the following error message:

    "The report cannot be displayed. (rsProcessingAborted)".

    All of the components of my CRM installation, SQL server, etc. are installed on a single machine on which I am working.  I have replaced the connection strings within the reports I made previously with the exact connection string of this locally hosted instance.  I have tried a variety of different things in the reports themselves, such as changing authenication credentials, but no luck so far.

    I am guessing that my problems are related to not having the CRM server and/or the SQL server installed/configured properly.  I don't really know where to begin on overviewing my CRM and SQL server installations/configurations.  Any suggestions?

    Wednesday, April 11, 2012 12:32 AM

All replies

  • Have you tried running the report directly from the report server?

    Have a look at the report server log files (normally C:\Program Files\Microsoft SQL Server\MSRS10.MSSQLSERVER\Reporting Services\LogFiles\)

    Musings on Information Technology

    Wednesday, April 11, 2012 6:53 AM
  • The reports run successfully in BIDS, which is locally installed on this machine as well.  When I tried to preview them, they would NOT run until I switched the connection string to match that of this locally hosted CRM instance.  That sort of makes sense, except that I never have to do this step if I am using CRM Online.

    Anyway, I did look in the log files, as I saw that recommendatoin on other similar posts on this forum.  I was not sure what I was looking for though, and unfortunately those log files are only associated with attempted report executions from BIDS---not from CRM itself.  I know that the report runs in BIDS, so I am not sure what the log files are going to tell me, other than the fact that the report ran successfully in BIDS.  My problem now is simply that the report will not run in CRM.

    There is no error information on the CRM side, as I understand it, except from the very ambiguous error message I have already posted: "The report cannot be displayed. (rsProcessingAborted)".

    • Edited by RST Dev Wednesday, April 11, 2012 1:28 PM
    Wednesday, April 11, 2012 1:27 PM
  • Hi RTS Dev,

    as suggested in above reply ( ManyRootsofAllEvil), try to run report directly from report server, this would be first step to see where the problem is.

    Your report server must be accessible on like something like http://reportserver/reports, report server is computer that hosts Reporting services instance, if you have all on one machine this is your crm server.

    If report is ran successfully there this mean there is some error in your configuration of CRM, if report cannot be displayed there then we can start troubleshooting SSRS.


    Wednesday, April 11, 2012 1:36 PM