none
New error message? "Failed to create folder pair. Failed to create the provider."

    Question

  • Hello,

    I am getting an error in SyncToy, and cannot find a single internet resource that cites this error.  I have search this forum, the Microsoft Knowledge Base, Bing, Yahoo, and Google.  The error message I am getting appears to be discussed nowhere on the internet.

    The issue:

    When trying to create a new folder pair in SyncToy I get the following error message: "Failed to create folder pair. Failed to create the provider."   This happens when attempting to create a new folder pair, regardless of drive.  I have attempted to create new folders pairs that go C: > C:, C: > G:, C: > H:, and G: > H:.  I get the same error regardless of drive(s) used.

    C: is an internal hard disk, G: is an external Seagate 1 TB USB 2.0 hard disk, and H: is a SanDisk Cruzer Titanium 4GB flash drive.  There are no network drives hooked to this machine, except when I Telnet into school, and I have never tried to Sync over a network.  All Sync attempts have been with local drives.

    SyncToy has worked fine on this system for months, I have used it regularly to backup and synchronize data from flash drive to internal hard disk and external backup hard disk.

    When this error started to occur, it did not prevent me from running Syncjobs I had already created; it only prevented me from creating any new folder pairs for syncing.  This error started on SyncToy 2.0.

    The system:

    Windows Vista SP2, Asus laptop with an AMD Turion dual-core CPU and 4 GB of RAM.

    How I have attempted to fix the issue:

    1)      Reboot the system – FAIL

    2)      Uninstall and reinstall SyncToy 2.0 (previously created folder pairs were NOT deleted in this process, old folder pairs still showed after the reinstall) – FAIL

    3)      Download SyncToy 2.1, install it over the top of SyncToy 2.0 (previously created folder pairs were NOT deleted in this process, old folder pairs still showed after the reinstall) – FAIL

    4)      Uninstall SyncToy 2.1, reinstall SyncToy 2.1. (previously created folder pairs were NOT deleted in this process, old folder pairs still showed after the reinstall) – FAIL

    5)      Deleted ALL folder pairs in SyncToy 2.1, used Windows Installer Clean Up utility to uninstall SyncToy 2.1 – FAIL.

    6)      Uninstall SyncToy 2.1 (with no folder pairs present now that I had removed them all) and reinstall SyncToy 2.1 – FAIL.

    7)      Uninstall SyncToy 2.1 (with no folder pairs present now that I had removed them all) and reinstall SyncToy 2.0 – FAIL.

    No matter what I do, I can no longer create any folder pairs in SyncToy on this computer between any drive or drives.  The same error message always appears:

    "Failed to create folder pair. Failed to create the provider."

    I have come to rely on SyncToy to help me keep my data for school up-to-date, and really do not have the spare cash as a poor grad student to go dropping the cash for “real” backup software.  Anyone have any ideas?

    Monday, May 17, 2010 12:24 AM

All replies

  • Hi,

    I saw you mentioned "Deleted ALL folder pairs in SyncToy 2.1". Have you created any folder pair successfully for some other folders before?

    Thanks


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, May 17, 2010 7:10 AM
  • This problem started all of a sudden, it might have been after a software crash of SyncToy 2.0, I cannot remember.

    Before this problem started, I could create folder pairs at will, no problem.  After it began, I have failed each and every time to create a folder pair at all, regardless of the drive or drives I use, regardless of the whether I currently have SyncToy 2.0 or 2.1 installed.

    Wednesday, May 19, 2010 10:56 PM
  • Hi,

    It seems that there had been something unexpected happened in the "%LOCALAPPDATA%\Microsoft\SyncToy\2.0\" folder, especially the "SyncToyDirPairs.bin". But for now we do not have much information about the issue. Can the log of your SyncToy provide some information about the failure?

    (We are trying to find a way to resolve your problem with keeping your existed folder paris. But if you do not care about the exited folder pairs, you can try uninstalling SyncToy, deleting the ""%LOCALAPPDATA%\Microsoft\SyncToy\" folder and then reinstalling SyncToy. )

    Thanks


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Saturday, May 22, 2010 5:20 AM
  • I uninstalled SyncToy 2.0, then navigated to C:\Users\...\AppData\Local\Microsoft folder and deleted the SyncToy folder that was still there after the uninstall.

    I reinstalled SyncToy 2.1, attempted to create a new folder pair, and got the same error message: Failed to create folder pair. Failed to create the provider.

     

    I then uninstalled SyncToy 2.1, then navigated to C:\Users\...\AppData\Local\Microsoft folder and deleted the SyncToy folder that was still there after the install.  After this I did a Registry Search for any mention of SyncToy and deleted every reference to SyncToy that I found.

    I searched the registry from the top 3 times, starting at HKEY_CLASSES_ROOT, to make sure RegEdit wasn’t missing anything.  I deleted every registry reference to SyncToy I could find.

    I then rebooted my system.

    I re-checked the folder C:\Users\...\AppData\Local\Microsoft; the SyncToy folder had not been re-created.

    I re-checked RegEdit, again doing a search from the top for any entries that mentioned SyncToy, I found none.  No registry entries for SyncToy had been spontaneously re-created upon the reboot.

    I then installed SyncToy 2.1, and tried to create a folder pair.

    Once again the same error message:  Failed to create folder pair. Failed to create the provider.

     

    *The issue, it would appear, is going beyond SyncToy.*

     

    I notice after SyncToy installs, it speaks about the need for the user to search for updates to the .NET Framework.  Could this be a .NET problem?

    In Programs and Features on my install of Vista, I saw I have the Microsoft .NET Framework 1.1 installed, as well as the Microsoft .NET Framework 3.5 SP1.

    Is this a problem?

    Should I think about uninstalling and reinstalling the .NET Framework from my system?

    I have downloaded the full Microsoft .NET Framework 3.5 Service Pack 1 installer (the 231 MB file) from:  http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=ab99342f-5d1a-413d-8319-81da479ab0d7

    as well as some updates that the install instructions said I would need:

    Windows6.0-KB958481-x86.msu - 10.4 MB

    Windows6.0-KB958483-x86.msu - 6.9 MB

    NDP35SP1-KB958484-x86.exe - 1.4 MB

    Which according to the instructions here:  http://www.microsoft.com/downloads/details.aspx?familyid=B9DE7937-2C12-4F16-AD66-A31B83931953&displaylang=en&displaylang=en

    should be installed in the order I listed them, immediately following the install of the .NET Framework 3.5 SP1.

    I know almost nothing about .NET, though, so I am worried about creating a 2<sup>nd</sup> problem to go along with the first if I start messing with .NET.

    Any ideas about where to go from here?

    Saturday, May 22, 2010 1:03 PM
  • Hi, I got the same problem. I uninstalled Synctoy and everything that said Microsoft SQL CE (Compact Edition) bla bla and everything that said Microsoft Sync Service bla bla. Reinstalled Synctoy and it works again.

    You may want to test this out. Hope it works for you as well.

    regards

    Kapil Bamba

     

     

     

    • Proposed as answer by Ankit Nigam Friday, May 17, 2013 10:47 AM
    Thursday, May 27, 2010 6:59 PM
  • Hi, I had the same problem. No need to reinstall everything. Instead, do a "Repair" for "Microsoft SQL Server 2005 Compact Edition" and "Microsoft Sync Framework 2.0..." (there are 2 items, do for both). Give it a try. SyncToy worked for me after this. No need to uninstall or even repair SyncToy itself.

    Regards,

    Lior

    • Proposed as answer by Hangloose1806 Sunday, July 04, 2010 8:35 AM
    Saturday, May 29, 2010 11:30 PM
  • The repairing-thing worked!!! Thanxxxx
    • Proposed as answer by Narendra Naidu Wednesday, October 13, 2010 2:51 PM
    Sunday, July 04, 2010 8:35 AM
  • I didn't understand what "Repair" exactly meant, but I reinstalled SyncSDK-v2.0 and everything works again.

    Thanks!

     

    Friday, August 13, 2010 1:47 PM
  • This problem started all of a sudden, it might have been after a software crash of SyncToy 2.0, I cannot remember.

    Before this problem started, I could create folder pairs at will, no problem.  After it began, I have failed each and every time to create a folder pair at all, regardless of the drive or drives I use, regardless of the whether I currently have SyncToy 2.0 or 2.1 installed.


    Hi I had the same problem, I found out that Samsung KIES gives the problem. KIES is a software program for users who have a Samsung mobile phone.
    Tuesday, October 05, 2010 10:24 AM
  • Je confirme que l'installation de KIES a planté Synctoy et que la réinstallation de "Microsoft SQL Server 2005 Compact Edition" et "Microsoft Sync Framework 2.0..." semble avoir résolu le problème.

    Je n'ai cependant pas encore relancé KIES.

    Merci pour les solutions.

    Tuesday, October 12, 2010 4:01 PM
  • I did same thing, and it worked.

     

    Thanks....

    Thursday, October 14, 2010 4:54 PM
  • This problem started all of a sudden, it might have been after a software crash of SyncToy 2.0, I cannot remember.

    Before this problem started, I could create folder pairs at will, no problem.  After it began, I have failed each and every time to create a folder pair at all, regardless of the drive or drives I use, regardless of the whether I currently have SyncToy 2.0 or 2.1 installed.


    Hi I had the same problem, I found out that Samsung KIES gives the problem. KIES is a software program for users who have a Samsung mobile phone.

    I have the same problem, also started after I installed Samsung Kies !!!
    Sunday, October 24, 2010 3:35 PM
  • The repairing suggestion works, even after you have installed Samsung Kies.
    Wednesday, November 10, 2010 11:04 AM
  • Lior Messer:

     

    Your suggestion for repair works for me. Thx!

    Wednesday, November 10, 2010 4:16 PM
  • OK so the repair seems to work for everyone. How do I accomplish the repair?
    Thursday, November 18, 2010 11:25 PM
  • I did a "Repair" for "Microsoft Sync Framework 2.0..." (there are 2 items, do for both). Not for "Microsoft SQL Server 2005 Compact Edition", as I don't have this entry.

    I controlled Kies and it seems to work fine.

    The problem, same as exposed by Hyperion, seems to be solved. Thanks to Lior Messer!

    • Proposed as answer by Ledbum Thursday, January 06, 2011 7:43 PM
    Sunday, November 28, 2010 2:29 PM
  • Repair of both sync frameworks worked for me too... I'd also installed Samsung Kies.
    • Proposed as answer by chantivlad Thursday, June 14, 2012 2:33 PM
    Thursday, January 06, 2011 7:43 PM
  • I found the same problem after installing Kies. I reinstall the framework 2.0 provider servies and solve the problem. Happy~
    Sunday, January 23, 2011 9:53 AM
  • Same. Didn't realise Kies had caused it.

    Synctoy now working.

    Grrr Samsung

    Friday, February 04, 2011 12:59 PM
  • Hi, Sorry if I seem a bit thick but I'm definitely not a wizkid. I'm having the same problem with Synctoy since installing Kies. How do I go about reinstalling the framework 2.0 provider servies (and what is it)? Many thanks if you can help me. Rick.
    Friday, February 04, 2011 5:10 PM
  • Lior: You are a lifesaver. I had the same problem after installing samsung's crappy kies. Repair of these components got syncToy working. I cant thank you enough!
    Saturday, February 26, 2011 8:06 PM
  • Go to control panel > add remove programs > search for the components as Lior said > click on change > and then repair. Et voila!
    • Proposed as answer by osappg Thursday, October 27, 2011 3:21 PM
    Saturday, February 26, 2011 8:07 PM
  • It works after repaired both of them and no need to uninstall and restart.

    Thanks so much

     

    Thursday, March 17, 2011 2:07 AM
  • Dear Lior,

    You are the angel!!

    The problem really "headached" me for months.

    You saved lots of us!!

    THANKS!!

    Brian Wong

     

    Saturday, March 26, 2011 3:37 AM
  • Brilliant !!... have had this error for a very long time... perhaps before Samsung Kies installed, but did not think it was related.  "Repair" to MS Sync resolved the issue in <10 secs. Absolutely BRILLIANT!!!... as is SyncToy itself.
    Thursday, March 31, 2011 4:59 AM
  • Hi,

     

    thank you so much Lior.  its working well.  I installed framework 2.  I was facing this issue for the past two months since i installed and uninstall ed kies.  I once again thank you so much

    Sunday, April 03, 2011 5:50 PM
  • Unbelievable! You guys saved me lots of time and refrained from cursing SyncToy and Samsung. You are the Saviour!
    Sunday, April 24, 2011 3:17 PM
  • Synctoy is superb...I love it so much. Thanks Microsoft.

    I have the same problem after I installed Samsung Kies. I  can't do the repair processes above because it asked for installation CD. Anyway I tried uninstalled and reinstalled Synctoy 2.1 x86 and the same problem appear.

    Then I tried installing Synctoy 2.1 x64 (my laptop use Windows 7) and it works. During the process, the installer update my Sync Framework.

    Thanks for the information above, And I am so grateful for all this technology, and all this companies that make it happen. I enjoyed playing with my new android tablet (hence the Samsung Kies) and how easy it is to get information when we have problems.

     

     

    Saturday, April 30, 2011 4:13 AM
  • Same cause, same effects : I installed Samsung KIES, and SyncToy started providing the error message above.

    I went to "Configuration Panel" -> "Install / Remove Programs" -> "Microsoft Sync Framework 2.0 Core Components" -> "Modify" -> "Repair"

    => back to normal SyncToy operation (without changing/fixing anything to SyncToy itself).

     

    Thanks !

     

    Sunday, May 01, 2011 8:37 AM
  • Hello

    I am sorry but i am not a computer wiz. I had the same problem. Can you tell me how to solve the issue according to what you mwentioned

    Regards

    Sami

    Thursday, May 26, 2011 8:50 AM
  • Thanks for all the information in this thread - I was racking my brains to work out what had happened, but I too had recently installed Samsung Kies. Before I read this I had repaired Synctoy, removed it completely, cleaned up my registry, all without success.

    Now I've seen this I downloaded Sync Framework 2 from http://www.microsoft.com/downloads/en/details.aspx?FamilyID=89adbb1e-53ff-41b5-ba17-8e43a2e66254&displaylang=en and re-installed it over the top of the existing installation, and Synctoy now appears to work. All that remains is to retrieve my backup of my folder pairs.

    • Proposed as answer by iLuvGadgets Monday, December 10, 2012 12:06 PM
    Friday, May 27, 2011 2:26 PM
  • 100% success with Win XP pro - Ditto with Synctoy being taken out after installing Samsung Kies, but the simple repair option in "Add or remove programs" under item "Microsoft Sync Framework 2.0 Core Components...." does the trick - no need to reinstall anything, in my case.

    Thanx 1.000,000 to all contributors on this thread, I found it by searching on error message heuristics.  Synchtoy is backing up my images as I type!!

    Tuesday, May 31, 2011 1:28 PM
  • Hi Lior,

    Thank you so much for this solution.

     

    Tuesday, June 14, 2011 7:46 PM
  • I had the same problem and i also did install Kies a week ago

    Thx to you guys i discovered that the problem is the stupid samsung software Kies, and that the solution is to reinstall Framework 2.0

     

    You saved me a lot of times ! 

    Thx once more

     

    Sunday, June 19, 2011 5:04 AM
  • Hi everybody,

    My wife also had a new mobile and the program KIES destroyed SyncToy, great you all discussed this problem as I couldn't find the problem. Samsung is really bad distributor as website is not very easy, software KIES is not working without problems and it destroyed before I found your discussion synctoy.

    It's working again after removing the 2 Microsoft Sync .... and reinstalling synctoy and repair the 2 Microsoft Sync after that again...

     

    Tuesday, June 21, 2011 9:41 PM
  • I have downloaded Kies as well only yesterday 28th June 2011 and the same problem occurred with my copy of SyncToy (a great utility)

     

    Is it not time Microsoft tell Samsung to fix their product. It is a pain to fix it - and thanks for the advice on how to fix it.  More importantly, how many people haven't found this or a similar forum and still can't get their Synctoy to work.  Has there been any affect on other products.


    Phil www.abc2xyz.com
    Wednesday, June 29, 2011 8:24 AM
  • Thank you so much...

    i've installed Kies and synctoy stopped to work, i was lost till i found this post

    you're great guys...

     

    Wednesday, July 13, 2011 9:35 AM
  • Hi!

    I have the same problem with Synctoy

    How to do a "Repair" for "Microsoft SQL Server 2005 Compact Edition" and "Microsoft Sync Framework 2.0..." to solve that problem on Synctoy?

     

    Thanks

     

    Sunday, July 24, 2011 5:59 PM
  • Thanks for the tip about repairing - it worked for me, I'm another Kies user/victim.

     

    jalmaeida62 - go to the control panel, add remove programs, click on the sql server compact item and choose repair. Then do the same for the synchronisation software in that list, too. I had to download the files the windows wanted from microsoft.com, but then I was all set to go syncing again. phew! :)

    Sunday, August 07, 2011 1:21 PM
  • Same problem (with Samsung Kies), and the "repair" solution works.  Thanks very much!!
    • Proposed as answer by Claire LBC Saturday, August 13, 2011 2:35 PM
    Saturday, August 13, 2011 3:04 AM
  • Me too, same problem and the repair worked. Be very careful to use this exact path : "Configuration Panel" -> "Install / Remove Programs" -> "Microsoft Sync Framework 2.0 Core Components" -> "Modify" -> "Repair".

    If you select "Microsoft Sync Framework 2.0 Core Components" and then immediatly "Repair" as I did at first, its doesn't work. Make sure you don't skip the "Modify" step.

    Thanks a lot !

    Saturday, August 13, 2011 2:41 PM
  • Same problem after installing Samsung Kies thanks to this thread All OK now          As mentioned above

    Go to control panel > add remove programs > search for the components > click on change > and then repair.
    NOTE:  You may have the X64 version
    Sunday, August 14, 2011 10:04 AM
  • I had same problem suddenly occur and, yes, I had installed Samsung Kies too.

    Many thanks to all contributors, particularly to Alanch1 for your explicit link and instructions.

    I installed the x86 version from the Microsoft page link (SyncSDK-v2.0-x86-ENU.msi) for my Vista laptop and Synctoy worked again brilliantly immediately afterwards, without even a reboot.

    Relief !!

     

    Wednesday, August 17, 2011 1:36 PM
  • Hi I had the same problem, I found out that Samsung KIES gives the problem. KIES is a software program for users who have a Samsung mobile phone.

     

    Toppie van Oppie is absolutely right. The SyncToy problem happens right after Samsung Kies (v2.0, for my case) installation. My error message was "Exception during preview: cannot create provider."

    I did a repair on the Microsoft Sync Framework v2.0 Provider Service and everything works fine after that!

    Some side information, reinstallation of SyncToy didn't help. I guess I didn't uninstall the Sync Framework and Provider Service and that was why. However, I didn't find out further.

    This post really saved me lots of time and unnecessary try. I would never thought that Samsung Kies would be the one giving me the problem. Great post and solution.


    • Edited by Lawrence Teo Sunday, August 21, 2011 4:48 PM Inclusion of error message
    Sunday, August 21, 2011 4:45 PM
  • Thank You so much!

    Had thew same SyncToy problem after installing Kies, the repait on the Microsoft Sync Framework v2.0 Provider Service worked fine

     

     

    Wednesday, August 24, 2011 5:45 PM
  • It worked for me too - took one minute.

     

    Thank you

    Stephen

    Wednesday, September 14, 2011 7:02 AM
  • Same cause, same effects : I installed Samsung KIES, and SyncToy started providing the error message above.

    I went to "Configuration Panel" -> "Install / Remove Programs" -> "Microsoft Sync Framework 2.0 Core Components" -> "Modify" -> "Repair"

    => back to normal SyncToy operation (without changing/fixing anything to SyncToy itself).

     

    Thanks !

     


    I also had same problem with SyncToy after Kies installation.

    The solution above, plus  "Configuration Panel" -> "Install / Remove Programs" -> "Microsoft Sync Framework 2.0 Provider Services (x86) ENU" -> "Modify" -> "Repair"
    solves the promlem for me.

    Thanks!!!

    • Proposed as answer by NCBnetworks Wednesday, October 03, 2012 5:26 PM
    Monday, October 03, 2011 8:30 PM
  • Thanks every one.

    I did not have a recovery disk, but downloaded "Synchronization-v2.0-x86-ENU.msi" and "ProviderServices-v2.0-x86-ENU.msi" from http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=18241

    Running the repair function on "Microsoft Sync Framework 2.0 Core Components (x86) ENU" and on "Microsoft Sync Framework 2.0 Provider Services (x86) ENU", I was able to direct the function to the above 2 downloaded files. 

    Bingo, SyncToys is now working fine.  Why, oh! why can not Samsung get this right!!

    Thanks everybody

    Sunday, October 16, 2011 3:09 PM
  • make

    Go to control panel > add remove programs > search for the components as Lior said > click on change > and then repair.

    OK works again....!

    Thursday, October 27, 2011 3:22 PM
  • Yet another success story here with running a repair operation on "Microsoft Sync Framework 2.0 Core Components (x86) ENU" and on "Microsoft Sync Framework 2.0 Provider Services (x86) ENU"! Thanks all for sharing. Great example of strength in numbers, people!
    Sunday, November 20, 2011 2:24 PM
  • Perfect. I had installed Samsung Kies in the hope it would fix my phone and it broke my SyncToy ... found this, ran the Repairs and boom! ... its all working again. Thank you so much, I would have swore and tried and tested for hours ...

     

    Monday, November 28, 2011 3:24 PM
  • Well Well Well.

    Just a big thanks to all involved.

    Kies broke my Sync Toy too!!!

     

    Rule one of trouble shooting????

    What did you change!?

    Note this though...

    Had to go find the relevant .msi files to get the repair to work.

    When I did my repair it wanted me to tell it where to find the files, since they were in a temp file when last used for the install.

    Initially the one (Microsoft Sync Framework 2.0 Core Components (x86) ENU") worked straight away. Just had to point it at my downloads folder after finding the relevant .msi file.

    "Microsoft Sync Framework 2.0 Provider Services (x86) ENU was tricky because the version of msi file i already had was broken... had to ownload this too. pointed the repair at the new file in my downloads folder and all was fixed!!!!

    Thanks again...

     

     

    Friday, December 02, 2011 2:21 PM
  • The same - I receive a Galaxy S2  as a gift on Cristmas, instal Kies and my Sync Toy died!

    Full month I try do something and any results till today I googled this exelent forum.

    THANK YOU LIOR! My Sync Toy repaired in some minutes!.

    Tuesday, January 31, 2012 10:12 PM
  • Thank you so much!  My problem must have started when I got a Samsung tab....and installed Kies!!

    This is a superb forum.....I followed the advice above (it took several goes as I'm a non expert and using W7!)..... and sync toy is rattling away......

    Nice to know you are here!!

     

     

    Sunday, February 05, 2012 2:46 PM
  • Thanks for all of your help here in this forum. I had this problem since 1 week as I installed KIES from Samsung.

    Now I will try to find some help for my next problem here.

    Is someone using a synch tool for outlook and Androit??

    I've tried KIES but without success, than I tried MyPhoneExplorer but this tool in my eyes is not finished.

    Does anybody has an idea for my for a good working synch tool between outlook 2007 an my androit Samsung galaxy nexus?

    Thanks a lot

    Uwe

    Wednesday, February 29, 2012 1:22 PM
  • FIXED: I just went paranoia, installed all suggested above: SyncSDK, Microsoft SQL server 2005 compact edition enu, SQL server compact 4.0 enu, Sync Framework 2.0 core components, Provider Services and of course SyncToy. Then repaired all of them again (the paranoia part) and it works.
    Tuesday, May 15, 2012 1:58 AM
  • Thanks guys!  Absolute magic!  SyncToy running again, like a little hero!  Don't know what I'd do without it!

    I uninstalled Kies before repairing.  I wonder if I can re-install Kies, then do the repair, or if the two are totally incompatible.  Still, the choice is a no brainer, even if it means dismantling my phone, to get the micro SD card out,  every time I want to download some pics! I wonder who did that bit of design work!  Should have listened to my daughter and bought an iPhone!

    I'm a bit surprised at the phone getting all the awards it did!  I suppose it just shows how many people are missing out on SyncToy!

    Monday, June 11, 2012 5:08 PM
  • Yes, repairing of the 2 SyncToy frameworks worked for me too (uninstalling Samsung Kies only is not sufficient).

    Thanks

    • Proposed as answer by chantivlad Thursday, June 14, 2012 2:33 PM
    Thursday, June 14, 2012 2:31 PM
  • Yep - repair was the answer. (Windows 7, SP 1)  Sync Toy now works again.

    I did a repair on the Microsoft Sync Framework v2.0 Provider Service and everything works fine after that!

    Control panel > Programs and Features > Microsoft Sync Framework v2.0 Provider Service > Change (After that I clicked everything that made sense - sorry I didn't record those steps, but hopefully, this gets anyone close.

    Great forum and solution.

    Sunday, August 05, 2012 9:44 PM
  • Thanks to all for the repair help.

    My commenting 2-cents: I wouldn't throw the blame on Kies or whomever. Kies didn't work on my system the way it was expected to. This thread suggests that SyncToy prevented its working. 1) SyncToy and Kies do the same job of sync' files between external device and PC. 2) SyncToy is not a component of Microsoft Windows (I recall somewhere in the SyncToy download there was a warning to that). There are zillions of add-ons, zillions chances two add-ons doing more or less the same thing will collide heads-on. I'm just glad that a simple repair gave a fix.

    Thursday, September 20, 2012 9:12 AM
  • Thanks a lot for starting this thread, your the pioneer.

    My problem started after installing this Ultra heavy and not at all good Samsung kies

    I immediately un installed kies it the same day. When after a week I used synctoy this gave me the same error and lead me to this thread.

    Once again thanks and bravo!

    Tuesday, October 02, 2012 3:44 PM
  • Hello. Y had que same error, did the repair of both Microsoft Sync Framework and worked fine !!

    Y also had installed KIES, so that program caused the error... the thing is that uninstalling KIES does not solve the problem, so repair the files manually and that´s it.

    Saturday, November 03, 2012 2:49 AM
  • Hi, thanks for the suggestion. It works for me too.

    Thank you.

    Wednesday, November 07, 2012 9:20 AM
  • Thanks for the advice, Synctoy works fine now. I had also installed Samsung Kies, I have never liked that programme, having used it in several incarnations. 
    Tuesday, December 04, 2012 7:10 AM
  • Thanks for all the information in this thread - I was racking my brains to work out what had happened, but I too had recently installed Samsung Kies. Before I read this I had repaired Synctoy, removed it completely, cleaned up my registry, all without success.

    Now I've seen this I downloaded Sync Framework 2 from http://www.microsoft.com/downloads/en/details.aspx?FamilyID=89adbb1e-53ff-41b5-ba17-8e43a2e66254&displaylang=en and re-installed it over the top of the existing installation, and Synctoy now appears to work. All that remains is to retrieve my backup of my folder pairs.

    This has worked for me!!!

    Thanks!!!

    Monday, December 10, 2012 12:06 PM
  • I've had the same problem. I had also installed & unistalled Kies which I found to be a very flaky bit of software. 

    I was unable to affect a repair as I got messages that that files were not available (I cant't remember the exact words) I uninstalle Synctoy & the two MS Framework items & then reinstalled Synctoy & it works perfectly. I Iost one folder pairing but not a big issue.

    Wednesday, December 19, 2012 5:40 PM
  • THANK YOU! Worked for me too!
    Friday, August 09, 2013 8:53 PM
  • Pretty late but just wanted to add. SyncToy is really awesome . Once I got "Exception. Failed to create provider". Thot it was temp, will try later, but some days later same thing.

    Repair Microsoft Sync frame network.

    Tried repair, but got mssge, not accessible. check path or something.

    Finally unistalled, reinstalled and LO - works fine. Yep jus checked - 1392 new files created.

    Link below helped.

    http://www.labnol.org/tech/synctoy-errors/19841/

    Tuesday, January 07, 2014 4:59 AM