locked
Outlook CRM 2011 - not return any Service Endpoints RRS feed

  • Question

  • Hi, I've installed CRM 2011 - on W2K8; the web site is working fine; I can connect from LAN.

    Now on a W7 client I try to install the Outlook connector.

    As the server url I entered: http://myserver:5555 and I click on "Test Connection" button; the form is populated with the correct user, organization and display name but when I click on "Ok" button I receive the following error:

    There is a problem communicating with the Microsoft Dynamics CRM server. The server might be unavailable. Try again later. If the problem persists, contact your system administrator.

    The IIS CRM site has the anonymous authentication enabled and I can access from the client the following url without problems: http://crmserver:5555/XRMServices/2011/Discovery.svc

    Below is the log file:

    20:18:18|  20:18:19|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ConfigInfo.RemoveOrphanDatastoreIfNeeded
    20:18:19|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ConfigInfo.ConfigInfo
    20:18:19|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.MainForm.MainForm
    20:18:19|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.MainForm.MainForm_Shown
    20:18:19|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.MainForm.AddServer
    20:18:19|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.ServerForm.ServerForm
    20:18:19|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ServerForm.ServerForm
    20:18:19|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.ServerForm.SetUIData
    20:18:19|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ServerForm.LoadAvailableUrls
    20:18:19|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ServerForm.LoadAvailableUrls
    20:18:19|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ServerForm.SetUIData
    20:18:25|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.ServerForm._testConnectionButton_Click
    20:18:25|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.ServerForm.TestConnection
    20:18:25|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ServerForm.TestConnection
    20:18:25|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ServerForm._testConnectionButton_Click
    20:18:26|  Info| Fill organization comboBox with server information.
    20:18:27|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.ServerForm._okButton_Click
    20:18:27|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ServerForm._okButton_Click
    20:18:27| Error| Exception : The provided uri did not return any Service Endpoints!  at Microsoft.Xrm.Sdk.ClientExceptionHelper.Assert(Boolean condition, String message)
      at Microsoft.Xrm.Sdk.Client.ServiceConfiguration`1..ctor(Uri serviceUri)
      at Microsoft.Xrm.Sdk.Client.OrganizationServiceConfiguration..ctor(Uri serviceUri)
      at Microsoft.Xrm.Sdk.Client.ServiceConfigurationFactory.CreateConfiguration[TService](Uri serviceUri)
      at Microsoft.Crm.Outlook.ClientAuth.ClientAuthProvidersFactory`1.GetAuthProvider(Uri endPoint, Credential credentials, AuthUIMode uiMode, Uri webEndPoint, IClientOrganizationContext context, Form parentWindow)
      at Microsoft.Crm.Application.Outlook.Config.ServerInfo.LoadUserId()
      at Microsoft.Crm.Application.Outlook.Config.ServerInfo.Initialize(Uri discoveryUri, OrganizationDetail selectedOrg, String displayName, Boolean isPrimary)
      at Microsoft.Crm.Application.Outlook.Config.ServerForm.LoadDataToServerInfo()
      at Microsoft.Crm.Application.Outlook.Config.ServerForm.<InitializeBackgroundWorkers>b__2(Object sender, DoWorkEventArgs e)
      at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
      at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)
    20:18:30|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.MainForm.AddServer
    20:18:30|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.MainForm.MainForm_Shown
    20:18:31|Verbose| Method entry: Microsoft.Crm.Application.Outlook.Config.ClientConfig.Terminate
    20:18:31|  Info| Exit code: Default
    20:18:31|Verbose| Method exit: Microsoft.Crm.Application.Outlook.Config.ClientConfig.Terminate
    20:18:31|  Info| === Microsoft Dynamics CRM for Outlook Configuration Wizard logging stopped: 4/6/2011 8:18:31 PM ===

    Any ideas ?

    Thank you,

    Daniel


    Daniel
    Wednesday, April 6, 2011 5:40 PM

Answers

  • Ok, it looks like there's a helpful error message there.

     Security settings for this service require Windows Authentication but it is not enabled for the IIS application that hosts this service

    Is it possible that Negotiate is not in Windows Authentication providers?

    1. Go to CRM website in IIS Manager
    2. Select Authentication
    3. Select Windows Authentication and add 'Negotiate' before NTLM
    4. Run iisreset to restart the server
    • Proposed as answer by Alex A. Kalinin Wednesday, April 6, 2011 9:13 PM
    • Marked as answer by DS19 Wednesday, April 6, 2011 9:17 PM
    Wednesday, April 6, 2011 9:12 PM

All replies

  • I am not sure about the email router issue, but I have some ideas on the outlook problem.  You may need to revisit the configuration of the email router along with firewall settings and such.

    If this is CRM online I would uninstall and reinstall windows live essentials as they tend to clash and this fixes the problem.

    If not, verify that your time, date, timezone settings are correct on the client and the CRM server as it tends to interferee with client - server WCF communications with the CRM services if the client and server are too far off.

    Lastly, just to make sure your email router and outlook clients are being set up properly I would refer you to the implementation guide for exact tutorials.

    Implementation guide link:

     http://www.microsoft.com/downloads/en/details.aspx?FamilyID=9886AB96-3571-420F-83AD-246899482FB4

    I hope this helps!


    Jamie Miley
    http://mileyja.blogspot.com
    Linked-In Profile
    Follow Me on Twitter!
    Wednesday, April 6, 2011 6:08 PM
    Moderator
  • If you have problems with endpoints I would do the following:

    1. Go to the server box and check Event Viewer (eventvwr) for any errors from CRM

    2. Open IIS manager (inetmgr) and check the bindings for CRM website (it should have only 1 binding), note down the port

    3. Open CRM deployment manager, right click 'Microsoft Dynamics CRM', select Web Addresses and make sure the port is the same as in IIS Manager

    I specified a solution in different thread, worth taking a look: http://social.microsoft.com/Forums/en-US/crmdeployment/thread/9942ea5f-52cc-4535-a3af-f93b6a5b1eb1

    There seems to have been a solution recently with similar topic as well http://social.microsoft.com/Forums/en-US/crmdeployment/thread/e4508d8f-ddad-41cb-b0df-d0b6d6f960ad

    Hello,

    I just found a solution, my problem was to add a port to IIS site of CRM *:80. Just delete it and restart www service.

    I use the default http://xxxx:5555 and all works fine. Due to the Outlook CRM that used by default xxx:5555/XRMServices/... so only port 80 doesn't work with Outlook client.

     

    Jérôme

    Wednesday, April 6, 2011 8:43 PM
  • If you have problems with endpoints I would do the following:

    1. Go to the server box and check Event Viewer (eventvwr) for any errors from CRM

    2. Open IIS manager (inetmgt) and check the bindings for CRM website (it should have only 1 binding)

    There seems to have been a solution recently with similar topic http://social.microsoft.com/Forums/en-US/crmdeployment/thread/e4508d8f-ddad-41cb-b0df-d0b6d6f960ad

    Hello,

    I just found a solution, my problem was to add a port to IIS site of CRM *:80. Just delete it and restart www service.

    I use the default http://xxxx:5555 and all works fine. Due to the Outlook CRM that used by default xxx:5555/XRMServices/... so only port 80 doesn't work with Outlook client.

     

    Jérôme

    1. I have found this entry in the Event Viewer:

    Sender Information: System.ServiceModel.ServiceHostingEnvironment+HostingManager/21647132 
    Exception: System.ServiceModel.ServiceActivationException: The service '/crmserver/XRMServices/2011/Organization.svc' cannot be activated due to an exception during compilation. 
    The exception message is: Security settings for this service require Windows Authentication but it is not enabled for the IIS application that hosts this service.. ---> System.NotSupportedException: Security settings for this service require Windows Authentication but it is not enabled for the IIS application that hosts this service. at System.ServiceModel.Activation.HostedAspNetEnvironment.ValidateHttpSettings(String virtualPath, Boolean isMetadataListener, Boolean usingDefaultSpnList, AuthenticationSchemes& supportedSchemes, ExtendedProtectionPolicy& extendedProtectionPolicy, String& realm) 

     

    The IIS CRM site has enabled Anonymous and Windows Authentication (NTLM)

    2. I have only one binding on port 5555


    Daniel
    Wednesday, April 6, 2011 9:03 PM
  • Ok, it looks like there's a helpful error message there.

     Security settings for this service require Windows Authentication but it is not enabled for the IIS application that hosts this service

    Is it possible that Negotiate is not in Windows Authentication providers?

    1. Go to CRM website in IIS Manager
    2. Select Authentication
    3. Select Windows Authentication and add 'Negotiate' before NTLM
    4. Run iisreset to restart the server
    • Proposed as answer by Alex A. Kalinin Wednesday, April 6, 2011 9:13 PM
    • Marked as answer by DS19 Wednesday, April 6, 2011 9:17 PM
    Wednesday, April 6, 2011 9:12 PM
  • This solved my case. Only one binding and properties of the web server in the CRM deployment manager equal to binding to all items. My deployment is on port 80.
    Ely
    Tuesday, April 26, 2011 2:32 AM
  • Thanks for advise!

    This help for my situation.

    Friday, June 10, 2011 8:46 AM
  • Thank you for this.  We were getting this error after we turned off Claims auth and IFD on CRM 2013, and instead went to 2 factor auth via our NetScalar.

    Once we adding Negotiate back in (it was turned off when IFD was on), it all worked.

    The answer was offered in 2011, but it's still just as relevant in 2015!

    Monday, September 7, 2015 3:34 PM