locked
Issue after databases moved to new server - Privilege With Id <....> Does Not Exist RRS feed

  • Question

  • Morning

    We have recently moved our database to another server and since then I cannot create new entities in our CRM instance.

    When I try I get the below error message. The Trace logs don't give any more detail as it seems to be a more fundamental issue that just user privileges.

    Unhandled Exception: System.ServiceModel.FaultException`1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: privilege With Id = 0d8251b8-fd30-46ee-9c22-02d8f1723ded Does Not ExistDetail: <OrganizationServiceFault xmlns:i="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/xrm/2011/Contracts"> <ErrorCode>-2147220969</ErrorCode> <ErrorDetails xmlns:d2p1="http://schemas.datacontract.org/2004/07/System.Collections.Generic" /> <Message>privilege With Id = 0d8251b8-fd30-46ee-9c22-02d8f1723ded Does Not Exist</Message> <Timestamp>2016-03-22T10:12:37.222735Z</Timestamp> <InnerFault i:nil="true" /> <TraceText i:nil="true" /> </OrganizationServiceFault>

    Can anybody offer any advice on this please? Thankfully this is a development instance but we do need to move our production systems as well in the very near future.
    Tuesday, March 22, 2016 10:31 AM

All replies

  • Just created a new CRM instance on the same servers (application and database) and this has the same issue.

    Is there something obvious I'm missing somewhere?

    Tuesday, March 22, 2016 11:28 AM
  • Assuming on the same domain you need to script the Crm logins from previous do an run against new one
    Wednesday, March 23, 2016 9:41 PM
  • Thanks - apologies for the delay, was out of office :)

    Do you mean the SQLServer Logins? This appears to have been done successfully on the new SQLServer.

    Would this affect new instances as well as migrated instances of CRM?



    Wednesday, April 6, 2016 11:05 AM