event viewer cannot connect to computer "computer name"the rpc server is unavailable RRS feed

  • Question

  • hi,

     I am getting error in Active Directory (windows server 2008 Enterprise) when I
    connect to a remote machine (win XP) via event viewer, it always complain that rpc
    server is not available.


    Error is :- Event Viewer cannot connect to computer computer_name and the reported

    error: "The RPC server is unavailable".

    All the services related to RPC are in automatic status & started as well.

    Earlier firewall is on & tried with setting it off but doesn't work.

    Monday, November 8, 2010 9:53 AM

All replies

  • Allow inbound rules on the remote machine firewall. Even if the firewall is off.

    1. Computer Configuration –> Policies –> Windows Settings –> Security Settings –> Windows Firewall with Advanced Security –> Inbound Rules
    2. Right click and left click on New Rule.
    3. Click the Predefined radio button.
    4. Choose the Remote Event Log Management option in the drop down list
    5. Click Next.
    6. Leave the defaults and click Next.
    7. Choose Allow the connection and click Finish.


    • Proposed as answer by fmatosic Friday, February 4, 2011 4:13 PM
    Friday, February 4, 2011 9:49 AM
  • In my case, it was after applying Windows Server 2008 SP2 - the console itself was waiting for a person to click "Ok" that SP2 had finished installing.

    Sometimes, there's an additional whrily-gig of dos-window activity related to the Service Pack CAB file after you log in.

    Funny thing: even if you RDP /console (or /admin), it won't let you in, you have to go THE ACTUAL console, login and click 'OK.'

    Maybe because some piece of RDP itself was being updated.

    After clickink 'ok' at console, all is well, RDP is happy, etc.

    Monday, September 16, 2013 6:48 PM
  • In services, plase check the  following

    rpc services------started


    Saturday, October 19, 2013 5:51 AM
  • You are a legend! 

    Thanks for the new rule!

    Friday, April 25, 2014 5:52 AM