locked
Email Router Send Error "5.7.1 Client does not have permissions to send as this sender" using Local Service Account RRS feed

  • Question

  • Hi,

    We have been using CRM 4.0 email router (Rollup 7) for some time in situe on a Exchange 07 box for some time with little fault. However there is now an issue whereby emails will not send via the router, with the error "5.7.1 Client does not have permissions to send as this sender". In the first intance this was solved by using a domain admin account in the outgoing access credentials. This is not ideal, and I am at a loss as to why this behaviour has occured using the local system account. We could use a less privelaged account on Exchange, but this will involve changes to users SendAs permissions, as this was not needed before I am reluctant to do this now. Both the Exchange and CRM boxes are members of the PrivUserGroup.

    Any pointers or ideas will be great, as i'm at a loss here!

    Many Thanks

    Rich
    Tuesday, October 27, 2009 10:15 AM

Answers

  • Hi Rich,

    Here are two ways of solving this.

    a.  use an account with minimal rights on exchange server, but that do have the 'send as' rights. 

    b.  Allow anonymous send on your exchange server smtp connector ONLY from the ip address of the crm server.  The advantage is that you can then setup the outgoing connector to use anonymou ssmtp.  The disavantage is that you need to allow anonymous relay from that CRM server ip.
    Alex Fagundes - www.PowerObjects.com
    Tuesday, October 27, 2009 5:58 PM