none
"SyncToy.config" file CANNOT be edited to change logging detail from "Info" to "Verbose"

    General discussion

  • The FAQ's for SyncToy and the Help file suggest, to increase information available for troubleshooting "hangs" and errors, editing the "SyncToy.config" file in SyncToy's installation folder to change

         "<add name="SyncToyTraceLevel" value="Info" />"

    TO

         "<add name="SyncToyTraceLevel" value="Verbose" />".

    I am running Windows 10, and just installed the Creators Upgrade, 64-bit, and have the 64-bit version of SyncToy installed.  It always ran flawlessly before the upgrade, but now it's hung several times on the same folder pair, in one user account only.  So I uninstalled and then reinstalled it without problem.

    Before recreating and running that folder pair, and "Echo" operation, I wanted to increase the logging detail in case the problems persist or increase.

    However, despite running as a system administrator, and having taken ownership of, first the "SyncToy.config" file, and then the entire folder, and then restarting the PC, I am refused permission to do the edit.  More accurately, I can change the text in Notepad, but when I attempt to save the file and replace the original, I am told to consult an administrator or the file owner!  I tried renaming the original file as "SyncToy2.config", which succeeded, but was still no allowed to save the file with text edits back to the folder as "SyncToy.config".

    PLEASE HELP.  I'M STUCK.

    • Changed type Kengrush (TechNet) Sunday, August 27, 2017 6:59 PM Important qualification for instructions in the Help file for SyncToy 2.1 about editing the "SyncToy.config" file to allow "verbose" logging.
    Sunday, August 27, 2017 6:31 PM

All replies

  • UPDATE:

    The problem has been solved.  I ran into a similar scenario a while ago with XP, and the with Windows 7.

    It seems that not all Administrators are created equal!  Users granted System Administrator group membership are usually granted full access to the file system.  But, and I'm reaching here without thorough research, but my prior memory seems to include this, when trying to alter system or other critical files, only THE BUILT-IN ADMINISTRATOR account can succeed.

    I usually keep this "super" account disabled, and with a strong password in case somehow accessed.  So I re-enabled the built-in Administrator account and logged into it.  Voila!  Change effected without any change of permissions or changing the owner from "SYSTEM" to the Administrator.  I then disabled that account again.

    Nice to be reminded of this fact, and I guess it's more secure that way, but enabling that account and logging in for the first time and creating the profile ate up ~250 MB!

    Sunday, August 27, 2017 7:10 PM