WHS Connector setup fails with "A maximum of ten computers have already been added" RRS feed

  • Question

  • A brief history:
    I was using OneCare to back up my two 64-bit machines directly to a network share on WHS because I was never able to install the Connector on either of these machines.  Not a big deal until I ran out of space and had to add a new disk.  Now my OneCare backups fail with "not enough space" even though there is 698GB free space according to the console.  OneCare can see 23 GB of free space when I try to back up.  So now I need to actually bother installing the connector and get it working.  I try and it fails many times "Configuring Computer Backup".  There is no toolkit for 64-bit that I can find, so I spend much time troubleshooting and rerun setup many times.  Suddenly it starts failing with an exciting new error:

    This computer cannot be added to Windows Home Server.

    A maximum of 10 computers have already been added.  Use the Windows Home Server Console to remove a computer that is no longer being used and then try again.

    One WHS with one 500 GB disk it came with, and a 750GB disk that I just added
    One 32-bit Windows XP machine that is connected and successfully working.  This is the only computer that shows up in the WHS console.
    Two 64-bit Vista machines that can access WHS network shares, but WHS Connector Setup fails during the "Configuring the Backup" stage.

    Any ideas on how to get past this error, or at least be able to see the space to run a OneCare backup until the setup issue is sorted out?

    Wednesday, October 29, 2008 7:42 AM


All replies

  • OneCare seems to see only the space in the landing zone, which is the free space on drive D:.
    Do you have folder duplication enabled on the backup folder?
    Maybe the backups of your PCs are still stuck on your D: drive as well, so the disk is nearly full.
    You can try to trigger the relocation to the second disk by using LZReallocator from http://vanelsberg.homeserver.com/public/whs/LZreallocator.zip
    Regarding your second problem, may be worth to dig through the registry of your WHS, key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Home Server\Transport\Clients. Are there multiple appearances of the same or no longer existing machines?
    Best greetings from Germany
    Wednesday, October 29, 2008 9:05 AM
  • Vista sees only the space on the D: partition, and you filled that partition. This can happen if you run your server almost entirely out of space, then add a drive which it looks from your post like you did. Using the (unsupported, but reasonably harmless) LZReallocator tool that Olaf recommended is a good idea, and will probably get your OneCare backups working again.

    As for the error message you're seeing, is it possible that you're trying to install the connector on your x64 computers from the Connector CD that shipped with your HP MediaSmart Server? (I assume that's what you have.) If so, you can try running the installer from the server directly using the URL

    (replacing SERVER with the name you gave your server).

    I'm not on the WHS team, I just post a lot. :)
    Wednesday, October 29, 2008 3:47 PM
  • I found the reg keys and deleted them, so now when I run setup I'm getting the old "Configuring Computer Backup" setup failure.  I haven't run the LZReallocator yet, I'll try that when I get home tonight.

    I've been running setup.exe directly from the network\\server\Software\Home Server Connector Software.  The date is 7/12/2008 so I guessed that was the right version.

    When I browse to HTTP://SERVER:55000 
    and click download it brings up this page: http://<server>:55000/setup/WHSConnectorInstall.exe and I get a 404 Page Not Found

    I can see that file on my WHS in c:\WHS directory though.  Should I try copying it and running locally?  Or does this, and all the partly successful installs, indicate some wierd network problem?

    Thanks for your help!

    Wednesday, October 29, 2008 4:32 PM
  • Hello,
    this kind of problem appeared after upgrading to Power Pack 1, if people relocated the folder \\server\Software\Home Server Connector Software or removed some files from here.
    Please check http://social.microsoft.com/Forums/en-US/whsfaq/thread/144dda77-d40a-4fe9-a5bc-bf71fa66b0d5/ for a list of files, which you need to have there and how to get them back.

    Which version does your WHS console show? Should be 6.0.1800.x
    Best greetings from Germany
    • Proposed as answer by Ken WarrenModerator Wednesday, October 29, 2008 10:22 PM
    • Marked as answer by GlitterMom Thursday, October 30, 2008 7:53 AM
    Wednesday, October 29, 2008 9:35 PM
  • Thanks Ken and Olaf!

    I ran ConnectorInstallAssistant.cmd and was finally able to install the connector successfully on both 64-bit machines!  Now I have a file conflict with setup.exe, but it's installed and backup is running now so this seems like a huge victory!

    Thursday, October 30, 2008 7:52 AM