locked
Forwarding of Port 80 and Work-Arounds RRS feed

  • Question

  • I just found out that my ISP, Cox Communications in California, blocks port 80 but not port 443.  Both are needed to enable remote access.  Cox refered me to www.portforward.com which offers a program that manages a router.  However, I beleive this is bad advice since the problem is Cox, not my router blocking port 80.  Do you experts agree?

    Also, are there any work-arounds to this?  For example, can I configure WHS to use a different port than 80?  If so, how?  Are there other ways to get around my ISP blocking port 80?

    Thanks in advance for the help!
    Saturday, September 12, 2009 8:21 PM

Answers

  • Thanks for the response.  I decided to rebuild my server so it took time to get back to this point.

    Yes, that was part of the problem, but it also required my to remap the port 80 https function to another port in my router.  This was easily done using the Linksys router configuration sreen.  It was also necessary to check or uncheck (I don't remember which and I'm away from the router now) a box in the WRT54G Game setting page.  I now access my home server using https:xxxx.homeserver.com:port.

    Note the inclusion of the new port number.  That additional information is necessary.

    I purchased a book tittled, "Windows Home Server Bible", by Kettle and Kettle.  It is an excellent resource and one I'd recommend anyone using WHS get.  It will save a newbie like me a lot of time!
    • Marked as answer by BobMarso Monday, September 21, 2009 5:57 PM
    Monday, September 21, 2009 5:28 PM

All replies

  • I just found out that my ISP, Cox Communications in California, blocks port 80 but not port 443.  Both are needed to enable remote access.  Cox refered me to www.portforward.com which offers a program that manages a router.  However, I beleive this is bad advice since the problem is Cox, not my router blocking port 80.  Do you experts agree?

    Also, are there any work-arounds to this?

    Yes, and it's easier than you might think (and more secure in the process  :)  ).  Just use https://xxxxx.homeserver.com when typing your website.  (Although my ISP does not block port 80, I don't forward it since I want my server to be as secure as possible.)

    For example, can I configure WHS to use a different port than 80?  If so, how?  Are there other ways to get around my ISP blocking port 80?

    Thanks in advance for the help!

    Saturday, September 12, 2009 10:42 PM
    Moderator
  • Thanks for the response.  I decided to rebuild my server so it took time to get back to this point.

    Yes, that was part of the problem, but it also required my to remap the port 80 https function to another port in my router.  This was easily done using the Linksys router configuration sreen.  It was also necessary to check or uncheck (I don't remember which and I'm away from the router now) a box in the WRT54G Game setting page.  I now access my home server using https:xxxx.homeserver.com:port.

    Note the inclusion of the new port number.  That additional information is necessary.

    I purchased a book tittled, "Windows Home Server Bible", by Kettle and Kettle.  It is an excellent resource and one I'd recommend anyone using WHS get.  It will save a newbie like me a lot of time!
    • Marked as answer by BobMarso Monday, September 21, 2009 5:57 PM
    Monday, September 21, 2009 5:28 PM
  • Thanks for the response.  I decided to rebuild my server so it took time to get back to this point.

    Yes, that was part of the problem, but it also required my to remap the port 80 https function to another port in my router.  This was easily done using the Linksys router configuration sreen.  It was also necessary to check or uncheck (I don't remember which and I'm away from the router now) a box in the WRT54G Game setting page.  I now access my home server using https:xxxx.homeserver.com:port.

    Note the inclusion of the new port number.  That additional information is necessary.

    I purchased a book tittled, "Windows Home Server Bible", by Kettle and Kettle.  It is an excellent resource and one I'd recommend anyone using WHS get.  It will save a newbie like me a lot of time!
    https is port 443.  http is port 80.  You shouldn't have had to remap anything (unless your ISP is blocking port 443 as well).
    Wednesday, September 23, 2009 12:58 AM
    Moderator