none
procedure entry point _except_handler4_common could not be located

    Question

  • I get the following error when trying to run the DRMShow sample application from the Windows Media Format SDK:

    "The procedure entry point _except_handler4_common could not be located in the dynamic link library msvcrt.dll"

    I had to recreate the project since I use VC 2003 and the sample expects a more recent version, so I may have missed some settings.  I'm trying to run it on XP and linking it with:

    WMStubDRM.lib
    Advapi32.lib
    LIBCP.LIB
    libc.lib


    Many thanks,
    Alex
    • Moved by nobugzMVP Wednesday, June 04, 2008 1:09 PM Off topic for C++ General
    Wednesday, April 04, 2007 9:14 PM

All replies

  • Just got this from WMLA:

    We have identified a bug with the Format SDK v11 stublibs that cause a run-time application failure on Windows XP. The failure is caused because the stublibs are built with a dependency on the Vista C run-time components. These run-time components are often not present on Windows XP.  The application failure may result in the following error message:

     

    "The procedure entry point _except_handler4_common could not be located in the dynamic link library msvcrt.dll”

     

    A fix has been generated and final testing is underway.  We expect to have the revised stublibs available to distribute to you sometime next week.  The new stublib will have the same ID as the one previously provided and it should replace your existing one.  The previously one you received should be destroyed.
    • Proposed as answer by stojkovski77 Tuesday, June 02, 2009 4:35 PM
    Friday, April 06, 2007 7:54 PM
  • when is this update going to come out cause this update that you put out really messed up my computer bad, and im going to have to reconfigure my computer again to fix your mess up
    Sunday, August 12, 2007 3:13 AM
  • Anonymous said:
    A fix has been generated and final testing is underway.  We expect to have the revised stublibs available to distribute to you sometime next week. 


    Great... I'm getting this error *now* on some stuff... So if your "fix" came out anywhere within a week, as stated... Then it didn't work for me! - Since it now seems to be over a *year* later!

    I tried putting the DLL with that function into windows\system32\msvcrt.dll - but then Windows wouldn't even boot! - And I'm not sure how else to tell arbitrary software to use the other DLL!  :(

    Any ideas...?
    Wednesday, June 04, 2008 12:33 AM
  • Anonymous said:
    A fix has been generated and final testing is underway.  We expect to have the revised stublibs available to distribute to you sometime next week. 

     


    Great... I'm getting this error *now* on some stuff... So if your "fix" came out anywhere within a week, as stated... Then it didn't work for me! - Since it now seems to be over a *year* later!

    I tried putting the DLL with that function into windows\system32\msvcrt.dll - but then Windows wouldn't even boot! - And I'm not sure how else to tell arbitrary software to use the other DLL!  :(

    Any ideas...?

    Tuesday, June 02, 2009 4:38 PM