locked
Error when running reports in CRM 4 http 500 internal Error RRS feed

  • Question

  • Hi,
    I have CRM 4 setup which is running reporting services.
    Since today the reports have stopped working and when I try and access the sites I get a HTTP 500 internal error, I have checked all services are up and running seem fine, I repaired the connector and still no luck.  Also have checked the reporting services configuration in SQL 2005 and all looks fine with green ticks, unsure why this is happening, on the web server there was this event log 19968 MSCRMreportingServices Client found response content type of 'text/html; charset=utf-8', but expected 'text/xml'.
    Has anyone seen this before?
    Thanks


    Monday, August 24, 2009 3:19 PM

Answers

  • Try browsing directly to the Report Manager URL. The message 'Client found response content type of 'text/html; charset=utf-8', but expected 'text/xml'.' often occurs when reporting services returns an error message, rather than data, and you should see the message in Report Manager


    Microsoft CRM MVP - http://mscrmuk.blogspot.com  http://www.excitation.co.uk
    Tuesday, August 25, 2009 8:24 AM
    Moderator
  • We need to isolate where the problem is.  Is the 500 (which means 'internal server error' and is typically at the IIS level, below ASP.NET) error comming from the CRM or the SSRS server?  As David suggests, can you browse to both the Http://reportservername/reports and http://reportservername/reportserver  URLs to see if the manager and Web services are working?  Does the rest of CRM work? 
    || Aaron Elder - Dynamics CRM MVP || http://www.ascentium.com/blog/crm
    Tuesday, August 25, 2009 5:15 PM

All replies

  • Try to reboot your reporting service server to see if your problem go away.  I will try reboot first before digging deeper into it.
    Darren Liu | 刘嘉鸿 | MS CRM MVP | English Blog: http://msdynamicscrm-e.blogspot.com | Chinese Blog: http://liudarren.spaces.live.com
    Monday, August 24, 2009 8:31 PM
    Moderator
  • Have rebooted both web server and reporting service server and still no luck.
    Monday, August 24, 2009 9:00 PM
  • Try browsing directly to the Report Manager URL. The message 'Client found response content type of 'text/html; charset=utf-8', but expected 'text/xml'.' often occurs when reporting services returns an error message, rather than data, and you should see the message in Report Manager


    Microsoft CRM MVP - http://mscrmuk.blogspot.com  http://www.excitation.co.uk
    Tuesday, August 25, 2009 8:24 AM
    Moderator
  • We need to isolate where the problem is.  Is the 500 (which means 'internal server error' and is typically at the IIS level, below ASP.NET) error comming from the CRM or the SSRS server?  As David suggests, can you browse to both the Http://reportservername/reports and http://reportservername/reportserver  URLs to see if the manager and Web services are working?  Does the rest of CRM work? 
    || Aaron Elder - Dynamics CRM MVP || http://www.ascentium.com/blog/crm
    Tuesday, August 25, 2009 5:15 PM