CRM 4.0 Outlook Client - Fails on Install RRS feed

  • Question


    Hi Guys,


    I tried to install the outlook client for CRM 4.0 today, firstly i tried to upgrade from the CRM 3.0 Outlook client which it seemed to go ahead with (it gave the option to upgrade), but then failed when checked for the SQL instance for CRM.


    Strangely enough, the new client had removed the SQL instance and was now trying to find it again? Bug....?


    2nd try, I removed all traces of SQL and Microsoft CRM by following Microsoft's KB article on manually removing CRM 3.0 Outlook client. I then ran the install, it installed the requirements plus the SQL instance and copied the files. Right near the end it started rolling back the actions and said the installation had failed. Another bug?


    I followed this KB for removal: http://www.microsoft.com/dynamics/crm/using/deploy/removeclient.mspx


    Any ideas? I shall try on some other PC's and update you.



    Tuesday, January 29, 2008 12:27 PM


All replies


    Below is some of what the crm40setup.log contained:


    Calling custom action Microsoft.Crm.Setup.Client!Microsoft.Crm.Setup.Client.ClientSetup.UpgradeDatabase
    Searching for Database Files
    Moving Database Files
    Finished Database Actions
    Assigning Permissions for S-1-5-21-484763869-1682526488-839522115-5220
    C:\Program Files\Microsoft CRM\sql\v3_msde_mscrm.mdf
        at System.Security.AccessControl.NativeObjectSecurity.CreateInternal(ResourceType resourceType, Boolean isContainer, String name, SafeHandle handle, AccessControlSections includeSections, Boolean createByName, ExceptionFromErrorCode exceptionFromErrorCode, Object exceptionContext)
       at System.Security.AccessControl.FileSystemSecurity..ctor(Boolean isContainer, String name, AccessControlSections includeSections, Boolean isDirectory)
       at System.Security.AccessControl.FileSecurity..ctor(String fileName, AccessControlSections includeSections)
       at System.IO.FileInfo.GetAccessControl()
       at Microsoft.Crm.Setup.Client.DatabaseInstaller.Upgrade(Session session)
       at Microsoft.Crm.Setup.Client.ClientSetup.UpgradeDatabase(Session session)
    Action ended 11:51:13: InstallFinalize. Return value 3.
    Action 11:51:13: Rollback. Rolling back action:
    Rollback: UpgradeDb
    Rollback: InstallHelpIndexAction
    Rollback: EditSqlExpress
    Rollback: EditMapi
    Rollback: Copying new files
    Rollback: Creating folders
    Rollback: Updating component registration
    Action ended 11:51:23: INSTALL. Return value 3.
    Action ended 11:51:23: ExecuteAction. Return value 3.
    Action 11:51:23: SetupCompleteError.
    Action start 11:51:23: SetupCompleteError.
    Info 2898. For TahomaBold10 textstyle, the system created a 'Tahoma' font, in 0 character set, of 16 pixels height.
    Action 11:51:23: SetupCompleteError. Dialog created
    Action ended 11:52:39: SetupCompleteError. Return value 2.
    Action ended 11:52:39: INSTALL. Return value 3.
    === Logging stopped: 29/01/2008  11:52:39 ===
    MSI (c) (D4:74) [11:52:39:520]: Product: Microsoft Dynamics CRM 4.0 for Microsoft Office Outlook -- Installation failed.

    MSI (c) (D4:74) [11:52:39:522]: Windows Installer installed the product. Product Name: Microsoft Dynamics CRM 4.0 for Microsoft Office Outlook. Product Version: 4.0.7333.3. Product Language: 1033. Installation success or error status: 1603.

    Tuesday, January 29, 2008 2:25 PM
  • Tried removing all files from the Outlook folders under application data for the user. This removed 'CRM' from the menu, which was greyed out anyway.


    Still doesn't work =(


    Wednesday, January 30, 2008 10:14 AM
  • @PartyMarty:

    Are you still facing the same problems? I (and a collegue) have the exact same problems as you descibed above. Removed everything (using Windows Install Clean Up tool), cleaned registry, but nothing seems to work. Please help.


    Monday, March 10, 2008 2:06 PM

    No, I've solved all my issues.


    add me on MSN - party (dot) marty (at) hotmail (dot) com

    Monday, March 10, 2008 4:41 PM
  • I'm having this same problem.  Is there anyone that can post a resolution? 



    Thursday, March 20, 2008 9:32 PM