locked
CRM 4.0 Plugin registration issue on Windows Server 2008 R2 RRS feed

  • Question

  • Dear all,

     

    I have installed the CRM plug-in registration tool on a Microsoft Dynamics CRM 4.0 application server built on Windows Server 2008 with SQL Server 2008. I am receiving 'Unhandled Exception: System.Net.WebException: The request failed with HTTP status 401: Unauthorized. I registered the plugin with the installation user (local admin on both DB and App server and also Deployment Admin)

     

    Sometimes IISreset helps.

     

    I couldn't get any message inside the Tracie yet, but as soon as I have I'll post it.

     

    Did anybody have familiar issue? Could it be solved?

     

    Thanks in advance,

     

    Zoltan

    Thursday, December 9, 2010 6:14 PM

Answers

  • I had the problem to. I've downloaded the newest version of the registration tool and that helped for me. The tool included in the sdk just don't work anymore.
    The link to the newest version is here.

    Let me know if this solved your problem to.

    Steven De Waele

    Monday, January 3, 2011 5:51 PM
  • I solved my problem (Or our hardwere genius did). It was an issue in server machine. I try to explain problem shortly, altough i does not know much about these things.

    Our server machine have two network adapter connected. The Server Machine does not use DHCP so it generates IP:s for these networkcards (Here is an article about that http://support.microsoft.com/kb/220874) . The problem with plugin Registration Tool caused because of somekind of mixup with network adapters IP:s. We disabled other network adapter from server machine and after that Plugin Registration Tool worked ok.

    Hope this quids someone who have similar problems. 

    Wednesday, January 5, 2011 11:42 AM

All replies

  • Hi Zoltan, I had a similar issue on a new dev server recently. I haven't solved it yet but I think it's to do with Kerberos authenticaion and SPNs. Mine is an IFD configuration which can often cause authentication issues. As soon as I can find a solution, I'll post it back here.

    Regards, Neil


    Neil Benson, CRM Addict and MVP at Customery Ltd. You can reach me on LinkedIn or Twitter. Join over 10,000 other CRM professionals on the Microsoft Dynamics CRM group on LinkedIn.

    Thursday, December 9, 2010 9:24 PM
    Moderator
  • Hi, I also got similar issue. I have succesfully used Plugin Registration Tool many times before. But now In new CRM Server (Windows Server R2) connection to organization fails with 'Unhandled Exception: System.Net.WebException: The request failed with HTTP status 401: Unauthorized'. Has anyone found out whats wrong?

    Jani 

    Friday, December 31, 2010 10:08 AM
  • I had the problem to. I've downloaded the newest version of the registration tool and that helped for me. The tool included in the sdk just don't work anymore.
    The link to the newest version is here.

    Let me know if this solved your problem to.

    Steven De Waele

    Monday, January 3, 2011 5:51 PM
  • I solved my problem (Or our hardwere genius did). It was an issue in server machine. I try to explain problem shortly, altough i does not know much about these things.

    Our server machine have two network adapter connected. The Server Machine does not use DHCP so it generates IP:s for these networkcards (Here is an article about that http://support.microsoft.com/kb/220874) . The problem with plugin Registration Tool caused because of somekind of mixup with network adapters IP:s. We disabled other network adapter from server machine and after that Plugin Registration Tool worked ok.

    Hope this quids someone who have similar problems. 

    Wednesday, January 5, 2011 11:42 AM
  • Hello,

    Have you checked by giving IP of crm server. i mean connect plugin registration tool with IP not netbios name.

    :)
    • Proposed as answer by Unirix01 Sunday, January 23, 2011 5:46 PM
    Sunday, January 23, 2011 5:15 PM