locked
Cannot see image any image on the "Stitch" screen RRS feed

  • Question

  • The old version of ICE worked fine on my HP laptop (Windows 7 - 64 bit). But I just downloaded the new version, along with the VC++ redistributable package (2013) and I am having issues. Once the images are stitched I cannot see anything on my screen. It is just a black blank screen. I can export the unseen panorama (as a JPG) and view it in other programs (e.g. Picasa) but not within ICE! Any ideas why?
    Sunday, February 15, 2015 2:04 AM

All replies

  • I have the same problem here: The stiched image is not shown in steps 2 to 4 but you can export it successfully.

    My system: Windows 7 SP1, I7 processor, 8GB ram, Geforce GTX 970 (not newest driver because it killed my system - Windows didn't start anymore - but everything else works flawlessly)

    Tuesday, February 17, 2015 10:08 AM
  • I have the same thing happening occasionally. After compositing several images and clearing each one without restarting ICE, suddenly step 3 will be blank. If I restart ICE it will work fine again, even on the same photo set. I'm using Win 7 x64 sp1 on Lenovo Thinkpad,  Intel i7-4700MQ, 2.4 GHz, 16.0GB ram and ICE 2.0.2.0.
    Wednesday, February 18, 2015 5:51 PM
  • I have exactly the same problem on my Win 7 64bit ACER. I can do everything and export and so on, but cant see anything until its .jpg.

    I really like the programme and am also interested what can fix this.

    Wednesday, February 25, 2015 3:54 PM
  • Everyone who ran ICE 2.0.2 and saw no preview on the Stitch, Crop, and Export pages: please try the latest update (version 2.0.3).  You'll be asked if you want to download the update next time you run ICE, or you can get it from the home page: http://research.microsoft.com/en-us/um/redmond/projects/ice/

    Version 2.0.3 displays a message rather than a blank screen whenever it fails to render a preview, and it reports telemetry to Microsoft (completely anonymous) so that we can diagnose the problem.  We'd love to solve this issue, but we'll need to gather data from people using the app before we can begin to understand what's going wrong!

    Thanks for using ICE and helping us fix this problem.


    Eric Stollnitz, Computational Photography Group, Microsoft Research

    Thursday, February 26, 2015 10:27 PM
    Moderator
  • Eric, Thanks for trying, but this did nothing for me. No message showed up, and yet I can see no stitched image. Only the black background and cross-hairs. (It seems as if ICE thinks it has rendered the image, but the image just does not show up!) Also, this time I tried with vertically oriented images but ICE tried to stitch them horizontally, and when I exported the panorama to a file, I saw a garbled image. I will be happy to send you the originals and the rendered panorama so that you can test it out yourself. In the meantime, is it possible to let us download Version 1 of the program so that we can actually use ICE. R
    Friday, February 27, 2015 3:45 PM
  • Still no preview with 2.0.3.0 64-bit 2015-02-24 22:47:59, and no error messages.

    Laptop with Windows 7 Ultimate SP1 64-bit, 8GB RAM, AMD Radeon 6600M video.

    I create my own SPJ files which I load into ICE to stitch.  Export works fine, but no previews after the Import screen.

    Thanks.

    Oops, spoke a little too soon- ICE 2.0.3 is creating PSB files even though the file size is small enough that a PSD would work, and even if the extension PSD is explicitly used in the export file name.  2.0.2 was creating PSDs of the same composites.  This is a big pain because GIMP won't load PSBs.  I haven't done a lot of testing, but a 64-layer export at 3500x2761 pixels produces a 183M PSB, while a 3000x2366 export of the same composite produces a 134M PSD.  I just located a 382M PSD that 2.0.2 created, so this is a recent change.




    • Edited by SeanRiddle Saturday, February 28, 2015 10:19 AM added PSB info
    Saturday, February 28, 2015 9:53 AM
  • I had a similar problem on W7 64bit.

    After stitching together half a dozen panoramas the program still appeared to process multiple images, but at no point did the UI display them.

    Shutting down the program and restarting it removed the error. It has only happened once (the first use after installing it).

    Sunday, March 1, 2015 2:28 AM
  • Same problem, when it comes to render the stitched panorama it says

    Preview is unavailable.

    (Could not create Direct3D texture from shared handle.)

    Sunday, March 1, 2015 12:35 PM
  • ARI expert:  At least you get the error message. For many of us, we don't even get the error message as the new version is supposed to display. I guess, unless Eric and his team can duplicate the problem, we are out of luck :-(.  Can we get the older verison of ICE somewhere? R
    Sunday, March 1, 2015 8:00 PM
  • I am admitting defeat and going back to the older version of ICE:  

    https://web.archive.org/web/20131024123003/http://research.microsoft.com/en-us/um/redmond/groups/ivm/ice/ 

    Works like a charm!

    R

    • Proposed as answer by Ancoma Monday, August 31, 2015 4:50 PM
    Sunday, March 1, 2015 8:23 PM
  • Going back too.. :(
    Monday, March 2, 2015 7:05 PM
  • It looks like there are a few different causes for blank previews -- some intermittent and some persistent.  At least we are now getting telemetry indicating what kinds of problems ICE is having with Direct3D, so we have somewhere to start.

    It may take us a while to figure out what's going wrong in each case.  We'll let you know when we've got an update, but for now -- sad to say -- your best option if you encounter a blank preview is to uninstall ICE (from the Control Panel) and install ICE 1.4.4 using the link Ra__Ra provided above.

    Thanks for your patience!


    Eric Stollnitz, Computational Photography Group, Microsoft Research

    Monday, March 2, 2015 7:46 PM
    Moderator
  • i'm having this exact same issue with vista 64bit, however i do get the stitched panorama by exporting it.

    Monday, March 16, 2015 11:39 PM
  • ICE v. 2.0.3, works well on my Windows 7 64-bit (GTX650 Ti 2G), but Vista 32-bit (Radeon HD 3400) yields error message from shared handle. 

    No Preview in Stitch

    I successfully exported, but was unable to preview the projection, orientation, or cropping.

    Thursday, March 19, 2015 2:09 AM
  • Same problem here too, go back to older Version.

    Thanks anyway for ICE Panorama it is Free, it is good to use and most important it Works

    Saturday, March 28, 2015 10:28 PM
  • Now i am using 2.03 or whatever is the latest.  I see that nothing has changed........  tried using it again today for a 3 picture pano from jpegs that i know stitched (rotation) together well because i had just stitched it with the earlier version of ICE.  Still no previews and when i imported it, the version of the pano i got was a stitch of only 2 of the jpegs.  I kind of figured that after 3 1/2 months that you would have figured out something by now, considering i'm not trying to do anything the old version couldn't do.  I guess not 
    Wednesday, July 1, 2015 6:50 PM
  • I just tried the 2.0.3 version of ICE on vista 64bit once again.  3 shot pano, rotation.......  got the preview is unavailable box.......exported the stitch and got a pano of only 2 of the 3 shots.  It was a straight forward pano of seattle, nothing fancy or that the old version of ICE couldn't do (and in fact, did do).  So I'm guessing you haven't fixed anything on the second version of ICE.
    Wednesday, July 1, 2015 6:56 PM
  • It is incredible to see that a company such as Microsoft is unable to solve such a problem in a user acceptable timeframe.

    Version 1.x worked as a charm. With earlier version of 2.x I already experienced this inability to display the image under VISTA Home Premium SP2.

    So I tried the latest 2.0.3.0 but still to no avail; Preview is unavailable; (Could not create Direct3D 9 texture from shared handle)

    The only workaround is to simply continue, clicj the autocrop otion and export to disk. The only relief is that the end result is superb.

    Sunday, July 5, 2015 2:49 PM
  • Same problem, no preview during processing. Vista 32bit sp2. I hope for a solution. 
    Monday, July 6, 2015 10:31 AM
  • I'm using Windows 7 64 bit.

    I noticed this problem with the newest version some time ago but put it down to a minor bug in the program.  The last few days I've been using it regularly and it always occurs after 15 or 16 stitches.  Closing the program and restarting is enough to get it working again.  I wondered if a cache or something like that was filling up and was cleared by closure.

    Monday, July 13, 2015 12:05 PM
  • Eric Stollnitz:

    Any update on this? As people have remarked, it has been a while! You should have figure it out by now?


    RA__RA

    Wednesday, August 19, 2015 2:20 PM
  • I was having the same problem on my laptop with two GPUs. I managed to solve it by going to graphic switching options and set the ICE app to work with integrated GPU. Now I don't have any issues with image display.
    Friday, August 28, 2015 10:42 AM
  • Same thing. Tried to update graphic drivers, tried catalyst control panel, but I don't see the preview. Had to revert to the old 1.4.4
    Monday, August 31, 2015 4:56 PM
  • Same problem on Vista 32bit.  I uninstalled 2.0.3 (using the system in Vista, via Control Panel/Programs and Features).   But 1.4.4 will not reinstall because it says a newer version still exists.  Have restarted the computer.  Any ideas??

    David P

    Tuesday, September 15, 2015 12:02 PM