locked
USB Drive not showing up in Server Storage RRS feed

  • Question

  • I added a 750gig Seagate Free Agent USB drive to my WHS PP1 server. The drive does not show up in the WHS console under the Server Storage tab.

    But when I RDP onto the WHS desktop it shows as an additional USB drive.

    I have all four drive bays loaded with internal drives and I have 5 USB drives connected externally (with a USB HUB).

    I want to use the new 750 USB drive to backup my shared folders. Does WHS PP1 have a maximum USB device threshold? What am I doing wrong?

    Friday, July 25, 2008 4:01 PM

Answers

  • I've had the same problem with a Seagate FreeAgent Pro 1TB via USB.

     

    I just "solved" it by connecting the hard drive to another PC, converting the (empty) disk into a GBT disk (with the disk management console) and then performing a quick format.

     

    After that, the WHS recognized the external drive and let me add it.

     

    I can't tell if it was just the formatting or turning the disk into a GBT disk that helped.

     

    Friday, August 1, 2008 2:35 AM

All replies

  • There isn't a maximum number of devices, but each individual external drive should be run through one USB on-board controller. Using more than one drive per controller leads to such poor speeds that it's probable that at times WHS won't see an individual drive as it might not have been able to signal it's presence in time.

     

    Colin

     

    Friday, July 25, 2008 5:12 PM
  • Do you have another USB port?

     

    Please try using that for the new USB Drive.

     

    I assume that the "Hub" is powered and even if it is the hub may have its limitations.

     

    I would not advise using "ANY USB HUB" to attach Drives to WHS.

     

    Friday, July 25, 2008 5:15 PM
  • I have been using the USB port for 7 months now with no issues.

     

    I tried using the extra port on the USB powered hub and the USB port on the front of the server; both give me the same results.

     

    Also I have used this drive on another machine to store some files, which are still present on the drive. I don't have to have the drive formatted before I add it to the server do I?

     

    Friday, July 25, 2008 5:32 PM
  • I've had the same problem with a Seagate FreeAgent Pro 1TB via USB.

     

    I just "solved" it by connecting the hard drive to another PC, converting the (empty) disk into a GBT disk (with the disk management console) and then performing a quick format.

     

    After that, the WHS recognized the external drive and let me add it.

     

    I can't tell if it was just the formatting or turning the disk into a GBT disk that helped.

     

    Friday, August 1, 2008 2:35 AM
  • Even when you get the drive working, you really should take note of the Microsoft recommendation regarding just one drive to one USB controller. The lag in trying to run multiple drives which might be reading/writing at the same time, will at some point, lead to server errors.

     

    Colin

     

    Friday, August 1, 2008 4:46 PM
  • Pls Pardon my ignorance, what is a "GBT disk"?  tried goggling with no sucess.
    Tuesday, December 1, 2009 1:16 AM
  • Pls Pardon my ignorance, what is a "GBT disk"?  tried goggling with no sucess.
    I believe he meant GPT disk.
    Tuesday, December 1, 2009 1:46 AM
    Moderator